Java JDK 11.0.2 - JDK 13 + lucee's bundled felix version does not support jrt protocol LDEV-2215

https://luceeserver.atlassian.net/browse/LDEV-2215
https://bugs.openjdk.java.net/browse/JDK-8217364.

It appears that there is currently no upgrade path for Lucee with Java JDK 11.0.2 to 13

LDEV-2215 has been set to deployed but this is not a fix beyond 11.0.1 which is a problem for deployment systems relying on the latest Java JDK for Lucee.

Seems strange that OpenJDK are not able to include the fix they have for JDK 13 with earlier versions. I shall raise this on there board.

Is there no workaround that could be applied at the Lucee end? @IamSigmund

1 Like

Hi @pat.moody. I’ll have to investigate this one. The permutations on Lucee releases and Java versions has gotten a bit more complex of late. Stay tuned. @isapir

There has been some discussion on LDEV-2215.

For the moment I’ve managed to update to the latest RC of Lucee 5.3.3.60-RC and now have it working with JDK 12.0.1 So we will stick with that and see how we get on.

1 Like