Issues with 5.4.X

Hey all,
I am testing upgrading our servers to use from I am getting a specific error relating to transforming a legacy XSL stylesheet.
lucee.runtime.exp.NativeException: org/apache/xalan/processor/TransformerFactoryImpl Caused by: java.lang.NoClassDefFoundError: org/apache/xalan/processor/TransformerFactoryImpl
I have tried adding the xalan 2.7.2 jar to the bundle (along with xerces and xml-apis that was suggested here but I am not having any luck. Any idea what changed with the new versions or what I need to do to fix this?

P.S. It seemed to have happened before

Thanks as walways!

OS: Linux
Java Version: 11.0.20

There have been a few changes to XML handling recently:

Take a look at this - it may or may not be related to your problem.

I am using an external java jar to handle the transformation instead of xmlTransform. I tried to globally set the xmlFeatures but still receive the same error. I might be able to modify that jar to contain the correct transformer? Thanks for the tips though! Going to drop the stacktrace below in case anyone else is seeing this.

lucee.runtime.exp.NativeException: org/apache/xalan/processor/TransformerFactoryImpl
	at java.base/java.lang.Class.getDeclaredMethods0(Native Method)
	at java.base/java.lang.Class.privateGetDeclaredMethods(Unknown Source)
	at java.base/java.lang.Class.privateGetPublicMethods(Unknown Source)
	at java.base/java.lang.Class.getMethods(Unknown Source)
	at lucee.runtime.reflection.Reflector.getMethodInstanceEL(
	at lucee.runtime.reflection.Reflector.getMethodInstance(
	at lucee.runtime.util.VariableUtilImpl.callFunctionWithoutNamedValues(
	at lucee.runtime.PageContextImpl.getFunction(