Installing Lucee


#1

Trying to move away from Adobe and giving Lucee a shot.
Windows installer seemed to go fine and default Lucee page shows in IIS.
However when trying to load a .cfm page get the error:

Generic Connector Communication Error:
Please check and adjust your setup:
Ensure that Tomcat is running on given host and port.
If this is a timeout error consider adjusting IIS timeout by changing executionTimeout attribute in web.config (see manual).
The source was not found, but some or all event logs could not be searched. Inaccessible logs: Security. at System.Diagnostics.EventLog.FindSourceRegistration(String source, String machineName, Boolean readOnly, Boolean wantToCreate)
at System.Diagnostics.EventLog.SourceExists(String source, String machineName, Boolean wantToCreate)
at System.Diagnostics.EventLog.SourceExists(String source)
at BonCodeIIS.BonCodeCallHandler.RecordSysEvent(String message, EventLogEntryType eType)
at BonCodeIIS.BonCodeCallHandler.ProcessRequest(HttpContext context)

Been working on this for a while with no luck…
Any thoughts?
Thanks!


#2

Hi @californiaimage and welcome to Lucee! The default Lucee page is a .cfm page so I’m not sure what you’re hitting. Have you created a new site in IIS or are you still using the default IIS site? Also, did you choose to tie Boncode to all IIS sites or a single site? There’s a lot of missing information here to know what you have going on.

To simplify your debugging, try hitting the HTTP port on Tomcat directly. You can find this in Tomcat’s server.xml file in the httplistener tag. While you’re in there, confirm the port of the AJP listener and also check to see if you have other servers installed on your machine that might be trying to use the same ports.


#3

To clarify, @bdw429s means that you try to hit a URL like http://localhost:8888/ or http://localhost:8080/ rather than the default HTTP port 80.


#4

Hmm,
I see in the Tomcat logs it shows:

2018-03-20 13:09:00 Commons Daemon procrun stderr initialized
Error opening zip file or JAR manifest missing : C:\Program Files\Lucee\lucee-inst.jar

After installing Lucee there is no .jar at that location.
Perhaps is it:

C:\Program Files\Lucee\lib\lucee-5.2.6.59.jar

Tomcat is not starting after a reboot. It was running earlier.

I had Boncode apply to all IIS sites. I created a test site in IIS to run and tried on a few other sites.

Thanks


#5

Yeah, not seen lucee-inst.jar that is called from tomcat. Cant find in the https://bitbucket.org/lucee/lucee/downloads/


#6

Lucee 5 doesn’t use that separate instrumentation jar. Can you track down where that’s coming from? Check the JVM args in catalina.bat? Just guessing at the file name. I haven’t used the standard installer in years now that I have CommandBox :slight_smile:


#7

One of the steps in the install process declared:

"C:\Program Files\Apache Software Foundation\Tomcat 9.0\bin\tomcat9.exe" //US//Tomcat9 ++JvmOptions="-javaagent:C:\Program Files\Lucee\lucee-inst.jar"

How would I undo that command?

I also checked catalina.bat and do not see that reference to lucee-inst.jar
Thanks!


#8

lucee-inst.jar is mentioned here, you said you used the installer or did you do a manual install?
http://docs.lucee.org/guides/running-lucee/windows/installing-and-configuring-lucee-jar-file-on-windows.html

the windows installer defaults to c:\lucee with everything i.e (tomcat) under that?


#9

You need to Uninstall the Service and then Reinstall it without that option. You can use Catalina.bat to remove/install the service, but I’m AFK and can’t look up the exact command ATM.


#10

@Jordan_Michaels Can you confirm, are we still including the instrumentation jar in the classpath as part of the Lucee installer? That hasn’t been needed since Lucee 5.0.0.


#11

I ran the installer, but in comparing to the manual install didnt see tomcat thus used the manual instructions. Also, see reference to the lucee-inst.jar on the last step on page:
http://docs.lucee.org/guides/running-lucee/windows/installing-and-configuring-lucee-jar-file-on-windows.html


#12

Confirmed. The Windows service that is created by the Installer uses the service.bat file in the Tomcat/bin/ folder within the Lucee directory:

This batch file can also be used to remove and re-install the Windows service if necessary.

Last, the installer uses Tomcat 8.5, as Tomcat 9 (last I heard) isn’t fully supported by Lucee yet. The fact that this install is showing Tomcat 9 illustrates that this build did not come from the Installer.

@californiaimage Try running the latest Lucee Windows Installer on a clean system and see if you have better luck.


#13

Thanks,
I didnt see reference to 8.5 being needed.
The manual approach was after trying the installer and not having luck there…


#14

Can you tell us what happened when you tried the installer?


#15

I should be more clear. Was the original error you posted the error you received just after you used the Installer, or after you modified it a bit?

If it was just after you used the Installer (without any other changes), then we can dig into that more. It looks like an issue with the BonCode Connector. So the Lucee install went fine, but connecting it to IIS did not. Can you tell us what version of Windows you’re using?


#16

@californiaimage yes, please back up and show us the steps you’ve taken. Your original post said you simply used the Windows installer, but now you’re telling us that you’ve also been making manual changes to your server following some other set of instructions? These are very important things that you have left out as they completely change how we help you. For instance, I wouldn’t have pinged Jordan if you had told me you were making manual changes that weren’t from the installer.