Installing Lucee on linux

Hi, Installing Lucee on ubuntu and also tried on CentOS.
Installation went find, but after the install I check and made sure service is also running.

But some how the cfm page never showed up on CentOS, it just keep loading… and nothing else.

In ubuntu, I was getting 502 proxy error.

Tried Ubuntu 16.04.02 x64, installation went without any error but I get 502 proxy error when try accessing page.
Tried with CentOS 7.3.1611 x64 and installtion went fine and afte that CFM page never load up.

appreciate if anyone can help.


can anyone help?
I am sure that it is connector issue, but found no article anywhere shows how to install lucee connectors manually.
would appreciate if anyone can put me to right directions.


You’d probably get more help if you put this in “support” instead of “dev”. I only noticed it out of chance.

Can you tell us how your apache config looks after you do your install? Need to verify your config was added correctly.

Also, what kind of environment are you running in? Any sort of unique virtualized environment variables we should know about? Can you hit your server on port 8888? Is Tomcat listening on port 8888?


Assuming that html pages are shown, you should check the Tomcat server.xml file
Set file path according to your system.

Edit the server.xml file:
nano /opt/lucee/tomcat/conf/server.xml

There should be an entry for your domain, e.g.:

<HOST name="" appBase="webapps">
  <Context path="" docBase="/var/www/vhosts/" />


1 Like

yes tomcat is listening on 8888 but have same issue, page never loads up.
trying to get the apache conf file from console to paste here in a min.

I pasted the above in my server.xml but still same issue, page never loads up.

do you have a link for the support forum?

here is how my apache2.conf looks like

<VirtualHost 162.2043.131.174:8080>

    DocumentRoot /home/admin/web/
    ScriptAlias /cgi-bin/ /home/admin/web/
    Alias /vstats/ /home/admin/web/
    Alias /error/ /home/admin/web/
    #SuexecUserGroup admin admin
    CustomLog /var/log/apache2/domains/ bytes
    CustomLog /var/log/apache2/domains/ combined
    ErrorLog /var/log/apache2/domains/
    <Directory /home/admin/web/>
        AllowOverride All
        Options +Includes -Indexes +ExecCGI
        php_admin_value open_basedir /home/admin/web/
        php_admin_value upload_tmp_dir /home/admin/tmp
        php_admin_value session.save_path /home/admin/tmp
    <Directory /home/admin/web/>
        AllowOverride All

    <IfModule mod_ruid2.c>
        RMode config
        RUidGid admin admin
        RGroups www-data
    <IfModule itk.c>
        AssignUserID admin admin

    IncludeOptional /home/admin/conf/web/*


and that is how my server.xml file looks like.

<?xml version='1.0' encoding='utf-8'?>
<Server port="8005" shutdown="SHUTDOWN">
  <Listener className="org.apache.catalina.startup.VersionLoggerListener" />
  <Listener className="org.apache.catalina.core.AprLifecycleListener" SSLEngine="on" />
  <Listener className="org.apache.catalina.core.JreMemoryLeakPreventionListener" />
  <Listener className="org.apache.catalina.mbeans.GlobalResourcesLifecycleListener" />
  <Listener className="org.apache.catalina.core.ThreadLocalLeakPreventionListener" />
  <Service name="Catalina">
    <Connector port="8888" protocol="HTTP/1.1"
               redirectPort="8443" />
    <Connector port="8009" protocol="AJP/1.3" redirectPort="8443" />
    <Engine name="Catalina" defaultHost="">
      <Host name=""  appBase="webapps"
            unpackWARs="true" autoDeploy="true">
        <Valve className="org.apache.catalina.valves.AccessLogValve" directory="logs"
               prefix="localhost_access_log" suffix=".txt"
               pattern="%h %l %u %t &quot;%r&quot; %s %b" />

	<!-- visit for details on mod_cfml configuration options -->
	<Valve className="mod_cfml.core"
      <!-- ADD NEW HOSTS HERE -->
<HOST name="" appBase="webapps">
  <Context path="" docBase="/home/admin/web/" />


after new install of lucee, the port 888 does show Welcome to your Lucee 5 Installation! page.
but any other cfm page call shows the following error

Tomcat Mod_CFML error
mod_cfml request authentication failed!

After rebooting the server, now I am getting the folloiwng error and 8888 is not opening.
I double checked the lucee_ctl service is running.

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /info.cfm.

Reason: Error reading from remote server

If the Lucee cfm page needs more time to show up than the Apache timeout, then the mentioned error message could appear.

Try to set a high timeout value for the mod_proxy.

Edit Apache conf, e.g.
vi /etc/httpd/conf/httpd.conf

There should be a line like

<IfModule mod_proxy.c>
  ProxyPreserveHost On

Add a timeout like

<IfModule mod_proxy.c>
  ProxyTimeout 1000
  ProxyPreserveHost On

Do a system restart.



Hi Asim,

If you get the same issue on port 8888 than it sounds like some kind of runtime error.

Check your /opt/lucee/tomcat/logs/catalina.out log and see if there are any error messages that might point us in the right direction.