Installer on Ubuntu 22.04

Hi, on a newly installed Ubuntu server I can’t get the installer to work.
Regardless of the release, I get:

./ 2: Syntax error: Unterminated quoted string

Does anyone have any ideas?

I just tried with this version in my Ubuntu server.
It works for me.

Have you assigned execution permission?
chmod +x lucee-bla-bla--

I would also try redownloading it.

Yes, I have tried both, with different versions. chmod as well.

Does this help you?

Or this:

Are you sure you are on x64 architecture?

Thank you! Its was an Arm64 architecture…
I switched to x86 and it works…


Glad you solved it and kudos to @Roberto_Marzialetti for helping guide you. And if I can offer a suggestion, folks running on arm would do well to always identify that when raising an issue like this.

I realize it’s “the norm” to be running ARM processors for those on recent macs (and some cloud architecture alternatives), but there’s still a large percentage of folks who run on non-arm systems (and not just those on Windows).

At least in indicating you’re on arm, it helps trigger our considering if that may be significant to your issue–especially if we may have “done what you did” and had “no problem”.

Sure, in time we may always keep in mind that distinction, but I don’t sense we’re there yet.

Not a sermon, just a thought. :slight_smile: