IIS, Lucee, and a very strange website


#1

I have multiple websites running on my computer, but I have one that is acting very strange.

scans.company.local
runs on http, unassigned, 80

setup just like my others except it does not act like them. For some reason, despite what I put in IIS, its trying to say its webroot is C:\inetpub\ when its really C:\inetpub\scans.company.com . Doesn’t seem to respect the physical path I put in.

Is there a place I can manually change this to get it out of this funk?


#2

Also adding to this, it is happening on all new websites. They aren’t getting WEB-INF and the lucee files, or the Lucee IIS configuration. Appears mod_cfml may have died? Any ideas how I can fix it?


#3

Have you tried a restart of IIS / iisreset?


#4

check file permissions for the path.


#5

Try removing the periods from the path. I had a problem very similar to this a long time ago, and maybe it’s still an issue in IIS.


#6

How was Lucee installed?
Using the standard installer or manually?

You may have turned off mod_cfml and at one point registered manual contexts? If so, you will have to add new sites manually as well?

Best,
Bilal


#7

Thanks. Ultimately restarting IIS worked. Not sure what caused it to go down in the first place. Think its the second time I have run into this. Fortunately I haven’t run into this on production yet.