IIS Connector

Hi guys,

I have been a ColdFusion user for years and a Lucee user where license are restricted. I have a new environment - Windows Server 2016 and I am trying to get Lucee to work through IIS (port 8009). I have done multiple clean installs, and downloaded Bilal’s most recent AJP Connector stuff, but I am still unable to get IIS to passthrough and process my cfm pages. I can see pages on port 8888 if I shove things down there - but css etc, aren’t processing. I have gone through all the online stuff I can find, and I am well and truly stuck.

Lucee 5.3.3.062 latest AJP connector from: http://www.boncode.net/boncode-connector

Thanks.

First off, install on a new box without connecting the server to ADS, if you have not done so.

Second, install with the options shown, As local Administrator,

After IIS is installed. Reboot
Next click on the severs tab and disable IE enhanced security
Now Install Lucee from the download via lucee.org using the Windows binary. Use the included IIS Installer. Run as administrator

Choose defaults and allow the installation to complete.

That is it. Now you may configure the OS to join ADs or do whatever you need to do with the box, including updates and additional IIS modules.

Great, thanks for that. After I posted this I found another post that said the .Net 3.5 Framework is required for the AJP connector, and I don’t think that is a default for the IIS install anymore on 2016 Server. So, I will try that (I didn’t have the component installation readily available so I had to go our IT crew). I will give that a try and if it still doesn’t over, then I’ll back out to clean install with your sequence.

Thanks a lot for replying. I really appreciate it.

Nope, still not working. Clean install etc. Nothing seems to be serving over 8009 even though that was left as Default.

.Net 3.5 or higher is required. 2016 has 4.6 which will be fine (worked for me on a 2016 box). Make sure you choose the .NET Extensibility feature as well.

A while ago I blogged instructions for connecting Tomcat and IIS manually using Boncode which might help:

Not sure what version of ISO you are using for your server OS, but .net 4.6 is installed by default.

Everything installed by default with the options shown (see above) installs without issue.

You should not use port 8009 to access your website

It should be

Port 80 (Full website)
Port:8888 (Just Lucee Instance of code)
You can optionally change the path of your website from INETROOT\yoursite to LUCEEINSTALL\tomcat\webapps\Root

Silly question, but did you open 8009 in your firewall? Can you telnet to it?

@kmow what I’m missing from your post is what is happening in more details when you try to access IIS port 80. Is it a simple timeout? IIS 500.xxx error?

Thanks guys. After another clean install, and some communication with our IT guys around our VM port policies - I am up and running. Thanks to everyone for the assistance. I think there was a problem on the redirect through port 80. I checked with our IT guys and there seemed to be some embarrassment there on the ports… but I am not going to Cane the poor buggers since it is now working. Thanks again to everyone for throwing in - I really appreciate it.

Geez, and now everything has fallen in a heap again. I am going to get down to bare metal and do a clean install of IIS and start from scratch. Ah well.

Unless you have a specific need to develop or use IIS, My suggestion would be to use Apache and lucee.

for straight up DEV you can use the lucee version of tomcat without incident.

Thanks Terry. I have always preferred Apache, its just the IT support crowd getting swayed by all those free Microsoft T-Shirts. All good new, brought it down and clean installed everything. Thanks again.