HTTP Status 403 – Forbidden

I am working on local setup of lucee server with apache 2.4 on windows 10 for development. I have installed latest lucee version.

I am using mod_cfml to configure it. At apache 2.4, I kept in modules file and entered following lines in httpd.conf

But i am getting following error…

There is nothing in the logs. Can any body help me to resolve this issue.

how did you obtain a windows binary for Apache 2.4.x?
did you confirm that mod_jk is in the modules directory and enabled?

in Lucee Install directory \ tomcat \ conf
make sure that server.xml

You have a directive

<Connector protocol="AJP/1.3"

Make sure the secret matches your MOD_JK config in httpd.conf

if you make any changes restart both httpd and lucee / tomcat

Could the ajp secret, aka ghostcat?

Please always mention the software versions involved!

I am using bitnami wamp stack for apache. mod_jk is not in modules directory neither in httpd.conf. Server.xml does have this directive.

First you would need a proper working copy of Apache with mod_jk if you are to get mod_jk to work.

How did you install lucee? With the installer file or did you use the express version?

I used the exe file. I am now following this to install mod_jk.

Do you have any tutorial to setup. That stack overflow answer is not working. Apache doesn’t start after including file.

I have just setup Apache2 with Windows and Tomcat Express some days ago, trying to find to issue with mod_cfml not generating the context when hitting the default page.

From what I remember, you don’t need mod_jk. mod_proxy and mod_ajp should do it. Did you comment the modules out in the httpd.conf?

I am able to resolve this by following this blog:

Exactly, but this is http proxy. That way you will need to add headers and stuff e.g. for https cgi recognition. Alternatively to mod_proxy_http, you can use mod_proxy_ajp. Then you just need to change the proxy_pass from http:// to ajp:// and the port from 8888 to 8009.

That was i tried before and it was giving me 403 error.

I will check that again if i faced any issue with this. :slight_smile:

1 Like

thats for tomcat 7, Lucee installer uses tomcat 9 which is slightly different.

Start over, delete everything

go download and install xampp

Run that
Next download

now run that.
make sure your java jdk and javare paths are set
turn off your firewall
Now go to lucee\ tomcat \ conf\ server.xml
make the following line look like this
Connector protocol=“AJP/1.3”

Save and exit
Now go to xampinstall \ apache \ conf\extra

make httpd-ajp.conf

<Proxy >
Require all granted

ProxyPreserveHost On
ProxyPassMatch ^/([cm])(/.
)?$ ajp://$1$2

comment everything else out
now start lucee
now start apache


Sure. I will try that too. :slight_smile: Does htaccess file will work with this? OR i have to write the rewrite rule in virtual host?

By default everything is ran in the main config in xamp. "httpd.conf " You would just look for Directory \xampROOTINSTALL\HTDOCS\

and put an entry in for AllowOverride All, though I believe by default it ships with this already on.

in server.xml you need to have the following…

    <Host name=""  appBase="webapps"
         unpackWARs="true" autoDeploy="true">
        <Context path="" docBase="C:/xampp/htdocs" />