How do I ENABLE Robust Exception Information? (Error: “We’re sorry - An Error Occurred”)

How do I enable Robust Exception Information?

I have no problem finding (a few) posts on how do disable it. I amazed that I can’t find anything on how to enable it.

The message “We’re sorry - An Error Occurred” comes up by default, and I need to know how do get rid of it so I can see what’s going on with my code and fix it. Reversing the instructions on the ‘disable’ posts I’ve found doesn’t seem to help.

My stack …
OS: Windows 10
Java Version: No clue
Tomcat Version: No clue
Lucee Version:

Thank you!


Lucee doesn’t really have a setting by that name. The equivalent is changing the default error page from public to secure and vice versa. Adobe has a setting to change the error page and then the “robust” setting that changes what you see on that page. Lucee just has the one setting.

If you can’t get it, please send a screenshot so we know for certain what you’re looking at.

Okay, for me it was changing both dropdown settings in “Settings / Error” from error-public.cfm to error.cfm. (There was no “secure”.) Not intuitive, but if it works, it works.

I don’t think this solution should be so hard to find, though. Not as long as there are newbies. Update the documentation?

Thanks, bdw429s!


Sorry, the “secure” word is what CFConfig uses. When you set the equiv setting via CFConfig for either Adobe CF or Lucee, the shortcut names are “default” and 'secure" and I honestly just forget that Lucee’s admin doesn’t use those words.

cfconfig set generalErrorTemplate=secure

I don’t think this solution should be so hard to find

It’s not like the setting is hidden, you just have to know it’s there :slight_smile:

Update the documentation

Please do. The docs are found here

and can be edited via pull requests on Github.

Thanks! I will … but not right now, I’m up to my … :grinning: