How do debug only 1 app?

I am on a server with many cfml apps, but I am developing in only 1 app.

Is there a way to only turn on the debug mode for for the one app i am in? I turn it on in the web or server admin and then everyone gets the debugging info.

I tried to enter my ip address and created a debug template, but that never changes anything. When working with a very old adobe coldfusion, my ip would be enough so i only see the debugging.

Also showDebugOutput does not suppress the output or change anything.

Any help would be appreciated or some documentation on debugging in lucee. Thanks.

that’s odd, which version of Lucee?

there was a bug about removing debugging via the admin not resetting the xml entry, that was fixed in 5.3.3.16 https://luceeserver.atlassian.net/browse/LDEV-2229

|Version|Lucee 5.3.2.77|
|Version Name|Gelert|
|Release date|May 27, 2019|

This was the last stable release.

wanna try updating your dev enviroment to the latest snapshot to see if it’s resolved?

Maybe it is me, not understanding templates. Tell me if i am wrong.

  1. I turn on debuging which is for all apps.
  2. I make a template and assign an ip, which i incorrectly place 127.0.0.11 (11 not 1) and it still shows the debug. How do i turn it off for all other people?



I will upgrade my dev shortly.

The problem was if you add a debug template and then remove it, the default config wasn’t restored, which is why it was still enabled despite being removed.

Can you explain in more detail and how should I fix this? Or Is there a way to add debugging to the application.cfc. I tried the ondebug and they did not produce anything.