How: Connect Lucee Express to Apache HTTP server 2.4


i have a running Lucee Express (now on If i work in Browser (latest FF or MS Edge) over URL “http://localhost:15080/myproject/” everything is fine!

My application are 2 cfm-pages.
Page 1 show <cfdump var="#session#"> and have a link to Page 2.
Page 2 show <cfdump var="#session#"> and have a link to Page 1.

Application.cfc looks like this:

<cfcomponent output="no">
<cfset				= "Hello">
<cfset THIS.sessionManagement	= true>
<cfset THIS.clientManagement		= false>
<cfset THIS.setClientCookies		= true>
<cfset this.setDomainCookies 		= false>
<cfset THIS.applicationTimeout	= CreateTimeSpan(0,8,0,0)>
<cfset THIS.sessionTimeout		= CreateTimeSpan(0,0,20,0)>

So if i spring between the two pages i get 1 Session ID (j2ee or cfml).

Now i connect my HTTP 2.4 with following lines in httpd.conf

Case 1:

ProxyPass /myapp http://localhost:15080/myproject
ProxyPassReverse /myapp http://localhost:15080/myproject

Case 2:

ProxyPass "/myapp" "ajp://"
ProxyPassReverse "/myapp" ""

Modules are activated and service restartet.

Now i go over Browser with URL: “http://localhost/myapp/

In Case 1 will get a new Session-ID every time i call a page.
In Case 2 shows error, because browser try open “localhost/myproject/”

Whats wrong.
Server.xml of tomcat has port 15079 for shutdown. Port 15080 for http connector and Port 15081 for AJP connector. That makes the installer from Lucee Express.

Help please.

My next try would be to install a freash tomcat.
put lucee.war in webapps.
connect http server over Case 1
And why? Because Lucee 4.5 works with that setup wonderful. And Lucee 5?

Try this one:

<IfModule mod_proxy.c>
        ProxyPreserveHost On
        ProxyPassMatch ^/(.+\.cf[cm])(/.*)?$$1$2
        ProxyPassMatch ^/(.+\.cfchart)(/.*)?$$1$2
        ProxyPassMatch ^/(.+\.cfml)(/.*)?$$1$2
        ProxyPassReverse /

Change with your Tomcat-IP and Port.
Than i would create a vhost and webcontext for “myapp”.

Thanks David for answer.
I tried it, but it doesn’t work.

Now i have installed a new tomcat 9 and deployed the newest Lucee WAR into it.
HEAVY ERROR in stdout.log of Tomcat.

Ok, i deinstalled, Tomcat 9 and install Tomcat 8.5. I’ve deployed newest Lucee WAR into it.
HEAVY ERROR in stdout.log of Tomcat.

I tried the previous Lucee WAR and same heavy error in staderr of tomcat.

Last but not least. I have installed the old Version and it works! No errors at start.

But my session problem is still there.


Well, I made some tests today.

Install new Apache24
Install new Tomcat9

Try some simple setups with different lucee.war files.
Find 3 bugs and reported them LDEV-1890, LDEV-1889 and LDEV-1888.

But my connection between apache and tomcat with deployed lucee.war works now.
Simply with Davids or mine solution we want to use.

Soooo what was wrong? Maybe my http server was to security “harded” or Lucee Express is not the way for me.

For me this thread can closed.