How can I Set Up Lucee CFML with Tomcat and Apache on a Ubuntu 16.04 VPS


#21

please help


#22

I have to say firstly that with a name like lixmayor (aka linux mayor), makes me giggle at your question…

How are you serving the website? through nginx or apache or direct out of tomcat? All of these instructions can be found easily by googling ‘lucee install ubuntu’ and whatever webserver you’re using.


#23

I have followed those instructions but it is still not working


#24

Oh come on, what isn’t working, can you be explicit?

Please explain the problem in depth and the steps you have already taken to investigate,

i.e. have you looked in the various logs for the webserver / tomcat / lucee?


#25

Problem isnt with Lucee…

Lix, go read this

Then this


#26

terry_whitney I have read the two tutorials and I have followed the instructions there but the website is not lunching. it is not bringing any error but when i enter the url “cdemng.org” in my browser it is still saying “This site can’t be reached cdemng.org refused to connect.” maybe there is something I don’t know or perhaps I am not getting something right


#27

Zac_Spitzer, it is not a lucee problem lucee is loading properly… In the web context at the lucee admin page the url for my website is not showing but the webroot and configuration file is showing. And for the lucee all the web context is showing i.e the Url, webroot, and configuration file


#28

Please help me guys


#29

I see that your domain is cdemng.org is pointed to 185.130.204.52

Is the service apache2 running?

sudo systemctl start apache2.service

Is the service lucee running?
sudo systemctl start lucee.service

Did you make sure your firewall has the available ports open?
a quick test would be to disable the firewall temporarily
sudo uwf disable

Are the permissions correct?
sudo chgrp -R www-data /var/www
sudo chmod -R g+rwX /var/www

Anything beyond this and just posting “please help” and as many have posted, we need details or you need to contract someone out for the services as “Please help” doesn’t help us, help you.


#30

This is the error I get when i run sudo systemctl start lucee.service

“Failed to start lucee.service: Unit lucee.service not found.”

And I have done

/opt/lucee/lucee_ctl restart

then I tried running sudo systemctl start lucee.service again Yet it is still giving the same error


#31

try
sudo service lucee_ctl restart.


#32

Still the same error. I did /opt/lucee/lucee_ctl forcequit then started the lucee again and not try the sudo systemctl start lucee.service it still brings the same error


#33

then lucee isnt properly installed.

at this point you may wish to start over.


#34

Okay thanks, I will do that now. By the way should I change the directory from /opt/lucee to /home/lucee?


#35

One cavet,

Unless you have a specific reason and or LOVE for Ubuntu, use CentOS instead

A good tutorial, that can be adapted for centos is here


#36

It is terrible advice to suggest use of CentOS without a reason for Ubuntu; I would suggest the opposite. Unless you have some fundamental need to use CentOS I would highly recommend that you use Ubuntu. Any RPM-based distribution will be more pain than it’s worth when a great deal of developers running Linux will likely know Ubuntu (and be more comfortable with Ubuntu) than CentOS.


#37

Reasons to Love Ubuntu
Its easy
lots of people think its a desktop os
lots of documentation

Reasons to dislike Ubuntu
It does not follow *NIX standardized methods
Its bleeding edge rather than tested stable
it only very recently adopted 10 year support cycle for its product line (LTS)
Even the most “Stable” versions contain long well documented bugs that require an “upgrade” to the next version of Ubuntu to “pray its fixed”
Upgrades while sometimes possible between versions are not supported and often break software
Telemetry & Bloatware - its loaded with both
Closed Source with a blatant middle finger to FOSS on several of their key technologies

Yes, I work with both, and not once I have seen anyone suggest putting a production server of anything on Ubuntu. RHEL / CENTOS is predominately used by the MIL, GOV and Industrial sectors running everything from robots to IoT sensors. I guess, being one of the many who has to support both, You can take a RHEL 5.0 image and upgrade it to 7.6 without breaking an application, where as try Ubuntu 10.04 to Ubuntu 12.04 and everything but the command line will break.

:wink: