Help installing on windows 8.1

Hi Everyone,
I am a complete newbie to Lucee. I have Cold Fusion Development Server installed on my laptop and would like to install Lucee. Would anyone be kind enough to point me in the right direction?. I downloaded the windows installer package but it stated that it couldn’t be installed on windows 8.1.
Thank you,
Paul

Don’t forget to tell us about your stack!

OS: ???
Java Version: ???
Tomcat Version: ???
Lucee Version: ???

Hi @paulw, be very welcome to our community.

It depends very much on what you want to do on your Win 8.1. If what you want is pure development that doesn’t need any fronted web server and you are comming from Adobe, I recommend command box from ortus solutions. You can easily run a Lucee Server, Adobe Server and switching between versions of both cfengines becomes a piece of pie. It comes with many tools that will make life in both worlds easier (e.g. cfconfig). You can configure lots of webroots and run it how ever you want.
If you don’t like that approach and want to use Lucee only, you can download lucees express version. It is a kind of portable tomcat version that contains Lucee. But you’ll need to have JAVA JDK (e.g. AdoptJDK) pre installed on your development machine

If you want to install it with all along with IIS webserver: I remember I was able to do some time ago without problems with the installer. Don’t know how it is right now. But I think you’ll need to enable IIS first on Wins “add features” section. But if you are just starting with Lucee to try things out, do it with Express or CommandBox.

Have a.nice day.

ok thanks andreas. I’ll try the Express or CommandBox installations. If I get stuck is it appropriate to post to the community or would that be frowned upon?

Post away, this is the Lucee support forum!

ok thanks. I feel like a fish out of water here having been used to Adobe Cold Fusion. I’ve found the CommandBox software and the Express but no documentation on how to install, configure and use.

The documentation for CommandBox is located here:
https://commandbox.ortusbooks.com/getting-started-guide

Reading through the “embedded server” section of the docs will get you up to speed on everything you need to know.

When you’re feeling good about that, check into this additional library:
https://cfconfig.ortusbooks.com/introduction/getting-started-guide

ok thanks Brad.

Have you looked at docs.lucee.org?

Thanks Zac - I’ve just resumed setting up Lucee with CommandBox so that is very helpful

Hi Brad,

I’ve encountered a problem setting up Lucee with CommandBox. The installation of CommandBox ok and then I tried to install coldbox as per the documentation. After the ColdBox installation I typed ‘start’ as per the instructions but got an error message as follows:

ERROR <5.1.1+00191> The [.env] file is missing keys from the .env example. You can populate your .env with the new settings using ‘dotenv popluate --new’

Then there is a list of missing keys. Also I can’ type anything at the command prompt as the terminal is frozen.

Any help appreciated!

Paul

Hi Brad,

Ignore previous message. The terminal unfroze and I was able to create the .env file and populate. The only issue I now have is setting the S3_REGION to the UK timezone!
Paul

@paulw The validation of missing .env properties is an optional feature of the commandbox-dotenv module. It can be turned off, or you can entirely delete the .env files if you’re not using them.

ok thanks again. I’ve now installed commandbox ok but am now a bit foxed as how to add a datasource. Is there anyway of making a datasource globally available such as with the Adobe Cold Fusion Server? Sorry if these seem quite basic questions!

You can add datasources in the admin. If this is a CommandBox server, click on the icon for the server in your system tray and click “open” > “Server admin”. You can add global datasource there for your code ot use. If you have the CFConfig module installed and there is a .cfconfig.json file in the app template, keep in mind that file will be auto-imported on every server start so delete the JSON file if you’re not using it, or export any setting changes to the JSON file with cfconfig export

ok thanks again. I’ve managed to get the server running however to access the server admin I’m being prompted to import a password.txt file. I’ve placed this in the webroot directory (c:\playground) on my pc and tried to import but no luck. The server is asking me to place the password.txt file in the lucee-server/context/ directory. However, I’m not sure how to interpret that?

You can find where the server lives by clicking the tray menu icon and clicking “open” > “Server home”. However, I would recommend completely bypassing that silliness by installing the commandbox-dotenv module and setting a global env var called cfconfig_adminPassword which will get sucked in as the default admin pass for every server you start in the future. See my answer here for more details