Header not evaluating properly in cfdocument evalatprint="true"

We have
In the
It should loop through and change values based on the query values, but it seems to only use the last value in the query.
I have tried as I had seen suggested to use evalatprint=“true” does not seem to make a difference.
the rest of the document displays properly.
If I wrap the cfdocumentitem with a cfdocumentsection, like it was in CF 11, the headers display the correct information, but the data displayed that is not in a header or footer then moves up and displays improperly.
A coworker created a workaround, but it involved setting variables to detect the space on the page and then pad the top or bottom and guess on when to create a page break.
Lucee with PDF Extension Installed version

@trevor, first of all, you should know about evalatprint is not implemented in lucee.
And could you please share any test case? if possible. It’ll help to find an issue.

simplified example: So the line in bold LOAD NO: should return on 2 pages in the case I am working on and number should be different based on the query. But it only returns the last value from the query,

The part NO in the details portion is correct. ONly seems to affect headers and footers

<cfdocument format=“pdf” Filename = “ram:///#filename#.pdf” overwrite = “yes” orientation=“landscape” marginbottom = “1.8” marginleft = “0.5” marginright = “0.5”

margintop = “#documentmargintop#” fontembed=“yes” localUrl = “yes” name = “pdfdoc”>

#getrpt.ADDRESS1# #getrpt.SHIPTO# LOAD NO: #getrpt.LOADNBR#
TARE: #NumberFormat(getrpt.STARE,"999,999")# #getrpt.STARE_UOM# #NumberFormat(getrpt.LD_TARE,"999,999")# #getrpt.LTARE_UOM#

Actually, it is. I found this out recently when the latest version of Lucee suddenly slowed down because I had that attribute in there and it had never worked until now.


I believe it was added in this ticket:


@trevor If you are reporting a bug, I would recommend doing so in JIRA as a ticket along with an executable example code.

Brad thanks,

I was able to get all but page numbers working. Looking and seems to be an issue as well.

#cfdocument.currentpagenumber# of #cfdocument.totalpagecount# does not appear to work, if you have any suggestions, let me know, please.

@bdw429s I was able to get everything working properly. Thank you.
Added the evalatprint=“true” and page numbers worked.
Since this was a fairly complicated document it took some doing to fix some other layout issues, but all good now I think.