Form enctype kills special characters


#1

My website migrated from Coldfusion on Windows to Lucee on Linux. It all looks ok to me but there is one difficulty so far:

One of the forms is used to enter various text fields plus to upload an image. The form tag carries an enctype="multipart/form-data" for that reason.

When text entered into the form contains special Umlaut characters, they get all translated into “?” on the next page. I found that this only happens when the enctype is set - when I omit the enctype from the form, the Umlauts arrive unharmed.

Is there something I can do about this?

Charset is iso-8859-1.

-Michael


#2

Hi Michael. How is the charset being specified?


#3

in Application.cfm:

<cfset setEncoding("form","ISO-8859-1")>
<cfset setEncoding("url","ISO-8859-1")> 

in the page header:

< META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1" >

#4

What’s set for the “web charset” in the application’s web context administrator (Settings > Charset)?


#5

Also check out Settings > Language/Compiler.

I usually set UTF-8 everywhere I can find it in Lucee, here and in Settings > Charset.