Express version doesn't "just run" here

Please excuse my unfamiliarity with the underpinnings of the express
version, but for me, it doesn’t “just run” (Win7 Pro). The included docs
seem to be for some of the components used, not this package as a whole,
and don’t appear to address potentially necessary configuration issues. Is
this supposed to work now?

I know it’s early, not everything is soup yet, no criticism is intended,
just want to get it running, and maybe help others who want the same. Maybe
more familiarity with this infrastructure is assumed, but ideally, anyone
could download the express package and be up and running with nothing but
the instructions provided. At minimum, if configuration or environment
setup is required, a Lucee-specific start-from-zero guide should be
provided. Better error messaging would be great too.

Here’s what happens here: When I just double click startup.bat, it just
exits, probably expected, but if so, should be documented somewhere. If I
run it from the cmd line, it reads out some environment vars, then returns
to the cmd prompt, without actually starting the Lucee engine, or
complaining about why it couldn’t, as far as I can tell. Ran the cmd prompt
as admin, no difference. The logs directory is empty.

Nothing in startup.bat appears to be machine or environment-specific, and
nothing in web.xml, context.xml, or server.xml jumped out at me as needing
to be edited.

Thanks for any thoughts, and again, my apologies for not knowing whatever
is it that probably should be obvious to folks with more Java background.
I’ve been working in CFML for many years, but clearly I’m missing some
required info, and I’m quite likely not alone in that.

Dave

Dave,

I had the same problem you did initially. I’m running on Win 8.1 and when
I tried to run startup.bat, it opened and closed. What I found out was
that I needed to have installed (I believe) JRE 1.8 and set the JAVA_HOME
env var. Once I had that installed, then I retried running the startup.bat
and it ran and opened a new command window (Tomcat) but when I looked at
the log file, there was still some problem (I believe it was a binding
issue because of how many times I had tried running the startup.bat). I
rebooted and then everything came up as it should when I ran the batch file.

Hopefully that helps.

Adam De LayOn Tuesday, February 3, 2015 at 8:16:12 AM UTC-5, Dave Merrill wrote:

Please excuse my unfamiliarity with the underpinnings of the express
version, but for me, it doesn’t “just run” (Win7 Pro). The included docs
seem to be for some of the components used, not this package as a whole,
and don’t appear to address potentially necessary configuration issues. Is
this supposed to work now?

I know it’s early, not everything is soup yet, no criticism is intended,
just want to get it running, and maybe help others who want the same. Maybe
more familiarity with this infrastructure is assumed, but ideally, anyone
could download the express package and be up and running with nothing but
the instructions provided. At minimum, if configuration or environment
setup is required, a Lucee-specific start-from-zero guide should be
provided. Better error messaging would be great too.

Here’s what happens here: When I just double click startup.bat, it just
exits, probably expected, but if so, should be documented somewhere. If I
run it from the cmd line, it reads out some environment vars, then returns
to the cmd prompt, without actually starting the Lucee engine, or
complaining about why it couldn’t, as far as I can tell. Ran the cmd prompt
as admin, no difference. The logs directory is empty.

Nothing in startup.bat appears to be machine or environment-specific, and
nothing in web.xml, context.xml, or server.xml jumped out at me as needing
to be edited.

Thanks for any thoughts, and again, my apologies for not knowing whatever
is it that probably should be obvious to folks with more Java background.
I’ve been working in CFML for many years, but clearly I’m missing some
required info, and I’m quite likely not alone in that.

Dave

I have Java 1.7 installed, and the system environment var JAVA_HOME points
to it.

  • Does Lucee actually require 1.8? Where are the system requirements
    documented?

  • Do I need to set JAVA_HOME somewhere in the Lucee startup script or
    configs, or is the system var sufficient?

DaveOn Tuesday, February 3, 2015 at 8:58:49 AM UTC-5, Adam De Lay wrote:

Dave,

I had the same problem you did initially. I’m running on Win 8.1 and when
I tried to run startup.bat, it opened and closed. What I found out was
that I needed to have installed (I believe) JRE 1.8 and set the JAVA_HOME
env var. Once I had that installed, then I retried running the startup.bat
and it ran and opened a new command window (Tomcat) but when I looked at
the log file, there was still some problem (I believe it was a binding
issue because of how many times I had tried running the startup.bat). I
rebooted and then everything came up as it should when I ran the batch file.

Hopefully that helps.

Adam De Lay

On Tuesday, February 3, 2015 at 8:16:12 AM UTC-5, Dave Merrill wrote:

Please excuse my unfamiliarity with the underpinnings of the express
version, but for me, it doesn’t “just run” (Win7 Pro). The included docs
seem to be for some of the components used, not this package as a whole,
and don’t appear to address potentially necessary configuration issues. Is
this supposed to work now?

I know it’s early, not everything is soup yet, no criticism is intended,
just want to get it running, and maybe help others who want the same. Maybe
more familiarity with this infrastructure is assumed, but ideally, anyone
could download the express package and be up and running with nothing but
the instructions provided. At minimum, if configuration or environment
setup is required, a Lucee-specific start-from-zero guide should be
provided. Better error messaging would be great too.

Here’s what happens here: When I just double click startup.bat, it just
exits, probably expected, but if so, should be documented somewhere. If I
run it from the cmd line, it reads out some environment vars, then returns
to the cmd prompt, without actually starting the Lucee engine, or
complaining about why it couldn’t, as far as I can tell. Ran the cmd prompt
as admin, no difference. The logs directory is empty.

Nothing in startup.bat appears to be machine or environment-specific, and
nothing in web.xml, context.xml, or server.xml jumped out at me as needing
to be edited.

Thanks for any thoughts, and again, my apologies for not knowing whatever
is it that probably should be obvious to folks with more Java background.
I’ve been working in CFML for many years, but clearly I’m missing some
required info, and I’m quite likely not alone in that.

Dave

Sorry to state what might sound obvious but is there anything running on
that port? Not sure what port the express version is running on but from
your post that sounds like the issue.

Andrew PenhorwoodOn Tuesday, February 3, 2015 at 8:16:12 AM UTC-5, Dave Merrill wrote:

Please excuse my unfamiliarity with the underpinnings of the express
version, but for me, it doesn’t “just run” (Win7 Pro). The included docs
seem to be for some of the components used, not this package as a whole,
and don’t appear to address potentially necessary configuration issues. Is
this supposed to work now?

I know it’s early, not everything is soup yet, no criticism is intended,
just want to get it running, and maybe help others who want the same. Maybe
more familiarity with this infrastructure is assumed, but ideally, anyone
could download the express package and be up and running with nothing but
the instructions provided. At minimum, if configuration or environment
setup is required, a Lucee-specific start-from-zero guide should be
provided. Better error messaging would be great too.

Here’s what happens here: When I just double click startup.bat, it just
exits, probably expected, but if so, should be documented somewhere. If I
run it from the cmd line, it reads out some environment vars, then returns
to the cmd prompt, without actually starting the Lucee engine, or
complaining about why it couldn’t, as far as I can tell. Ran the cmd prompt
as admin, no difference. The logs directory is empty.

Nothing in startup.bat appears to be machine or environment-specific, and
nothing in web.xml, context.xml, or server.xml jumped out at me as needing
to be edited.

Thanks for any thoughts, and again, my apologies for not knowing whatever
is it that probably should be obvious to folks with more Java background.
I’ve been working in CFML for many years, but clearly I’m missing some
required info, and I’m quite likely not alone in that.

Dave

I blogged my experiences getting it working:


(I did not have the same issue as mentioned here, that said).

It’d be really good if other ppl could also blog their mission so there’s
more links back to Lucee, plus more material for people in future to find
if/when they run into problems.–
Adam

On 3 February 2015 at 13:58, Adam De Lay <@Adam_De_Lay> wrote:

Dave,

I had the same problem you did initially. I’m running on Win 8.1 and when
I tried to run startup.bat, it opened and closed. What I found out was
that I needed to have installed (I believe) JRE 1.8 and set the JAVA_HOME
env var. Once I had that installed, then I retried running the startup.bat
and it ran and opened a new command window (Tomcat) but when I looked at
the log file, there was still some problem (I believe it was a binding
issue because of how many times I had tried running the startup.bat). I
rebooted and then everything came up as it should when I ran the batch file.

Hopefully that helps.

Adam De Lay

On Tuesday, February 3, 2015 at 8:16:12 AM UTC-5, Dave Merrill wrote:

Please excuse my unfamiliarity with the underpinnings of the express
version, but for me, it doesn’t “just run” (Win7 Pro). The included docs
seem to be for some of the components used, not this package as a whole,
and don’t appear to address potentially necessary configuration issues. Is
this supposed to work now?

I know it’s early, not everything is soup yet, no criticism is intended,
just want to get it running, and maybe help others who want the same. Maybe
more familiarity with this infrastructure is assumed, but ideally, anyone
could download the express package and be up and running with nothing but
the instructions provided. At minimum, if configuration or environment
setup is required, a Lucee-specific start-from-zero guide should be
provided. Better error messaging would be great too.

Here’s what happens here: When I just double click startup.bat, it just
exits, probably expected, but if so, should be documented somewhere. If I
run it from the cmd line, it reads out some environment vars, then returns
to the cmd prompt, without actually starting the Lucee engine, or
complaining about why it couldn’t, as far as I can tell. Ran the cmd prompt
as admin, no difference. The logs directory is empty.

Nothing in startup.bat appears to be machine or environment-specific, and
nothing in web.xml, context.xml, or server.xml jumped out at me as needing
to be edited.

Thanks for any thoughts, and again, my apologies for not knowing whatever
is it that probably should be obvious to folks with more Java background.
I’ve been working in CFML for many years, but clearly I’m missing some
required info, and I’m quite likely not alone in that.

Dave


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/fceb57bc-d224-45fd-9eff-7cf04d89aff5%40googlegroups.com
https://groups.google.com/d/msgid/lucee/fceb57bc-d224-45fd-9eff-7cf04d89aff5%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

Thanks for jumping in Micah.

It just penetrated that you said there needs to be a JRE installed, which
there is, but the system var JAVA_HOME points to a 1.7 JDK.

  • Will a JDK work?
  • Will 1.7 work?
  • If I need to point to a JRE, or install a different Java version and
    point to it, where should I set JAVA_HOME so Lucee will see it, without
    changing the system var other things are looking at?

Thanks, and apologies for this low-level trivia.

DaveOn Tuesday, February 3, 2015 at 9:30:22 AM UTC-5, Micha wrote:

We did the Express Version completely new with Tomcat and we no longer
provide the JRE version, so a JRE version need to be installed and
JAVA_HOME need to be set.
We will shortly add more details to the wiki about all bundles we provide,
we will also look into it, to provide a better experience in case it does
not work.

Micha

On Tue, Feb 3, 2015 at 3:02 PM, Adam Cameron <dac...@gmail.com <javascript:>> wrote:

I blogged my experiences getting it working:
http://blog.adamcameron.me/2015/02/lucee-hiccups-when-getting-new-express.html
(I did not have the same issue as mentioned here, that said).

It’d be really good if other ppl could also blog their mission so there’s
more links back to Lucee, plus more material for people in future to find
if/when they run into problems.


Adam

On 3 February 2015 at 13:58, Adam De Lay <adam.n...@gmail.com <javascript:>> wrote:

Dave,

I had the same problem you did initially. I’m running on Win 8.1 and
when I tried to run startup.bat, it opened and closed. What I found out
was that I needed to have installed (I believe) JRE 1.8 and set the
JAVA_HOME env var. Once I had that installed, then I retried running the
startup.bat and it ran and opened a new command window (Tomcat) but when I
looked at the log file, there was still some problem (I believe it was a
binding issue because of how many times I had tried running the
startup.bat). I rebooted and then everything came up as it should when I
ran the batch file.

Hopefully that helps.

Adam De Lay

On Tuesday, February 3, 2015 at 8:16:12 AM UTC-5, Dave Merrill wrote:

Please excuse my unfamiliarity with the underpinnings of the express
version, but for me, it doesn’t “just run” (Win7 Pro). The included docs
seem to be for some of the components used, not this package as a whole,
and don’t appear to address potentially necessary configuration issues. Is
this supposed to work now?

I know it’s early, not everything is soup yet, no criticism is
intended, just want to get it running, and maybe help others who want the
same. Maybe more familiarity with this infrastructure is assumed, but
ideally, anyone could download the express package and be up and running
with nothing but the instructions provided. At minimum, if configuration or
environment setup is required, a Lucee-specific start-from-zero guide
should be provided. Better error messaging would be great too.

Here’s what happens here: When I just double click startup.bat, it just
exits, probably expected, but if so, should be documented somewhere. If I
run it from the cmd line, it reads out some environment vars, then returns
to the cmd prompt, without actually starting the Lucee engine, or
complaining about why it couldn’t, as far as I can tell. Ran the cmd prompt
as admin, no difference. The logs directory is empty.

Nothing in startup.bat appears to be machine or environment-specific,
and nothing in web.xml, context.xml, or server.xml jumped out at me as
needing to be edited.

Thanks for any thoughts, and again, my apologies for not knowing
whatever is it that probably should be obvious to folks with more Java
background. I’ve been working in CFML for many years, but clearly I’m
missing some required info, and I’m quite likely not alone in that.

Dave


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com
<javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/fceb57bc-d224-45fd-9eff-7cf04d89aff5%40googlegroups.com
https://groups.google.com/d/msgid/lucee/fceb57bc-d224-45fd-9eff-7cf04d89aff5%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com <javascript:>
.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/CAFwR%2BKc1ZnsPBrRL5w0ZTYbGwwHz_fUO0Ri58kDHK1FKSweYXQ%40mail.gmail.com
https://groups.google.com/d/msgid/lucee/CAFwR%2BKc1ZnsPBrRL5w0ZTYbGwwHz_fUO0Ri58kDHK1FKSweYXQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

We did the Express Version completely new with Tomcat and we no longer
provide the JRE version, so a JRE version need to be installed and
JAVA_HOME need to be set.
We will shortly add more details to the wiki about all bundles we provide,
we will also look into it, to provide a better experience in case it does
not work.

MichaOn Tue, Feb 3, 2015 at 3:02 PM, Adam Cameron <@Adam_Cameron1> wrote:

I blogged my experiences getting it working:
http://blog.adamcameron.me/2015/02/lucee-hiccups-when-getting-new-express.html
(I did not have the same issue as mentioned here, that said).

It’d be really good if other ppl could also blog their mission so there’s
more links back to Lucee, plus more material for people in future to find
if/when they run into problems.


Adam

On 3 February 2015 at 13:58, Adam De Lay <@Adam_De_Lay> wrote:

Dave,

I had the same problem you did initially. I’m running on Win 8.1 and
when I tried to run startup.bat, it opened and closed. What I found out
was that I needed to have installed (I believe) JRE 1.8 and set the
JAVA_HOME env var. Once I had that installed, then I retried running the
startup.bat and it ran and opened a new command window (Tomcat) but when I
looked at the log file, there was still some problem (I believe it was a
binding issue because of how many times I had tried running the
startup.bat). I rebooted and then everything came up as it should when I
ran the batch file.

Hopefully that helps.

Adam De Lay

On Tuesday, February 3, 2015 at 8:16:12 AM UTC-5, Dave Merrill wrote:

Please excuse my unfamiliarity with the underpinnings of the express
version, but for me, it doesn’t “just run” (Win7 Pro). The included docs
seem to be for some of the components used, not this package as a whole,
and don’t appear to address potentially necessary configuration issues. Is
this supposed to work now?

I know it’s early, not everything is soup yet, no criticism is intended,
just want to get it running, and maybe help others who want the same. Maybe
more familiarity with this infrastructure is assumed, but ideally, anyone
could download the express package and be up and running with nothing but
the instructions provided. At minimum, if configuration or environment
setup is required, a Lucee-specific start-from-zero guide should be
provided. Better error messaging would be great too.

Here’s what happens here: When I just double click startup.bat, it just
exits, probably expected, but if so, should be documented somewhere. If I
run it from the cmd line, it reads out some environment vars, then returns
to the cmd prompt, without actually starting the Lucee engine, or
complaining about why it couldn’t, as far as I can tell. Ran the cmd prompt
as admin, no difference. The logs directory is empty.

Nothing in startup.bat appears to be machine or environment-specific,
and nothing in web.xml, context.xml, or server.xml jumped out at me as
needing to be edited.

Thanks for any thoughts, and again, my apologies for not knowing
whatever is it that probably should be obvious to folks with more Java
background. I’ve been working in CFML for many years, but clearly I’m
missing some required info, and I’m quite likely not alone in that.

Dave


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/fceb57bc-d224-45fd-9eff-7cf04d89aff5%40googlegroups.com
https://groups.google.com/d/msgid/lucee/fceb57bc-d224-45fd-9eff-7cf04d89aff5%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/CAFwR%2BKc1ZnsPBrRL5w0ZTYbGwwHz_fUO0Ri58kDHK1FKSweYXQ%40mail.gmail.com
https://groups.google.com/d/msgid/lucee/CAFwR%2BKc1ZnsPBrRL5w0ZTYbGwwHz_fUO0Ri58kDHK1FKSweYXQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

To partially close the loop in this: After reading another thread about
JRE_HOME, I set JRE_HOME to point to the JRE inside the same JDK 1.7 that
the JAVA_HOME system var points to, and everything works now. Prior to
that, I didn’t get any errors or warnings mentioning JRE_HOME, just a dump .

I’m not sure if this is the right solution or not, given that Micha has
said (I think) that something needs to be fixed for that build on Windows,
but if you have htis issue and need to get running, it worked for me.

DaveOn Tuesday, February 3, 2015 at 4:37:17 PM UTC-5, Scott Busche wrote:

Dave:

1: You can add a local variable at the top of the batch file as you
suggested
set JAVA_HOME=/PathToJava1.8/
2: JDK has a JRE, so yes.
3: If changing to 1.8 causes the program to start, it would appear so, if
it still doesn’t work then continue debugging until it’s working, once it
is, switch back to 1.7 and see if it still works and report back. :slight_smile:

On Tuesday, February 3, 2015 at 1:23:46 PM UTC-6, Dave Merrill wrote:

Thanks for jumping in Chester, glad you got your system sorted. However,
as noted above, for other reasons “I have Java 1.7 installed, and the
system environment var JAVA_HOME points to it.” I don’t want to change the
global environment var, that will affect other projects.

So:

  • Where can I set JAVA_HOME in the Lucee scripts, so it affects only
    Lucee?
  • The existing var points to a JDK. Will that work, or is a JRE is needed
    instead?
  • Will Java 1.7 work, or is 1.8 required?

Thanks to anyone who can point me in some useful directions.

Dave

On Tuesday, February 3, 2015 at 2:11:28 PM UTC-5, Chester Austin wrote:

I’ve been following this thread since I had the same issue Dave
originally had. I happend to have JRE 1.8 installed, so the next logical
question would be “What do I do this with this information?” The answer
would be to create a system variable that points to the JRE path.

Using this as a guide,
https://confluence.atlassian.com/display/DOC/Setting+the+JAVA_HOME+Variable+in+Windows,
here are the steps:

  1. Create a New System Variable, since, obviously, there isn’t one
    (or else it would work?). In Windows, at least, it’s under the Advanced tab
    of Properties.
  2. New variable name JAVA_HOME with the path to the JRE, usually
    under “C:\Program Files (x86)\Java”
  3. Once done, run the startup.bat (double click); a command prompt
    pops up and another window with Tomcat starts running.
  4. Go to http://localhost:8888/ in browser, and viola, it runs!

On Tuesday, February 3, 2015 at 7:41:28 AM UTC-8, Dave Merrill wrote:

Thanks for jumping in Micah.

It just penetrated that you said there needs to be a JRE installed,
which there is, but the system var JAVA_HOME points to a 1.7 JDK.

  • Will a JDK work?
  • Will 1.7 work?
  • If I need to point to a JRE, or install a different Java version and
    point to it, where should I set JAVA_HOME so Lucee will see it, without
    changing the system var other things are looking at?

Thanks, and apologies for this low-level trivia.

Dave

On Tuesday, February 3, 2015 at 9:30:22 AM UTC-5, Micha wrote:

We did the Express Version completely new with Tomcat and we no longer
provide the JRE version, so a JRE version need to be installed and
JAVA_HOME need to be set.
We will shortly add more details to the wiki about all bundles we
provide, we will also look into it, to provide a better experience in case
it does not work.

Micha

On Tue, Feb 3, 2015 at 3:02 PM, Adam Cameron dac...@gmail.com wrote:

I blogged my experiences getting it working:
http://blog.adamcameron.me/2015/02/lucee-hiccups-when-getting-new-express.html
(I did not have the same issue as mentioned here, that said).

It’d be really good if other ppl could also blog their mission so
there’s more links back to Lucee, plus more material for people in future
to find if/when they run into problems.


Adam

On 3 February 2015 at 13:58, Adam De Lay adam.n...@gmail.com wrote:

Dave,

I had the same problem you did initially. I’m running on Win 8.1
and when I tried to run startup.bat, it opened and closed. What I found
out was that I needed to have installed (I believe) JRE 1.8 and set the
JAVA_HOME env var. Once I had that installed, then I retried running the
startup.bat and it ran and opened a new command window (Tomcat) but when I
looked at the log file, there was still some problem (I believe it was a
binding issue because of how many times I had tried running the
startup.bat). I rebooted and then everything came up as it should when I
ran the batch file.

Hopefully that helps.

Adam De Lay

On Tuesday, February 3, 2015 at 8:16:12 AM UTC-5, Dave Merrill wrote:

Please excuse my unfamiliarity with the underpinnings of the
express version, but for me, it doesn’t “just run” (Win7 Pro). The included
docs seem to be for some of the components used, not this package as a
whole, and don’t appear to address potentially necessary configuration
issues. Is this supposed to work now?

I know it’s early, not everything is soup yet, no criticism is
intended, just want to get it running, and maybe help others who want the
same. Maybe more familiarity with this infrastructure is assumed, but
ideally, anyone could download the express package and be up and running
with nothing but the instructions provided. At minimum, if configuration or
environment setup is required, a Lucee-specific start-from-zero guide
should be provided. Better error messaging would be great too.

Here’s what happens here: When I just double click startup.bat, it
just exits, probably expected, but if so, should be documented somewhere.
If I run it from the cmd line, it reads out some environment vars, then
returns to the cmd prompt, without actually starting the Lucee engine, or
complaining about why it couldn’t, as far as I can tell. Ran the cmd prompt
as admin, no difference. The logs directory is empty.

Nothing in startup.bat appears to be machine or
environment-specific, and nothing in web.xml, context.xml, or server.xml
jumped out at me as needing to be edited.

Thanks for any thoughts, and again, my apologies for not knowing
whatever is it that probably should be obvious to folks with more Java
background. I’ve been working in CFML for many years, but clearly I’m
missing some required info, and I’m quite likely not alone in that.

Dave


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it,
send an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/fceb57bc-d224-45fd-9eff-7cf04d89aff5%40googlegroups.com
https://groups.google.com/d/msgid/lucee/fceb57bc-d224-45fd-9eff-7cf04d89aff5%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it,
send an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/CAFwR%2BKc1ZnsPBrRL5w0ZTYbGwwHz_fUO0Ri58kDHK1FKSweYXQ%40mail.gmail.com
https://groups.google.com/d/msgid/lucee/CAFwR%2BKc1ZnsPBrRL5w0ZTYbGwwHz_fUO0Ri58kDHK1FKSweYXQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

yes, “Unsupported major.minor version 51.0” is a Java version. 51 is
Java 7.

Lucee does not require Java 8 to run, no.

what do you see if you go to a command line and you run the following
two commands:

echo %JAVA_HOME%

java -version

?On 2/3/2015 7:27 AM, Dave Merrill wrote:

Thanks Mark, that was at least partially helpful. I did see an error
running it that way, which I’ll try to retype here; tried to pipe the
result to a file, but it just echoed the environment vars, not the error.

Exception in thread “main” java.lang.UnsupportedClassVersionErrror:
org/apache/catalina/startup/Bootstrap : Unsupported major.minor
version 51.0
Could not find the main class org.apache.catalina.startup.Bootstrap.
Program will exit.

Is this about supported Java versions? If so, and I need to install
Java 1.8, but don’t want to change the system environment var, where
should I set JAVA_HOME so Luceee sees it? Directly in startup.bat?
Some config?

Thanks again,
Dave

On Tuesday, February 3, 2015 at 9:36:18 AM UTC-5, Mark Drew wrote:

Hi Dave

In the command line do the following

> cd lucee
> cd bin
> catalina.bat run 

That should give you all the output 

otherwise just open up lucee/logs/catalina.out and that will tell
you what is happening at startup

Regards

Mark Drew
On 3 Feb 2015, at 14:33, Dave Merrill <enig...@gmail.com <javascript:>> wrote:

I have Java 1.7 installed, and the system environment var
JAVA_HOME points to it.

- Does Lucee actually require 1.8? Where are the system
requirements documented?

- Do I need to set JAVA_HOME somewhere in the Lucee startup
script or configs, or is the system var sufficient?

Dave

On Tuesday, February 3, 2015 at 8:58:49 AM UTC-5, Adam De Lay wrote:

    Dave,

    I had the same problem you did initially.  I'm running on Win
    8.1 and when I tried to run startup.bat, it opened and
    closed.  What I found out was that I needed to have installed
    (I believe) JRE 1.8 and set the JAVA_HOME env var.  Once I
    had that installed, then I retried running the startup.bat
    and it ran and opened a new command window (Tomcat) but when
    I looked at the log file, there was still some problem (I
    believe it was a binding issue because of how many times I
    had tried running the startup.bat).  I rebooted and then
    everything came up as it should when I ran the batch file.

    Hopefully that helps.

    Adam De Lay

    On Tuesday, February 3, 2015 at 8:16:12 AM UTC-5, Dave Merrill wrote:

        Please excuse my unfamiliarity with the underpinnings of
        the express version, but for me, it doesn't "just run"
        (Win7 Pro). The included docs seem to be for some of the
        components used, not this package as a whole, and don't
        appear to address potentially necessary configuration
        issues. Is this supposed to work now?

        I know it's early, not everything is soup yet, no
        criticism is intended, just want to get it running, and
        maybe help others who want the same. Maybe more
        familiarity with this infrastructure is assumed, but
        ideally, anyone could download the express package and be
        up and running with nothing but the instructions
        provided. At minimum, if configuration or environment
        setup is required, a Lucee-specific start-from-zero guide
        should be provided. Better error messaging would be great
        too.

        Here's what happens here: When I just double click
        startup.bat, it just exits, probably expected, but if so,
        should be documented somewhere. If I run it from the cmd
        line, it reads out some environment vars, then returns to
        the cmd prompt, without actually starting the Lucee
        engine, or complaining about why it couldn't, as far as I
        can tell. Ran the cmd prompt as admin, no difference. The
        logs directory is empty.

        Nothing in startup.bat appears to be machine or
        environment-specific, and nothing in web.xml,
        context.xml, or server.xml jumped out at me as needing to
        be edited. 

        Thanks for any thoughts, and again, my apologies for not
        knowing whatever is it that probably should be obvious to
        folks with more Java background. I've been working in
        CFML for many years, but clearly I'm missing some
        required info, and I'm quite likely not alone in that.

        Dave


-- 
You received this message because you are subscribed to the
Google Groups "Lucee" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com
<javascript:>.
To view this discussion on the web
visit https://groups.google.com/d/msgid/lucee/b1da3fb3-65f0-47ba-b76c-c9ec783c370c%40googlegroups.com
<https://groups.google.com/d/msgid/lucee/b1da3fb3-65f0-47ba-b76c-c9ec783c370c%40googlegroups.com?utm_medium=email&utm_source=footer>.
For more options, visit https://groups.google.com/d/optout
<https://groups.google.com/d/optout>.


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to lucee+unsubscribe@googlegroups.com
mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com
mailto:lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/577801b5-7e60-4ec4-85a2-427dd114f8f2%40googlegroups.com
https://groups.google.com/d/msgid/lucee/577801b5-7e60-4ec4-85a2-427dd114f8f2%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

Railo is working with Java 6 (1.6), 7 (1.7), 8 (1.8)

MichaAm Mittwoch, 4. Februar 2015 schrieb Dave Merrill :

To partially close the loop in this: After reading another thread about
JRE_HOME, I set JRE_HOME to point to the JRE inside the same JDK 1.7 that
the JAVA_HOME system var points to, and everything works now. Prior to
that, I didn’t get any errors or warnings mentioning JRE_HOME, just a dump .

I’m not sure if this is the right solution or not, given that Micha has
said (I think) that something needs to be fixed for that build on Windows,
but if you have htis issue and need to get running, it worked for me.

Dave

On Tuesday, February 3, 2015 at 4:37:17 PM UTC-5, Scott Busche wrote:

Dave:

1: You can add a local variable at the top of the batch file as you
suggested
set JAVA_HOME=/PathToJava1.8/
2: JDK has a JRE, so yes.
3: If changing to 1.8 causes the program to start, it would appear so, if
it still doesn’t work then continue debugging until it’s working, once it
is, switch back to 1.7 and see if it still works and report back. :slight_smile:

On Tuesday, February 3, 2015 at 1:23:46 PM UTC-6, Dave Merrill wrote:

Thanks for jumping in Chester, glad you got your system sorted. However,
as noted above, for other reasons “I have Java 1.7 installed, and the
system environment var JAVA_HOME points to it.” I don’t want to change the
global environment var, that will affect other projects.

So:

  • Where can I set JAVA_HOME in the Lucee scripts, so it affects only
    Lucee?
  • The existing var points to a JDK. Will that work, or is a JRE is
    needed instead?
  • Will Java 1.7 work, or is 1.8 required?

Thanks to anyone who can point me in some useful directions.

Dave

On Tuesday, February 3, 2015 at 2:11:28 PM UTC-5, Chester Austin wrote:

I’ve been following this thread since I had the same issue Dave
originally had. I happend to have JRE 1.8 installed, so the next logical
question would be “What do I do this with this information?” The answer
would be to create a system variable that points to the JRE path.

Using this as a guide, https://confluence.atlassian.
com/display/DOC/Setting+the+JAVA_HOME+Variable+in+Windows, here are
the steps:

  1. Create a New System Variable, since, obviously, there isn’t one
    (or else it would work?). In Windows, at least, it’s under the Advanced tab
    of Properties.
  2. New variable name JAVA_HOME with the path to the JRE, usually
    under “C:\Program Files (x86)\Java”
  3. Once done, run the startup.bat (double click); a command prompt
    pops up and another window with Tomcat starts running.
  4. Go to http://localhost:8888/ in browser, and viola, it runs!

On Tuesday, February 3, 2015 at 7:41:28 AM UTC-8, Dave Merrill wrote:

Thanks for jumping in Micah.

It just penetrated that you said there needs to be a JRE installed,
which there is, but the system var JAVA_HOME points to a 1.7 JDK.

  • Will a JDK work?
  • Will 1.7 work?
  • If I need to point to a JRE, or install a different Java version and
    point to it, where should I set JAVA_HOME so Lucee will see it, without
    changing the system var other things are looking at?

Thanks, and apologies for this low-level trivia.

Dave

On Tuesday, February 3, 2015 at 9:30:22 AM UTC-5, Micha wrote:

We did the Express Version completely new with Tomcat and we no
longer provide the JRE version, so a JRE version need to be installed and
JAVA_HOME need to be set.
We will shortly add more details to the wiki about all bundles we
provide, we will also look into it, to provide a better experience in case
it does not work.

Micha

On Tue, Feb 3, 2015 at 3:02 PM, Adam Cameron dac...@gmail.com wrote:

I blogged my experiences getting it working: http://blog.
adamcameron.me/2015/02/lucee-hiccups-when-getting-new-express.html
(I did not have the same issue as mentioned here, that said).

It’d be really good if other ppl could also blog their mission so
there’s more links back to Lucee, plus more material for people in future
to find if/when they run into problems.


Adam

On 3 February 2015 at 13:58, Adam De Lay adam.n...@gmail.com wrote:

Dave,

I had the same problem you did initially. I’m running on Win 8.1
and when I tried to run startup.bat, it opened and closed. What I found
out was that I needed to have installed (I believe) JRE 1.8 and set the
JAVA_HOME env var. Once I had that installed, then I retried running the
startup.bat and it ran and opened a new command window (Tomcat) but when I
looked at the log file, there was still some problem (I believe it was a
binding issue because of how many times I had tried running the
startup.bat). I rebooted and then everything came up as it should when I
ran the batch file.

Hopefully that helps.

Adam De Lay

On Tuesday, February 3, 2015 at 8:16:12 AM UTC-5, Dave Merrill wrote:

Please excuse my unfamiliarity with the underpinnings of the
express version, but for me, it doesn’t “just run” (Win7 Pro). The included
docs seem to be for some of the components used, not this package as a
whole, and don’t appear to address potentially necessary configuration
issues. Is this supposed to work now?

I know it’s early, not everything is soup yet, no criticism is
intended, just want to get it running, and maybe help others who want the
same. Maybe more familiarity with this infrastructure is assumed, but
ideally, anyone could download the express package and be up and running
with nothing but the instructions provided. At minimum, if configuration or
environment setup is required, a Lucee-specific start-from-zero guide
should be provided. Better error messaging would be great too.

Here’s what happens here: When I just double click startup.bat, it
just exits, probably expected, but if so, should be documented somewhere.
If I run it from the cmd line, it reads out some environment vars, then
returns to the cmd prompt, without actually starting the Lucee engine, or
complaining about why it couldn’t, as far as I can tell. Ran the cmd prompt
as admin, no difference. The logs directory is empty.

Nothing in startup.bat appears to be machine or
environment-specific, and nothing in web.xml, context.xml, or server.xml
jumped out at me as needing to be edited.

Thanks for any thoughts, and again, my apologies for not knowing
whatever is it that probably should be obvious to folks with more Java
background. I’ve been working in CFML for many years, but clearly I’m
missing some required info, and I’m quite likely not alone in that.

Dave


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it,
send an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/fceb57bc-d224-
45fd-9eff-7cf04d89aff5%40googlegroups.com
https://groups.google.com/d/msgid/lucee/fceb57bc-d224-45fd-9eff-7cf04d89aff5%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it,
send an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/CAFwR%
2BKc1ZnsPBrRL5w0ZTYbGwwHz_fUO0Ri58kDHK1FKSweYXQ%40mail.gmail.com
https://groups.google.com/d/msgid/lucee/CAFwR%2BKc1ZnsPBrRL5w0ZTYbGwwHz_fUO0Ri58kDHK1FKSweYXQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com
<javascript:_e(%7B%7D,‘cvml’,‘lucee%2Bunsubscribe@googlegroups.com’);>.
To post to this group, send email to lucee@googlegroups.com
<javascript:_e(%7B%7D,‘cvml’,‘lucee@googlegroups.com’);>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/27704f4d-95a8-444d-9c31-793ead39a4ee%40googlegroups.com
https://groups.google.com/d/msgid/lucee/27704f4d-95a8-444d-9c31-793ead39a4ee%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

Windows users, after doing some checking on tomcat config files, all that’s
really needed is to edit the setclasspath.bat file in the lucee/bin
directory,

rem---------------------------------------------------------------------------
rem Set JAVA_HOME or JRE_HOME if not already set, ensure any provided
settings
rem are valid and consistent with the selected start-up options and set up
the
rem endorsed directory.
rem

set JRE_HOME=D:\Java\jdk1.7\jre
set JDK_HOME=D:\Java\jdk1.7

my JDK just happens to be on drive D so adjust accordingly–duh,

if you install a jdk it also installs a jre–see above, sounds like tomcat
uses the jre if both are specified
it uses jdk for debugging? Seldom used?

So in other words you can use a jre that came with railo/jetty express,
drop it wherever and point to it in the setclasspath.bat file

no need to set environment variables windows.

Yes, the jetty version never needed that to define java_home, when Java is
installed you simply can do “java …” Because it is in the path.
Tomcat express has to learn that lesson, I’m also considering doing version
that bundle the jre, that way the environment does not matter…Am Mittwoch, 4. Februar 2015 schrieb Dave Merrill :

Micha, just to clarify, in this quote from you in the JDK_HOME thread: “I
just did and we will improve that build asap. Problems seems only to happe
n in windows”, it seemed you were saying that people shouldn’t need to set
JDK_HOME like I did. I’m asking so other people with similar issues in the
future who find this thread can know what to do.

My understanding as of now is that:
a) If you do have JAVA_HOME pointing to a valid JDK of a supported version
and still have this problem, try setting JDK_HOME in startup.bat
b) There will be a new build at some point that will make that step
unnecessary

Is that right?

Dave

On Wednesday, February 4, 2015 at 7:48:00 AM UTC-5, Micha wrote:

Railo is working with Java 6 (1.6), 7 (1.7), 8 (1.8)

Micha

Am Mittwoch, 4. Februar 2015 schrieb Dave Merrill :

To partially close the loop in this: After reading another thread about
JRE_HOME, I set JRE_HOME to point to the JRE inside the same JDK 1.7 that
the JAVA_HOME system var points to, and everything works now. Prior to
that, I didn’t get any errors or warnings mentioning JRE_HOME, just a dump .

I’m not sure if this is the right solution or not, given that Micha has
said (I think) that something needs to be fixed for that build on Windows,
but if you have htis issue and need to get running, it worked for me.

Dave


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com
<javascript:_e(%7B%7D,‘cvml’,‘lucee%2Bunsubscribe@googlegroups.com’);>.
To post to this group, send email to lucee@googlegroups.com
<javascript:_e(%7B%7D,‘cvml’,‘lucee@googlegroups.com’);>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/472e3ff4-1e20-4b04-8842-f90a4b3c5401%40googlegroups.com
https://groups.google.com/d/msgid/lucee/472e3ff4-1e20-4b04-8842-f90a4b3c5401%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

Thanks for jumping in Igal.

Echoing JAVA_HOME, it points to a Java 1.7 JDK, valid and used by multiple
ACF and Railo instances on this box without problems. Java version reported
is 1.7.0_75, which as I understand it is fine.

I’m sorry guys (not you specifically Igal), but these various responses are
still totally unclear to me. On one level it doesn’t matter to me, since
I’m up and running after setting JDK_HOME in startup.bat and shutdown.bat,
but in terms of making it clear to others with similar problems what they
should do, we’re not there yet.

To quote myself, this is my as-yet-unconfirmed-by-the-community hypothesis:

a) If you do have JAVA_HOME pointing to a valid JDK with a supported
version and still have this problem, try setting JDK_HOME in startup.bat
(and shutdown.bat)
b) There will be a new build at some point that will make that step
unnecessary

Is that right?

I’m not trying to be difficult, or critical of anyone, just trying to leave
clear, unambiguous info for anyone who just wants this to work.

Thanks,
DaveOn Wednesday, February 4, 2015 at 6:46:32 PM UTC-5, igal wrote:

yes, “Unsupported major.minor version 51.0” is a Java version. 51 is
Java 7.

Lucee does not require Java 8 to run, no.

what do you see if you go to a command line and you run the following two
commands:

echo %JAVA_HOME%

java -version

?

On 2/3/2015 7:27 AM, Dave Merrill wrote:

Thanks Mark, that was at least partially helpful. I did see an error
running it that way, which I’ll try to retype here; tried to pipe the
result to a file, but it just echoed the environment vars, not the error.

Exception in thread “main” java.lang.UnsupportedClassVersionErrror:
org/apache/catalina/startup/Bootstrap : Unsupported major.minor version 51.0
Could not find the main class org.apache.catalina.startup.Bootstrap.
Program will exit.

Is this about supported Java versions? If so, and I need to install Java
1.8, but don’t want to change the system environment var, where should I
set JAVA_HOME so Luceee sees it? Directly in startup.bat? Some config?

Thanks again,
Dave

On Tuesday, February 3, 2015 at 9:36:18 AM UTC-5, Mark Drew wrote:

Hi Dave

In the command line do the following

cd lucee
cd bin
catalina.bat run

That should give you all the output

otherwise just open up lucee/logs/catalina.out and that will tell you
what is happening at startup

Regards

Mark Drew

On 3 Feb 2015, at 14:33, Dave Merrill enig...@gmail.com wrote:

I have Java 1.7 installed, and the system environment var JAVA_HOME
points to it.

  • Does Lucee actually require 1.8? Where are the system requirements
    documented?

  • Do I need to set JAVA_HOME somewhere in the Lucee startup script or
    configs, or is the system var sufficient?

Dave

On Tuesday, February 3, 2015 at 8:58:49 AM UTC-5, Adam De Lay wrote:

Dave,

I had the same problem you did initially. I’m running on Win 8.1 and
when I tried to run startup.bat, it opened and closed. What I found out
was that I needed to have installed (I believe) JRE 1.8 and set the
JAVA_HOME env var. Once I had that installed, then I retried running the
startup.bat and it ran and opened a new command window (Tomcat) but when I
looked at the log file, there was still some problem (I believe it was a
binding issue because of how many times I had tried running the
startup.bat). I rebooted and then everything came up as it should when I
ran the batch file.

Hopefully that helps.

Adam De Lay

On Tuesday, February 3, 2015 at 8:16:12 AM UTC-5, Dave Merrill wrote:

Please excuse my unfamiliarity with the underpinnings of the express
version, but for me, it doesn’t “just run” (Win7 Pro). The included docs
seem to be for some of the components used, not this package as a whole,
and don’t appear to address potentially necessary configuration issues. Is
this supposed to work now?

I know it’s early, not everything is soup yet, no criticism is
intended, just want to get it running, and maybe help others who want the
same. Maybe more familiarity with this infrastructure is assumed, but
ideally, anyone could download the express package and be up and running
with nothing but the instructions provided. At minimum, if configuration or
environment setup is required, a Lucee-specific start-from-zero guide
should be provided. Better error messaging would be great too.

Here’s what happens here: When I just double click startup.bat, it just
exits, probably expected, but if so, should be documented somewhere. If I
run it from the cmd line, it reads out some environment vars, then returns
to the cmd prompt, without actually starting the Lucee engine, or
complaining about why it couldn’t, as far as I can tell. Ran the cmd prompt
as admin, no difference. The logs directory is empty.

Nothing in startup.bat appears to be machine or environment-specific,
and nothing in web.xml, context.xml, or server.xml jumped out at me as
needing to be edited.

Thanks for any thoughts, and again, my apologies for not knowing
whatever is it that probably should be obvious to folks with more Java
background. I’ve been working in CFML for many years, but clearly I’m
missing some required info, and I’m quite likely not alone in that.

Dave


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/b1da3fb3-65f0-47ba-b76c-c9ec783c370c%40googlegroups.com
https://groups.google.com/d/msgid/lucee/b1da3fb3-65f0-47ba-b76c-c9ec783c370c%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/577801b5-7e60-4ec4-85a2-427dd114f8f2%40googlegroups.com
https://groups.google.com/d/msgid/lucee/577801b5-7e60-4ec4-85a2-427dd114f8f2%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

Things sound amazing here. Struggles yes but awesome seems to be crawling from the results.

Why did they switch from jetty to tomcat?

O.K. when you installed jdk did you also install the public jre? If so
everything should have worked fine,
if you did not install the public jre there still is a jre in the jdk
folder,
tomcat needs to be pointed to that jre, like I posted earlier which seems
to be the correct way after checking with some tomcat forums.

http://www.codejava.net/servers/tomcat/4-ways-to-change-jre-for-tomcatOn Thursday, February 5, 2015 at 5:55:33 AM UTC-6, Dave Merrill wrote:

Thanks for jumping in Igal.

Echoing JAVA_HOME, it points to a Java 1.7 JDK, valid and used by multiple
ACF and Railo instances on this box without problems. Java version reported
is 1.7.0_75, which as I understand it is fine.

I’m sorry guys (not you specifically Igal), but these various responses
are still totally unclear to me. On one level it doesn’t matter to me,
since I’m up and running after setting JDK_HOME in startup.bat and
shutdown.bat, but in terms of making it clear to others with similar
problems what they should do, we’re not there yet.

To quote myself, this is my as-yet-unconfirmed-by-the-community hypothesis:

a) If you do have JAVA_HOME pointing to a valid JDK with a supported
version and still have this problem, try setting JDK_HOME in startup.bat
(and shutdown.bat)
b) There will be a new build at some point that will make that step
unnecessary

Is that right?

I’m not trying to be difficult, or critical of anyone, just trying to
leave clear, unambiguous info for anyone who just wants this to work.

Thanks,
Dave

On Wednesday, February 4, 2015 at 6:46:32 PM UTC-5, igal wrote:

yes, “Unsupported major.minor version 51.0” is a Java version. 51 is
Java 7.

Lucee does not require Java 8 to run, no.

what do you see if you go to a command line and you run the following two
commands:

echo %JAVA_HOME%

java -version

?

On 2/3/2015 7:27 AM, Dave Merrill wrote:

Thanks Mark, that was at least partially helpful. I did see an error
running it that way, which I’ll try to retype here; tried to pipe the
result to a file, but it just echoed the environment vars, not the error.

Exception in thread “main” java.lang.UnsupportedClassVersionErrror:
org/apache/catalina/startup/Bootstrap : Unsupported major.minor version 51.0
Could not find the main class org.apache.catalina.startup.Bootstrap.
Program will exit.

Is this about supported Java versions? If so, and I need to install Java
1.8, but don’t want to change the system environment var, where should I
set JAVA_HOME so Luceee sees it? Directly in startup.bat? Some config?

Thanks again,
Dave

On Tuesday, February 3, 2015 at 9:36:18 AM UTC-5, Mark Drew wrote:

Hi Dave

In the command line do the following

cd lucee
cd bin
catalina.bat run

That should give you all the output

otherwise just open up lucee/logs/catalina.out and that will tell you
what is happening at startup

Regards

Mark Drew

On 3 Feb 2015, at 14:33, Dave Merrill enig...@gmail.com wrote:

I have Java 1.7 installed, and the system environment var JAVA_HOME
points to it.

  • Does Lucee actually require 1.8? Where are the system requirements
    documented?

  • Do I need to set JAVA_HOME somewhere in the Lucee startup script or
    configs, or is the system var sufficient?

Dave

On Tuesday, February 3, 2015 at 8:58:49 AM UTC-5, Adam De Lay wrote:

Dave,

I had the same problem you did initially. I’m running on Win 8.1 and
when I tried to run startup.bat, it opened and closed. What I found out
was that I needed to have installed (I believe) JRE 1.8 and set the
JAVA_HOME env var. Once I had that installed, then I retried running the
startup.bat and it ran and opened a new command window (Tomcat) but when I
looked at the log file, there was still some problem (I believe it was a
binding issue because of how many times I had tried running the
startup.bat). I rebooted and then everything came up as it should when I
ran the batch file.

Hopefully that helps.

Adam De Lay

On Tuesday, February 3, 2015 at 8:16:12 AM UTC-5, Dave Merrill wrote:

Please excuse my unfamiliarity with the underpinnings of the express
version, but for me, it doesn’t “just run” (Win7 Pro). The included docs
seem to be for some of the components used, not this package as a whole,
and don’t appear to address potentially necessary configuration issues. Is
this supposed to work now?

I know it’s early, not everything is soup yet, no criticism is
intended, just want to get it running, and maybe help others who want the
same. Maybe more familiarity with this infrastructure is assumed, but
ideally, anyone could download the express package and be up and running
with nothing but the instructions provided. At minimum, if configuration or
environment setup is required, a Lucee-specific start-from-zero guide
should be provided. Better error messaging would be great too.

Here’s what happens here: When I just double click startup.bat, it
just exits, probably expected, but if so, should be documented somewhere.
If I run it from the cmd line, it reads out some environment vars, then
returns to the cmd prompt, without actually starting the Lucee engine, or
complaining about why it couldn’t, as far as I can tell. Ran the cmd prompt
as admin, no difference. The logs directory is empty.

Nothing in startup.bat appears to be machine or environment-specific,
and nothing in web.xml, context.xml, or server.xml jumped out at me as
needing to be edited.

Thanks for any thoughts, and again, my apologies for not knowing
whatever is it that probably should be obvious to folks with more Java
background. I’ve been working in CFML for many years, but clearly I’m
missing some required info, and I’m quite likely not alone in that.

Dave


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/b1da3fb3-65f0-47ba-b76c-c9ec783c370c%40googlegroups.com
https://groups.google.com/d/msgid/lucee/b1da3fb3-65f0-47ba-b76c-c9ec783c370c%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/577801b5-7e60-4ec4-85a2-427dd114f8f2%40googlegroups.com
https://groups.google.com/d/msgid/lucee/577801b5-7e60-4ec4-85a2-427dd114f8f2%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

Yes, the JDK that the system JAVA_HOME var points to contains a JRE. I’ve
also tried pointing JAVA_HOME directly at the jre dir, in startup.bat, no
joy. Only thing that has worked so far is setting JRE_HOME to point there,
in startup.bat.

Just to note, the system environment var JAVA_HOME already points to the
same JDK, and works for other apps.

DaveOn Thursday, February 5, 2015 at 10:49:26 PM UTC-5, mmm mmm wrote:

O.K. when you installed jdk did you also install the public jre? If so
everything should have worked fine,
if you did not install the public jre there still is a jre in the jdk
folder,
tomcat needs to be pointed to that jre, like I posted earlier which seems
to be the correct way after checking with some tomcat forums.

http://www.codejava.net/servers/tomcat/4-ways-to-change-jre-for-tomcat

On Thursday, February 5, 2015 at 5:55:33 AM UTC-6, Dave Merrill wrote:

Thanks for jumping in Igal.

Echoing JAVA_HOME, it points to a Java 1.7 JDK, valid and used by
multiple ACF and Railo instances on this box without problems. Java version
reported is 1.7.0_75, which as I understand it is fine.

I’m sorry guys (not you specifically Igal), but these various responses
are still totally unclear to me. On one level it doesn’t matter to me,
since I’m up and running after setting JDK_HOME in startup.bat and
shutdown.bat, but in terms of making it clear to others with similar
problems what they should do, we’re not there yet.

To quote myself, this is my as-yet-unconfirmed-by-the-community
hypothesis:

a) If you do have JAVA_HOME pointing to a valid JDK with a supported
version and still have this problem, try setting JDK_HOME in startup.bat
(and shutdown.bat)
b) There will be a new build at some point that will make that step
unnecessary

Is that right?

I’m not trying to be difficult, or critical of anyone, just trying to
leave clear, unambiguous info for anyone who just wants this to work.

Thanks,
Dave

On Wednesday, February 4, 2015 at 6:46:32 PM UTC-5, igal wrote:

yes, “Unsupported major.minor version 51.0” is a Java version. 51 is
Java 7.

Lucee does not require Java 8 to run, no.

what do you see if you go to a command line and you run the following
two commands:

echo %JAVA_HOME%

java -version

?

On 2/3/2015 7:27 AM, Dave Merrill wrote:

Thanks Mark, that was at least partially helpful. I did see an error
running it that way, which I’ll try to retype here; tried to pipe the
result to a file, but it just echoed the environment vars, not the error.

Exception in thread “main” java.lang.UnsupportedClassVersionErrror:
org/apache/catalina/startup/Bootstrap : Unsupported major.minor version 51.0
Could not find the main class org.apache.catalina.startup.Bootstrap.
Program will exit.

Is this about supported Java versions? If so, and I need to install Java
1.8, but don’t want to change the system environment var, where should I
set JAVA_HOME so Luceee sees it? Directly in startup.bat? Some config?

Thanks again,
Dave

On Tuesday, February 3, 2015 at 9:36:18 AM UTC-5, Mark Drew wrote:

Hi Dave

In the command line do the following

cd lucee
cd bin
catalina.bat run

That should give you all the output

otherwise just open up lucee/logs/catalina.out and that will tell you
what is happening at startup

Regards

Mark Drew

On 3 Feb 2015, at 14:33, Dave Merrill enig...@gmail.com wrote:

I have Java 1.7 installed, and the system environment var JAVA_HOME
points to it.

  • Does Lucee actually require 1.8? Where are the system requirements
    documented?

  • Do I need to set JAVA_HOME somewhere in the Lucee startup script or
    configs, or is the system var sufficient?

Dave

On Tuesday, February 3, 2015 at 8:58:49 AM UTC-5, Adam De Lay wrote:

Dave,

I had the same problem you did initially. I’m running on Win 8.1
and when I tried to run startup.bat, it opened and closed. What I found
out was that I needed to have installed (I believe) JRE 1.8 and set the
JAVA_HOME env var. Once I had that installed, then I retried running the
startup.bat and it ran and opened a new command window (Tomcat) but when I
looked at the log file, there was still some problem (I believe it was a
binding issue because of how many times I had tried running the
startup.bat). I rebooted and then everything came up as it should when I
ran the batch file.

Hopefully that helps.

Adam De Lay

On Tuesday, February 3, 2015 at 8:16:12 AM UTC-5, Dave Merrill wrote:

Please excuse my unfamiliarity with the underpinnings of the express
version, but for me, it doesn’t “just run” (Win7 Pro). The included docs
seem to be for some of the components used, not this package as a whole,
and don’t appear to address potentially necessary configuration issues. Is
this supposed to work now?

I know it’s early, not everything is soup yet, no criticism is
intended, just want to get it running, and maybe help others who want the
same. Maybe more familiarity with this infrastructure is assumed, but
ideally, anyone could download the express package and be up and running
with nothing but the instructions provided. At minimum, if configuration or
environment setup is required, a Lucee-specific start-from-zero guide
should be provided. Better error messaging would be great too.

Here’s what happens here: When I just double click startup.bat, it
just exits, probably expected, but if so, should be documented somewhere.
If I run it from the cmd line, it reads out some environment vars, then
returns to the cmd prompt, without actually starting the Lucee engine, or
complaining about why it couldn’t, as far as I can tell. Ran the cmd prompt
as admin, no difference. The logs directory is empty.

Nothing in startup.bat appears to be machine or environment-specific,
and nothing in web.xml, context.xml, or server.xml jumped out at me as
needing to be edited.

Thanks for any thoughts, and again, my apologies for not knowing
whatever is it that probably should be obvious to folks with more Java
background. I’ve been working in CFML for many years, but clearly I’m
missing some required info, and I’m quite likely not alone in that.

Dave


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/b1da3fb3-65f0-47ba-b76c-c9ec783c370c%40googlegroups.com
https://groups.google.com/d/msgid/lucee/b1da3fb3-65f0-47ba-b76c-c9ec783c370c%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/577801b5-7e60-4ec4-85a2-427dd114f8f2%40googlegroups.com
https://groups.google.com/d/msgid/lucee/577801b5-7e60-4ec4-85a2-427dd114f8f2%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

Ease of support of one servlet engine vs another. Lots of clarifications always start with “what servlet engine are you running?”

Mark Drew> On 6 Feb 2015, at 03:49, mmm mmm <@mark> wrote:

Why did they switch from jetty to tomcat?

O.K. when you installed jdk did you also install the public jre? If so everything should have worked fine,
if you did not install the public jre there still is a jre in the jdk folder,
tomcat needs to be pointed to that jre, like I posted earlier which seems to be the correct way after checking with some tomcat forums.

http://www.codejava.net/servers/tomcat/4-ways-to-change-jre-for-tomcat

On Thursday, February 5, 2015 at 5:55:33 AM UTC-6, Dave Merrill wrote:
Thanks for jumping in Igal.

Echoing JAVA_HOME, it points to a Java 1.7 JDK, valid and used by multiple ACF and Railo instances on this box without problems. Java version reported is 1.7.0_75, which as I understand it is fine.

I’m sorry guys (not you specifically Igal), but these various responses are still totally unclear to me. On one level it doesn’t matter to me, since I’m up and running after setting JDK_HOME in startup.bat and shutdown.bat, but in terms of making it clear to others with similar problems what they should do, we’re not there yet.

To quote myself, this is my as-yet-unconfirmed-by-the-community hypothesis:

a) If you do have JAVA_HOME pointing to a valid JDK with a supported version and still have this problem, try setting JDK_HOME in startup.bat (and shutdown.bat)
b) There will be a new build at some point that will make that step unnecessary

Is that right?

I’m not trying to be difficult, or critical of anyone, just trying to leave clear, unambiguous info for anyone who just wants this to work.

Thanks,
Dave

On Wednesday, February 4, 2015 at 6:46:32 PM UTC-5, igal wrote:
yes, “Unsupported major.minor version 51.0” is a Java version. 51 is Java 7.

Lucee does not require Java 8 to run, no.

what do you see if you go to a command line and you run the following two commands:

echo %JAVA_HOME%

java -version

?

On 2/3/2015 7:27 AM, Dave Merrill wrote:
Thanks Mark, that was at least partially helpful. I did see an error running it that way, which I’ll try to retype here; tried to pipe the result to a file, but it just echoed the environment vars, not the error.

Exception in thread “main” java.lang.UnsupportedClassVersionErrror: org/apache/catalina/startup/Bootstrap : Unsupported major.minor version 51.0
Could not find the main class org.apache.catalina.startup.Bootstrap. Program will exit.

Is this about supported Java versions? If so, and I need to install Java 1.8, but don’t want to change the system environment var, where should I set JAVA_HOME so Luceee sees it? Directly in startup.bat? Some config?

Thanks again,
Dave

On Tuesday, February 3, 2015 at 9:36:18 AM UTC-5, Mark Drew wrote:
Hi Dave

In the command line do the following

cd lucee
cd bin
catalina.bat run

That should give you all the output

otherwise just open up lucee/logs/catalina.out and that will tell you what is happening at startup

Regards

Mark Drew

On 3 Feb 2015, at 14:33, Dave Merrill enig...@gmail.com wrote:

I have Java 1.7 installed, and the system environment var JAVA_HOME points to it.

  • Does Lucee actually require 1.8? Where are the system requirements documented?

  • Do I need to set JAVA_HOME somewhere in the Lucee startup script or configs, or is the system var sufficient?

Dave

On Tuesday, February 3, 2015 at 8:58:49 AM UTC-5, Adam De Lay wrote:
Dave,

I had the same problem you did initially. I’m running on Win 8.1 and when I tried to run startup.bat, it opened and closed. What I found out was that I needed to have installed (I believe) JRE 1.8 and set the JAVA_HOME env var. Once I had that installed, then I retried running the startup.bat and it ran and opened a new command window (Tomcat) but when I looked at the log file, there was still some problem (I believe it was a binding issue because of how many times I had tried running the startup.bat). I rebooted and then everything came up as it should when I ran the batch file.

Hopefully that helps.

Adam De Lay

On Tuesday, February 3, 2015 at 8:16:12 AM UTC-5, Dave Merrill wrote:
Please excuse my unfamiliarity with the underpinnings of the express version, but for me, it doesn’t “just run” (Win7 Pro). The included docs seem to be for some of the components used, not this package as a whole, and don’t appear to address potentially necessary configuration issues. Is this supposed to work now?

I know it’s early, not everything is soup yet, no criticism is intended, just want to get it running, and maybe help others who want the same. Maybe more familiarity with this infrastructure is assumed, but ideally, anyone could download the express package and be up and running with nothing but the instructions provided. At minimum, if configuration or environment setup is required, a Lucee-specific start-from-zero guide should be provided. Better error messaging would be great too.

Here’s what happens here: When I just double click startup.bat, it just exits, probably expected, but if so, should be documented somewhere. If I run it from the cmd line, it reads out some environment vars, then returns to the cmd prompt, without actually starting the Lucee engine, or complaining about why it couldn’t, as far as I can tell. Ran the cmd prompt as admin, no difference. The logs directory is empty.

Nothing in startup.bat appears to be machine or environment-specific, and nothing in web.xml, context.xml, or server.xml jumped out at me as needing to be edited.

Thanks for any thoughts, and again, my apologies for not knowing whatever is it that probably should be obvious to folks with more Java background. I’ve been working in CFML for many years, but clearly I’m missing some required info, and I’m quite likely not alone in that.

Dave


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/b1da3fb3-65f0-47ba-b76c-c9ec783c370c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/577801b5-7e60-4ec4-85a2-427dd114f8f2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/85cfb3c6-5eef-40e0-b9c0-b3c11df80c19%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Another issue on another platform:

I was trying to use the express version on a macbook running 10.9. After installing the current JRE, I tried to “just run” the startup.sh to no success. I followed Mark’s directions to get debug information and found this:

web1:bin bobd$ ./catalina.sh run
Using CATALINA_BASE: /Users/bobd/downloads/lucee-4
Using CATALINA_HOME: /Users/bobd/downloads/lucee-4
Using CATALINA_TMPDIR: /Users/bobd/downloads/lucee-4/temp
Using JRE_HOME: /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
Using CLASSPATH: /Users/bobd/downloads/lucee-4/bin/bootstrap.jar:/Users/bobd/downloads/lucee-4/bin/tomcat-juli.jar
Exception in thread “main” java.lang.UnsupportedClassVersionError: org/apache/catalina/startup/Bootstrap : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

I’ve been spoiled by railo and was thrilled to do the lucee jar drop on my test server, but really wanted to have the server running on this machine. I guess I can go back and find an OS X railo installer but would like to get things working and help to clarify things more.

bobOn Feb 7, 2015, at 6:15 PM, Igal @ Lucee.org <@Igal> wrote:

Dave,

maybe a clarification of the process will help. it’s all very simple stuff, really.

every Java Runtime Environment (JRE) ships with an executable program named “java” (e.g. java.exe in Windows). in order to run a Java program, like Catalina in this case (which is the servlet container component of Tomcat, that in turn runs Lucee), you need to call the java executable and point to the java program’s main entry point. (a slight variation when running as a service, where you reference the jvm.dll as opposed to the java executable).

so now the paths come into play.

most batch (and shell) scripts that ship with java programs don’t know where the JRE/bin is installed, so it’s become the standard way of using environment variables like JAVA_HOME (points to the JDK) and JRE_HOME (points to… well… the JRE). then the script does something like that (pseudo-cfscript-code):

if (fileExists("#JRE_HOME#/bin/java.exe"))
bin = “#JRE_HOME#/bin”;
else if (fileExists("#JAVA_HOME#/jre/bin/java.exe"))
bin = “#JAVA_HOME#/jre/bin”;
else {

echo("The JRE_HOME environment variable is not defined correctly. This environment variable is needed to run this program");
abort;

}

execute “#bin#/java” args;

so in your case modifying the batch script and removing “directory” prefix before the “java” call would have been sufficient.

if we need to improve the scripts, we will do it as soon as possible once we find the problems (user reporting is the best way for us to find problems).

HTH,

Igal

p.s. if you have the JRE’s bin directory in your system classpath, you can simply call “java”, as you did when you tried “java -version” and got the JRE to report its version (if you hadn’t had the bin directory in your system classpath you would have gotten an error).

On 2/6/2015 4:33 AM, Dave Merrill wrote:

Yes, the JDK that the system JAVA_HOME var points to contains a JRE. I’ve also tried pointing JAVA_HOME directly at the jre dir, in startup.bat, no joy. Only thing that has worked so far is setting JRE_HOME to point there, in startup.bat.

Just to note, the system environment var JAVA_HOME already points to the same JDK, and works for other apps.

Dave

On Thursday, February 5, 2015 at 10:49:26 PM UTC-5, mmm mmm wrote:
O.K. when you installed jdk did you also install the public jre? If so everything should have worked fine,
if you did not install the public jre there still is a jre in the jdk folder,
tomcat needs to be pointed to that jre, like I posted earlier which seems to be the correct way after checking with some tomcat forums.

http://www.codejava.net/servers/tomcat/4-ways-to-change-jre-for-tomcat

On Thursday, February 5, 2015 at 5:55:33 AM UTC-6, Dave Merrill wrote:
Thanks for jumping in Igal.

Echoing JAVA_HOME, it points to a Java 1.7 JDK, valid and used by multiple ACF and Railo instances on this box without problems. Java version reported is 1.7.0_75, which as I understand it is fine.

I’m sorry guys (not you specifically Igal), but these various responses are still totally unclear to me. On one level it doesn’t matter to me, since I’m up and running after setting JDK_HOME in startup.bat and shutdown.bat, but in terms of making it clear to others with similar problems what they should do, we’re not there yet.

To quote myself, this is my as-yet-unconfirmed-by-the-community hypothesis:
a) If you do have JAVA_HOME pointing to a valid JDK with a supported version and still have this problem, try setting JDK_HOME in startup.bat (and shutdown.bat)
b) There will be a new build at some point that will make that step unnecessary

Is that right?

I’m not trying to be difficult, or critical of anyone, just trying to leave clear, unambiguous info for anyone who just wants this to work.

Thanks,
Dave

On Wednesday, February 4, 2015 at 6:46:32 PM UTC-5, igal wrote:
yes, “Unsupported major.minor version 51.0” is a Java version. 51 is Java 7.

Lucee does not require Java 8 to run, no.

what do you see if you go to a command line and you run the following two commands:

echo %JAVA_HOME%

java -version

?

On 2/3/2015 7:27 AM, Dave Merrill wrote:

Thanks Mark, that was at least partially helpful. I did see an error running it that way, which I’ll try to retype here; tried to pipe the result to a file, but it just echoed the environment vars, not the error.

Exception in thread “main” java.lang.UnsupportedClassVersionErrror: org/apache/catalina/startup/Bootstrap : Unsupported major.minor version 51.0
Could not find the main class org.apache.catalina.startup.Bootstrap. Program will exit.

Is this about supported Java versions? If so, and I need to install Java 1.8, but don’t want to change the system environment var, where should I set JAVA_HOME so Luceee sees it? Directly in startup.bat? Some config?

Thanks again,
Dave

On Tuesday, February 3, 2015 at 9:36:18 AM UTC-5, Mark Drew wrote:
Hi Dave

In the command line do the following

cd lucee
cd bin
catalina.bat run

That should give you all the output

otherwise just open up lucee/logs/catalina.out and that will tell you what is happening at startup

Regards

Mark Drew

On 3 Feb 2015, at 14:33, Dave Merrill enig...@gmail.com wrote:

I have Java 1.7 installed, and the system environment var JAVA_HOME points to it.

  • Does Lucee actually require 1.8? Where are the system requirements documented?

  • Do I need to set JAVA_HOME somewhere in the Lucee startup script or configs, or is the system var sufficient?

Dave

On Tuesday, February 3, 2015 at 8:58:49 AM UTC-5, Adam De Lay wrote:
Dave,

I had the same problem you did initially. I’m running on Win 8.1 and when I tried to run startup.bat, it opened and closed. What I found out was that I needed to have installed (I believe) JRE 1.8 and set the JAVA_HOME env var. Once I had that installed, then I retried running the startup.bat and it ran and opened a new command window (Tomcat) but when I looked at the log file, there was still some problem (I believe it was a binding issue because of how many times I had tried running the startup.bat). I rebooted and then everything came up as it should when I ran the batch file.

Hopefully that helps.

Adam De Lay

On Tuesday, February 3, 2015 at 8:16:12 AM UTC-5, Dave Merrill wrote:
Please excuse my unfamiliarity with the underpinnings of the express version, but for me, it doesn’t “just run” (Win7 Pro). The included docs seem to be for some of the components used, not this package as a whole, and don’t appear to address potentially necessary configuration issues. Is this supposed to work now?

I know it’s early, not everything is soup yet, no criticism is intended, just want to get it running, and maybe help others who want the same. Maybe more familiarity with this infrastructure is assumed, but ideally, anyone could download the express package and be up and running with nothing but the instructions provided. At minimum, if configuration or environment setup is required, a Lucee-specific start-from-zero guide should be provided. Better error messaging would be great too.

Here’s what happens here: When I just double click startup.bat, it just exits, probably expected, but if so, should be documented somewhere. If I run it from the cmd line, it reads out some environment vars, then returns to the cmd prompt, without actually starting the Lucee engine, or complaining about why it couldn’t, as far as I can tell. Ran the cmd prompt as admin, no difference. The logs directory is empty.

Nothing in startup.bat appears to be machine or environment-specific, and nothing in web.xml, context.xml, or server.xml jumped out at me as needing to be edited.

Thanks for any thoughts, and again, my apologies for not knowing whatever is it that probably should be obvious to folks with more Java background. I’ve been working in CFML for many years, but clearly I’m missing some required info, and I’m quite likely not alone in that.

Dave


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/b1da3fb3-65f0-47ba-b76c-c9ec783c370c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/577801b5-7e60-4ec4-85a2-427dd114f8f2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/f582db63-eb8f-4621-9484-5efa4d5a61e7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/54D6AA9B.5080100%40lucee.org.
For more options, visit https://groups.google.com/d/optout.

Sean,

Thanks for the info. Unfortunately, it seems harder to get rid of/override java 6 in 10.9 than I figured. Tried following Oracle’s Directions, but didn’t seem to do enough. I will get back to this sometime, but had to give up and get some actual work done.

I’m glad the issue is not on the lucee side, that’s for sure. Of course, this doesn’t mean I won’t stop hating dealing with Java configs on client machines!

bobOn Feb 7, 2015, at 9:15 PM, Sean Herrala <@Sean_Herrala> wrote:

export JRE_HOME="/usr/libexec/java_home -v '1.8*'"


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/8b8ac4c1-6aa3-4019-993f-f26f7a923344%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Kai,

Thanks for the quick reply. I hadn’t been concerned about the java version because I DID download and install the current java. Even checking the java system pref reports I’m current at 8 r31. But the JRE_HOME still shows 1.6.0. Even tried manually exporting the variable with no luck.

Continuing the search for fixing the variable….

bobOn Feb 7, 2015, at 7:02 PM, Kai Koenig <@Kai_Koenig> wrote:

The issue is that your system is running a Java 6 JDK:

Using JRE_HOME: /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home

But the Tomcat bootstrap application requires Java 7 (51.0 is Java 7):

Exception in thread “main” java.lang.UnsupportedClassVersionError: org/apache/catalina/startup/Bootstrap : Unsupported major.minor version 51.0

Easiest solution for your case would be to install Java 7 or 8 on your Mac and set JRE_HOME to the appropriate directory.

Cheers
Kai


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/B61CC47D-0251-4BBD-A4CB-548F16B10F26%40gmail.com.
For more options, visit https://groups.google.com/d/optout.