Error when upgrading to MySQL Extension 6.0.5


#1

I upgraded to Lucee 5.2.3.35 and also upgraded to MySQL Extension 6.0.5.

This changes my datasource type to “Other - JDBC Driver (deprecated)”. When I try to verify the datasources, I get the following error message:

The server time zone value ‘EDT’ is unrecognized or represents more than one time zone. You must configure either the server or JDBC driver (via the serverTimezone configuration property) to use a more specifc time zone value if you want to utilize time zone support.

I can workaround by downgrading the MySQL Extension to 5.1.38 and checking that the data-source class is set to “org.gjt.mm.mysql.Driver”


#2

It seems not safe to update to the MySQL Extension 6.0.5, 5.1.20. I got the same behaviour. The datasource type was changed to “Other - JDBC Driver (deprecated)”. The connections were still working but new connections couldn’t be created. By switching the MySQL driver to 5.1.38 in Extension - Applications the type column in Services - Datasource showed again “MySQL” and new MySQL datasource connections can be created.


#3

I have the same problem

The server time zone value ‘CEST’ is unrecognized or represents more than one time zone. You must configure either the server or JDBC driver (via the serverTimezone configuration property) to use a more specifc time zone value if you want to utilize time zone support.

any solution for this??


#4

Just downgrade to the 5.1.x version of the extension until the issues with 6.x are fixed.


#5

Hi Andri - I could add datasources again after setting MySQL server (which was apparently “CEST” as well) to UTC, using this command:
SET @@global.time_zone = “+00:00”;

However, I had other issues (using Lucee for Mura CMS) and downgraded MySQL Connector again from within Lucee Server Admin and re-added all datasources in Lucee Web Admin.
Seems like the MySQL connector 6.0.5 is only for the upcoming MySQL version 6 (currently in Alpha), why this was not made clearer inside the Lucee Server Admin is something I hope gets a note next time like “warning: for use with alpha/beta development software only”.


#6

Foolishly I upgraded to 6.0.5 too and now have the same issue so need to revert back to 5.1.38.
What’s the easiest way to downgrade?

I don’t see any options to do so in the Admin/Extension/Applications page.
I’ve tried uninstalling the extension (6.0.5) and restarting Lucee but I don’t get any choice of version when choosing to re-install.
Looking in the \opt\lucee\tomcat\lucee-server\context\extensions\available I can see a mysql-5.1.38.lex package but I can’t see 6.0.5.

Any clues?


#7

For me, it was in the Extension - Applications - MySQL page.


#8

Hi Juan,

Thanks for the quick response.
I think you must be using a newer version of Lucee.
I’m on 5.0.0.252 and it doesn’t have the update/downgrade option.

But nevermind. I found a solution and just in case anyone else finds this here it is.

First I downloaded 5.1.38 lex file from here http://download.lucee.org/?type=ext
Then in the Lucee control panel I uninstalled MySQL 6.0.5 from Admin/Extension/Applications.
I stopped Lucee on the commandline.
Then I deleted the com.mysql.cj-6-0-5.jar from \opt\lucee\tomcat\lucee-server\bundles
Then copied the downloaded com.mysql.jdbc-5.1.38.lex into \opt\lucee\tomcat\lucee-server\deploy
Finally I restarted Lucee and I was back with mySQL 5.1.38