Error 'The REST Servlet is not configured in your environment' after upgrading to

I was running and ran the upgrade under the Lucee Admin control panel a couple of days ago to upgrade to The animated upgrade icon continued to spin, even after 10 mins, but when I opened the control panel in another browser window, it appeared to be upgraded to the newer release. However, now, visiting shows a 404 error. Also, at the top of the Admin front page is an error: ‘The REST Servlet is not configured in your environment’. Visiting the live URL of the site works without issues, so it’s only when trying to access it locally.

This is on a brand new server, installed only a couple of weeks ago, on Windows 2022. Any idea how I can get the working again?

(I have another Lucee server, which I’ve not yet upgraded. I noted that there is a REST menu option under Archives and Resources, but neither server have any configuration options under here - I was hoping there might be something I could copy/paste over).

I’m not familiar with REST and what it does, so thought to seek advice first rather than tinker! Has anyone else had this issue with an upgrade?

Thanks in advance.

OS: Windows 2022/IIS
Java Version: 11.0.17 Eclipse Adoptium 64 bit
Tomcat Version: 9.0.68
Lucee Version:

1 Like

How is the REST environment setup? Through the Lucee Administrator or within your Application.cfc?

Sorry, I can’t really answer that, as I’ve never used/configured REST in the past, either on a ColdFusion or Lucee setup.

I can tell you this, if it helps:

  • I’ve only ever used Windows servers
  • On a fresh install, I start with Windows/IIS and then install CF/Lucee on top. Other than configuring data sources and the odd scheduled task, there are no other settings I’ve ever changed in the admin section of CF or Lucee.
  • I do not set up an application.cfc file. (I do have an application.cfm file, but this makes no mention of REST)
  • I’ve never configured anything within the REST section of Lucee, as I never knew what it was used for

Sorry I can’t be more specific, but literally coming across that error was the first time that I was hearing about REST.

Ok, so if you never used REST, this shouldn’t be a problem. However, your Lucee instance isn’t seeing the REST servlet which is setup and loaded by Tomcat( configured in Tomcats configuration files). Doing an upgrade from within the Admin shouldn’t do anything with those files. I’d say some type of deployment didn’t complete on your instance after the upgrade.

  • For any further cases, do you have a backup of your Lucee configuration before upgrading?

  • Have you also tried restarting the Tomcat/Lucee service in the Windows Service Manager after the upgrade?

As it’s a new server I hadn’t yet implemented our backup software, so I don’t have a backup unfortunately.

I restarted Tomcat/Lucee in Services.msc, and had already rebooted the server. Neither had any effect.

If everything works as expected, you may only need to add a mapping for sitefolder in your

But I really can’t say for sure, because I don’t know what your real setup is all about.

It’s a pretty ‘vanilla’ setup, to be honest. The server’s job it to serve one website only, so I literally never even enter the web section of Lucee admin. There is zero customisation - I just enabled IIS, restored my site files into c:\inetpub\wwwroot\sitefolder, installed Lucee and connected to a datasource. (I did have to make one minor mod to the XML server file by adding address=“::1” to the connector protocol for AJP/1.3, as I was having a couple of seconds delay on every page - this is documented in another thread, but bears no relation to this issue. I also tried reverting that change after the failed update, just in case…)

I did go into the Web section as you suggested and tried to add a mapping, but it made no difference.

I also tried comparing \lucee\tomcat\conf\server.xml with another (working) Lucee server, but they were identical.

Are there any other files that you could recommend that I could compare, to see where there might be differences?

P.S. Thanks for all the direction on this. Issues like this are a real problem when you have no idea what caused it, why, and where to go to fix it!

In that case, that’s how I would reset the lucee server. This will wipe any setting configured through the Lucee Admin (web/server), also schedules and the admin password. But as you said, you didn’t setup anything in the Lucee admin, I’d reset your Lucee to the latest update as follows…

  1. backup everything so you can easily switch back if something goes totally wrong.
  2. Download the latest stable Lucee.jar from
  3. Stop the Tomcat/Lucee service in the Windows Service Manager
  4. Copy the downloaded Lucee.jar to c:\path-to-your-lucee-installation\tomcat\lib\ext\ (you will see another lucee.jar there. You can simply rename that one to lucee.old or similar but you MUST rename the extension or delete the file, otherwise Tomcat will load those too)
  5. Delete the directory lucee-server at c:\path-to-your-lucee-installation\tomcat\lucee-server
  6. Delete any existing WEB-INF folder (these are the webcontexts) within existing webroots, e.g. c:\inetpup\sitefolder\web-inf
  7. Restart the Tomcat/Lucee service in the Windows Service Manager

Wait for Tomcat to create the lucee-server directory and files, and also the web-inf web-contexts.

You may need to reset the password of your server admin. To do that, open a text editor, eriter your password there and save that file as password.txt to
c:\path-to-your-lucee-installation\tomcat\lucee-server\context\password.txt. When opening the Lucee Administrator you will be prompted to import the password.txt file. Just click on the import button. Then login and if everyone goes well you should be greeted with the newest Lucee version.

I hope I didn’t mention some path location incorrectly, coz’ Im writing these instruction from my mobile while my wife is driving :wink:

Firstly, absolute kudos for the multi-tasking skills!

I’ll test and report back. Thank you.

I followed the instructions to the letter (also backing up c:\lucee\ and all of the WEB-INF folders).

There was not a \ext\ sub folder within \lib. There were several .JAR files in \lib\ but none starting with Lucee. I search the c:\Lucee root and found the previous .JAR in \lib there, so assumed that this was the right one.

The server started correctly with v5.3.10.120, but unfortunately the problem remains.

I think the REST error is actually unrelated to the site not being accessible on!

I just upgraded my laptop, which also was running the same version of Lucee. The upgrade performed normally, but I still get the REST servlet error. However, loads correctly!

So I guess the question should be: What can I do to fault-find why the site is not loading on, but is loading against the domain I allocated against it?

Martin, while others may have still more to say, I’ll chime in with more to consider/try. It’s not brief, but it’s how I would approach this if it happened to me:

  1. I’d wonder if you tried downgrading back to, since all this started for you when you went from that to I’m not saying you SHOULD have to, but if you did and things worked, it would confirm that’s the problem.

Conversely, if it does NOT fix things, then I’d be wondering if that first update failed in some way, leaving things botched–and in such a way that the downgrade would not “repair”. Same with the prior steps today of dropping in the jar.

  1. If things still fail after that, I’d recommend trying to uninstall Lucee (given you did the prior steps Andreas offered today), then reinstall.

If that goes well, does your site work locally as expected? If not, it would suggest some bigger problem, right? But if the local site DOES work, try the Lucee admin update again. If I things works after that, it was some cobweb that’s now been wiped clean, and not likely even worth pursuing further, I’d think.

FWIW, there’s zero reference to that error in withe the lucee forums here or the broader web. That’s an indication of how unique this problem is. If it ever happens to anyone again, perhaps they may find this and add an update if some new info is found be then. :slight_smile:

  1. Finally, if you may say you DID try reinstalling and the local site fails immediately, you may feel stuck. But you could consider repeating your initial steps on a different machine or VM (or the Windows Sanbox on THIS machine), to see if all works–the install, the local site, the update.

If they did, then at least you’d Know now that there’s something other than Lucee that’s somehow gone amiss on this current machine.

  1. And to that point, or if you don’t want to try steps 2 or 3 (my step 1 seems trivial to at least try), my next guess would be something in the iis configuration - - since the url of your failing local request shows you using no port, I’m assuming that’s going through iis. Clearing out iis settings can be a challenge: the configuration elements could be at the iis site level (perhaps in the web.config for the site) or at the iis server level (in the applicationhost.config, which csn hold site-level config as well).

Lastly you say all was working initially (remote and local requests via iis to Lucee), so I’ll assume you’re not serving the local and remote requests via different iis site configurations somehow, as that could add more challenge “cleaning things up”.

But I realize you may not want to “go there” yet (about considering iis config issues), so I’m just
planting that seed, for you or others.

Let us know if you try/learn anything.

1 Like

Thanks @carehart for your suggestions.

I tried the deinstall/reinstall approach, with no success. Here’s exactly what I did:

  1. Open Windows Settings, select Apps, and Uninstall Lucee
  2. A message stating ‘all previous installation will be removed - do you want to keep IIS features and roles’. I selected YES. Noted that it prompted to also remove the BonCode AJP 1.3 Connector, which it did
    3.Started the install of the latest release. Noted that it said there was already a c:\Lucee folder. Prompted to overwrite, which I did. It also ran the command prompt to reconnect with IIS.

I could immediately get back into Lucee admin, and noted that it still had stored the database and mail server settings, so it hadn’t deleted everything. I could again access the website through its full URL but not (I’ve never been able to access any Lucee setup on IIS via localhost). At least I am in the same position as when I started.

Before I deinstall AND delete the lucee folder I thought I’d post the above in case anyone else had any suggestions.

Thanks again!

Consider now my points 3 and 4, or you may prefer to wait to see what others may offer.

@martinbailey did you get to try my points 3 or 4?

I am embarrassed to say that I found the problem - user error!

In IIS I have the default website (which was not used) plus two other sites (which are sub folders of wwwroot). It was recommended to me to disable the default site for security reasons. I’d done that shortly before the upgrade, but had not tested until after the upgrade.

Enabling the default site allowed to work as normal.

Thank you so much for your assistance on this. (I took a look at your website and have bookmarked it for future use, so it wasn’t entirely a waste of your time!).


Lot’s of thanks for posting back what was causing the issue. I really appreciate that a lot!!!

1 Like