Error page not working with IIS

Setting up my first Lucee server to replace 2 very old ACF servers (cf7 & cf8)

When I get a page error, it just takes me to a page that says
**The specified URL cannot be found. **

I thought it was a path issue so I moved the error.cfm to the root and tried running it directly. Same message. So I copied the error.cfm to error1.cfm and started to rem out large sections and it worked.

I noticed as soon as it tried to display #catch.type#… the URL cannot be found returned.

What do I have miss-configured?

OS: Windows Server 2016 Standard
Java Version: 11.0.7
Tomcat Version: 9.0.35
Lucee Version:

are you using IIS? It hides error pages by default?

Yes… Using IIS
How do I prevent IIS from hiding the error pages?

What happens if you set the error pages to return the 200 Status Code in Lucees administrator page by unticking the checkbox?

If that works, you’ll probably need to change your error templates to do exactly what you want in case of exceptions. This may work for you, but be aware that this will also pass the 200 status code to the IIS and to the browser. You will probably need to add cutom errors to IIS then or something similiar.

Google then ask :slight_smile:

I did… for over an hour before I posted the question after working on it for hours.

I never post a question I haven’t googled a few times… Found a lot of things, but not a setting to turn it off in IIS.

Unfortunately… no change

ok, thanks and sorry!

Did you search thru the forum archives here, I’m pretty sure this has come up before?

try tweeting to they are great

I had a problem once and they had an engineer spend four hours fixing my problem remotely for free

Is that a custom error page of IIS for 500 status errors? Did you find that page somewhere? Look into your IIS settings for custom pages.