Error: no access to update datsource connections


#1

I am having lots of issues installing Lucee on a new Windows Server 2016, MySQL 8, Lucee 5.2.9.31

It is the same issue as reported here:

Errors:
“no access to update datsource connections”
I have also had an error about the key store being tampered with

I get this when trying to verify the connection from the Services - Datasource page

I can initially add the connection if I untick the verify box. I can then verify it from the datasource list. But if I make changes and click update I start to get the errors. The only way to sort it out is to uninstall/install Lucee.

I have figured out that one issue is convertToNull is now CONVERT_TO_NULL with the latest connector (8.0.11) installed from the Applications page in Lucee.

Another issue is I need to add the following to lucee-server.xml:
&useSSL=false&requireSSL=false&allowPublicKeyRetrieval=true
However when I update the Datasource page in Lucee it removes this text from lucee-server.xml.

Anyone know what is going on and how I sort this out?


#2

In my case I never determined exactly what the issue was but suspected that it was a windows permission problem where Lucee just didn’t have the rights to write the connection information to the drive. Since it was a brand new install I wiped the drive, reinstalled windows and then reinstalled Lucee once I had updated windows with all the updates. After that everything worked.


#3

Hi denis, thanks for the reply.

I can reinstall everything but this was a new install, Windows updates installed first then everything else. It was working but then stopped. I think this issue was caused by dropping the database and importing a backup… that appears to have deleted the connecting in Lucee?

Does your install still work if you verify the connect from the datasource page? How about if you set Date Time behavior to Convert To Null. Is it possible for you to try that?
Appreciate the help.

I will try installing Lucee again tonight but I am concerned that if this goes live it could happen again at any time.


#4

In my setup I have separate MSSQL database servers on seperate boxes from the web servers. I have 2 NICs in each Web server box. The SQL servers are on a private network accessed through the second NIC’s and are separate from the ones servicing the Internet traffic.

Once I re-installed the OS and then Lucee I had no further issues with connecting to either of them and can verify the connections via Lucee’s server app page. I have over a 30 datasource connections for the various websites on that particular box. All MSSQL none MySql.

I suspected that my issue was a windows permission issue because the error response given had a typo/misspelling that allowed me to search the Lucee code for that unique phrase and from that I could discern that the the error was thrown when writing to the drive. A second install of Lucee on another box worked fine so ergo…

My current version of Lucee is 5.2.9.31 and I am using both the Microsoft SQL connector for our newer MSSQL server and the jTDS connector for our older MSSQL server.