EHCache connections - java.lang.NullPointerException


#1

All of a sudden my EHCache connections have started generating null pointer exceptions when verifying the cache in the server admin. In my code, calling cachePut() generates the same error, but cacheGet() does not. In the admin, I can create a new connection, and then when I verify it (immediately after it was created), it generates the same error.

I have to restart Lucee to get my connections to verify again, but subsequent calls to cachePut() will make all (or some) of them error out, and back into the “bad state”.

I’m going to take a guess that I have a corrupted cache somewhere… but where? How can I manually clean up EH Cache files?


#2

I must have had some kind of corruption going on. I deleted all my EHCache data files and things started working again. My data files were found in C:\lucee\tomcat\lucee-server\context\ehcache (Win7)


#3

I’m still getting random situations when my EH Cache connections are failing. When this happens, I’ve been deleting my cache data files after restarting Lucee. I’m running Lucee v5.2.4.37 with EHCache v2.10.0.25. If anyone has any ideas as to why this may all of a sudden be an issue, please feel free to clue me in! Thanks :slight_smile:


#4

After a day of working on this issue, I finally narrowed it down to something different in the EHCache extension between version 2.10.0.25 and 2.10.0.22. Our EHCache connections are stable and work as they always have when using version 2.10.0.22. Upgrading to 2.10.0.25 has introduced a bug that causes connections to return java.lang.NullPointerException when verified through the admin, and any calls to cachePut() throw an exception. I am unable to reproduce the error consistently, and rolling back to 2.10.0.22 seems to have fixed the issue.

I filed a bug report here:

https://luceeserver.atlassian.net/browse/LDEV-1579