Edit - https port 443 going to Apache2 home after letsencrypt install

I just installed letsencrypt and have my firewall pointing to port 443 so now my site pulls up the Apache2 default page instead of my lucee site. I’m new and trying to get ssl up and running. Any hints on where I went wrong would be most appreciated.

[edit] SSL is working. If I go to https://domain.com/index.cfm lucee serves the page however if I go to https://domain.com apache2 serves the page. I suspect this is a mod_cfml issue and I’ll go research that but if anyone has any pointers I’d be grateful.

Check to be sure that index.cfm is listed (first) in the Apache conf’s DirectoryIndex directive.

HTH

– Denny

I used this and let it create Apache config

+1 to index.cfm being in your DirectoryIndex.

You probably have two site configs in Apache, one for port 80 (http) and one for port 443 (https). You’ll need to ensure that index.cfm is listed in your DirectoryIndex directive for the config for port 443.

I used Certbot as well. Thanks for confirming that I’m on the track @webonix.

Problem- When browsing the site without entering the document after “domain.com/” Apache2 would pick up the request on index.html. I wanted lucee to get the request for index.cfm.

Solution- I followed what @ddspringle suggested and edited “/etc/apache2/sites-enabled/000-default-le-ssl.conf”. I added the line “DirectoryIndex index.cfm” before the line “DocumentRoot /var/www” and all is well again.

Thanks @Jordan_Michaels @ddspringle.
BTW - My system is Ubuntu 16.04 with Apache/2.4 for any other newbies like myself out there… :slight_smile:

1 Like