ED25519 OpenSSH key

Hi Everyone,
I am trying to use a newly created ED25519 private key for sftp.
(this key works when used in “winscp”.)

However I keep getting com.jcraft.jsch.JSchException: invalid privatekey: [xxxxxx

I have tried converting the key to PEM format with puttyGen and ssh-keyGen - but it doesn’t help any.
I have tried using the putty key (PPK) - it doesn’t work, either.

After digging around a little in the lucee bug tracker I found that we are using mwiede fork of jsch

And in the readme, there, it has;

  • In order to use ssh-ed25519 & ssh-ed448, you must use at least Java 15 or add Bouncy Castle (bcprov-jdk18on) to the classpath.
  • In order to use curve25519-sha256 & curve448-sha512, you must use at least Java 11 or add Bouncy Castle (bcprov-jdk18on) to the classpath.

I have added the JAR to the classpath and confirm that after a Tomcat restart - it is available and active to Lucee by viewing “bundled jars” in the Server Admin.

Not sure where to go from here…

Or if it is something completely different!
As always - Thanks.

Don’t forget to tell us about your stack!

OS: AWS Linux 2 (CentOS)
Java Version: 11.0.19+7
Tomcat Version: 8.x
Lucee Version:

I just wanted to pop this back up the list and ask for some help in being able to use a ED25519 flavoured certificate for authentication with the SFTP built-in function, please.

I am happy to create an issue in Jira - if it is needed…
Butr as per the Jira instructions - I am asking here first.