Docker pull upgrading to latest

Im tring to build an environmnet with the latest LTS 5.6.4.9

I creating the image in azure AlmaLinux (Redhat). When I specify a specific buld it always upgrades to the lucee latest 6.0.3.1. See image for details. At least its running :slight_smile:
commands i use to build the docker
“sudo docker pull lucee/lucee52-nginx:5.4.6.9”,
“sudo docker run -d -p 8888:8888 lucee/lucee”,

can anyone point me in the right direction to keep to a specified build?

Yes. Just change the image name at the end of your docker run to match that in your docker pull. :slight_smile:

The latter (as you have it now) is running the current version because you say simply “lucee/lucee”.

And FWIW that run would have done an implicit pull the first time you ran it. Really, there’s generally no need to bother with the separate pull, except when you DON’T mean to be also running it.

Let us know if that gets you going.

Thanks for your response. looks like the image isn’t available.

using “sudo docker pull lucee/lucee52-nginx:5.4.6.9”,
“sudo docker run -d -p 8888:8888 lucee/lucee52-nginx:5.4.6.9”,

supprising as its the LTS.

module.demo.azurerm_linux_virtual_machine.pl-lucee (remote-exec): Complete!
module.demo.azurerm_linux_virtual_machine.pl-lucee: Still creating… [5m30s elapsed]
module.demo.azurerm_linux_virtual_machine.pl-lucee (remote-exec): Created symlink /etc/systemd/system/multi-user.target.wants/docker.service → /usr/lib/systemd/system/docker.service.
module.demo.azurerm_linux_virtual_machine.pl-lucee (remote-exec): Error response from daemon: manifest for lucee/lucee52-nginx:5.4.6.9 not found: manifest unknown: manifest unknown
module.demo.azurerm_linux_virtual_machine.pl-lucee (remote-exec): curl: (7) Failed to connect to localhost port 8888: Connection refused
module.demo.azurerm_linux_virtual_machine.pl-lucee (remote-exec): Lucee installation failed

│ Error: remote-exec provisioner error

│ with module.demo.azurerm_linux_virtual_machine.pl-lucee,
│ on …..\ResourceDotGo\demo.tf line 258, in resource “azurerm_linux_virtual_machine” “pl-lucee”:
│ 258: provisioner “remote-exec” {

│ error executing “/tmp/terraform_236136840.sh”: Process exited with status 1

I belive you are using the ‘wrong’ image, looking at https://hub.docker.com/u/lucee it seems lucee52-nginx hasn’t been updated in a while.

Looking at the command on https://download.lucee.org/ it points to docker pull lucee/lucee:5.4.6.9, so I guess every new image will be in here https://hub.docker.com/r/lucee/lucee

However I have not yet used docker as much as I wanted, so might be wrong.

edit
Might be one of these https://hub.docker.com/r/lucee/lucee/tags?name=5.4.6.9
This one matches your current name: lucee/lucee:5.4.6.9-nginx

1 Like

Thanks for that. You guys are great.
I think lucee:5.4.6.9 only contains lucee and I want nginx and tomcat preinstalled if possible

This one looks promising: [lucee/lucee:5.4.6.9-nginx ] and it works. thanks so much for your help. onto Plesk next :slight_smile:

Glad you’ve solved things…though if the pull worked, then it seems the image does exist. It’s indeed odd then that the run failed. There would seem more to why the run failed, but I get that you’ll be moving on. (I’m not “trying” any of this along with you. I’m just writing from my phone.)

Again, my goal was to address your initial problem: how you ended running the latest unexpectedly. :slight_smile: Hope the rest goes well for you.

1 Like

Honestly anyone that takes the time to reply with an insight helps me move on. I really appreciate your time. It all helps as i pick my way through the build. cheers again

2 Likes