Creating Datasource in server admin for MSSQL failing

New install of LUCEE (see details below) and getting this:

lucee.commons.lang.ClassException: cannot load class through its string name, because no definition for the class with the specified name [] could be found caused by ( not found by lucee.core [46];;)

In extensions - Applications I see Microsoft SQL Server… but cannot install it.
I tried version 9.3.1 then the last jre8 (7.2.2 jre)
This is what I get when trying to add the application:

Unable to resolve [64](R 64.0): missing requirement [ [64](R 64.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0))) Unresolved requirements: [[ [64](R 64.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0)))]

Is this an easy fix… or should I re-build the OS and try again?

OS: Windows Server 2016
Java Version: 11.0.7 (AdoptOpenJDK) 64bit
Tomcat Version: Apache Tomcat/9.0.35
Lucee Version: Lucee

1 Like

@BKW I’ve filed a bug LDEV-3492 MSSQL version 9.3.1 shows the error in application page.. The same error shows for all the versions above the 7.2.2 jre 8. MSSQL extension 7.2.2 jre 8 is the last working version.

Restart admin and install 7.2.2 jre 8 works.


That is worked!!!

Thank you so very much for the information!