Configuring osgi bootdelegation classes

Hi Team,
We are using Lucee version…
We would like to know,where to configure the classes for "
org.osgi.framework.bootdelegation" to overcome the class loading issues.

Thanks in advance !!


Are you able to resolve this? I am trying to use pinpoint but it stuck at this stage.

can you explain in some more detail what you’re trying to achieve?

Trying to pinpoint APM with Lucee but somehow not able to create datasource I have added pinpoint agent.
While googling found following article mentioning OSGI and as per their article I need to bootdelegation following classes.
Here is article for same.

did you see this bug?

Hm… I tried but didn’t get success. Probably need to try without docker setup.

if you can go into detail on what steps you’re doing, maybe @micstriit can point you in the right direction?

Just to update here if that help someone. As of on today I didn’t find any direct way to add bootdelegation to lucee.
I tried to build from source by adding needed class path in following file and build lucee and seems work for me.