Component or class

ATM we still use the word “component” for components in the Lucee dialect,
should we consider to use the term “class” instead* in the Lucee dialect*?

so instead of
component {
}

we do
class {
}

in our code. we could still support “component” as alias to make the
conversion of an existing application easier.

What do you think?
Micha

I would only like that with proper constructors. A discussion about
constructors was started a while ago, including some proposals. The ‘init’
convention has served us well, but if something is going to be called a
class, I think a proper constructor is required. If ‘class’ is just an
alias for ‘component’, you might lose the opportunity to do something about
this in the future.

+1 for ‘class’ instead of ‘component’
+1 for ‘method’ instead of ‘function’

I’d like to see making (‘method’ | ‘function’) optional rather than just
dropping entirely.

Chip.On Thursday, April 23, 2015 at 5:19:18 AM UTC-4, Micha wrote:

ATM we still use the word “component” for components in the Lucee dialect,
should we consider to use the term “class” instead* in the Lucee dialect*
?

so instead of
component {
}

we do
class {
}

in our code. we could still support “component” as alias to make the
conversion of an existing application easier.

What do you think?
Micha

I completely agree :slight_smile:

+1 for class, removal of the function keyword inside class, deprecation of the pseudo-constructor.

Agree. “class” is the ubiquitous OO term for these things. It wasn’t so
cool CFML called them component’s from the outset.

I’ve lobbied in the past to get the term changed to “class” for CFML as
well, but ppl recoiled in horror and didn’t think it was a good use of
Adobe’s time. Mileage varies, it seems.

Good call, Micha.–
Adam

On Thursday, 23 April 2015 10:19:18 UTC+1, Micha wrote:

ATM we still use the word “component” for components in the Lucee dialect,
should we consider to use the term “class” instead* in the Lucee dialect*
?

so instead of
component {
}

we do
class {
}

in our code. we could still support “component” as alias to make the
conversion of an existing application easier.

What do you think?
Micha

+1 for class… I always wondered why MM used the term “component”…On Thursday, April 23, 2015 at 7:19:18 PM UTC+10, Micha wrote:

ATM we still use the word “component” for components in the Lucee dialect,
should we consider to use the term “class” instead* in the Lucee dialect*
?

so instead of
component {
}

we do
class {
}

in our code. we could still support “component” as alias to make the
conversion of an existing application easier.

What do you think?
Micha

Definitely in favour of classOn Thursday, 23 April 2015 13:06:46 UTC+1, Jesse Shaffer wrote:

I completely agree :slight_smile:

https://bitbucket.org/lucee/lucee/issue/82/5x-proposal-class-syntax

+1

Hello from 2022, where I am wondering … has this been implemented in the upcoming Lucee 6?

1 Like