Compile Mappings in webadmin results in error


#1

Hi team,

I’m trying to migrate my current ACF application into the Lucee. I tried to compile my mappings under the web admin of Lucee and it resulted in some syntax error. I fixed the error and cleared the classes ‘WEB-INF\lucee\cfclasses’ from this folder. I also cleared the cache and tried to do recompile the folder (mapping). It is still stuck on the previous error and doesn’t want to move ahead even after the fix is applied.

I have temporarily tried to set the ‘Inspect Templates (CFM/CFC)’ to never. I restarted Lucee service too with No luck.

I’m using Lucee 5.2.7.63

Am I missing something here? I’ll appreciate any help here.


#2

Have you restarted Lucee? Also, what is the error? Are you positive you fixed the CFML error in the code that Lucee is compiling and not a copy elsewhere?


#3

I have just edited the post that I have restarted the Lucee and double checked the code that I fixed.


#4

hey, thanks for your prompt reply. It was a permissions issue under 'WEB-INF\lucee\cfclasses’ folder. I gave the permissions and it worked. This issue can be closed.

Thanks btw.