Class redefinition failed: attempted to change superclass or interfaces


#1

Hello all,

We just recently updated our Lucee environment to version: 5.2.5.20, currently it’s the latest. Our servers are getting this error now " class redefinition failed: attempted to change superclass or interfaces ". We have all errors from the servers emailed to us. They all seem to be errors related to the CFinclude tag as every email has a similar line

<cfinclude template="/templates/include/main.cfm">

CF code has not changed and is the same across all servers. The servers are all CentOS 7. It’s not a fresh install but all the servers are identical in every way and had been working until the update.

Finding the error on some java forums, the post suggest that a class is being added twice. We are wondering if somehow the templates are loading the application.cfc twice.

I have not yet tried to delete the WEB-INF folder. I did have one server give me issues with that directory after the upgrade. the rest worked fine. I have checked owner and perms.

Thanks
Jay


#2

Hi @Jay,

Can you please delete the cfclasses folder in WEB-INF\lucee\cfclasses & restart lucee instance. I hope May be it’s help for you.


#3

Sorry for the long delay. Yes deleting the directory solved the issue.