Cfspreadsheet problems with

After upgrading from to my code that has been working fine falls over whenever a report spreadsheet is created that has an image in it. Same report spreadsheet creates successfully if I do not include images in the report.
Running Ubuntu 16.04 and using cfspreadsheet-lucee-5 from and latest version 3.0.3
Would love some assistance thank you.

That’s odd? That piece of code in the cfspreadsheet extension is simply just getting the file extension and doing so like this:

<cfset imgType = UCase(ListLast(arguments.filePath, ".")) />

“filepath” is the first argument to the addImage function. The error appears to be thrown from the ListLast function?

Yep, duplicated. That’s a bug. Not sure why though nor what changed in Lucee…

Thanks for confirming - let me know if there is anything that I can do to help- I know it’s not your code originally in cfspreadsheet-lucee-5, but you are the man :wink:

I also have problems with cfspreadsheet/spreadsheet functions after upgrading to so I hope it’s OK if I hijack this thread even though i get a different error.

We have Ubuntu 18.04 LTS and we are using the same spreadsheet extension as zendata.

This is my the code

<cfset s = spreadsheetNew("report_seminar","true")>
<!--- Header --->
<cfset cols = getMetadata(get_reg)>
<cfset colList = "">
<cfloop from="1" to="#arrayLen(cols)#" index="x">
<cfset colList = listAppend(colList, cols[x].name)>

<cfset spreadsheetAddRow(s, colList)>

<!--- Daten --->
<cfset SpreadsheetAddrows(s, get_reg)>

… and this is the error (caused by the SpreadsheetAddrows function in the last line of code I posted):;Ljava/lang/String;Ljava/lang/String;)D

Seems there is something broken with a list function as well…

problem is that the extension seem to use a “las” archive, “las” archives are containing the compiled java bytecode from the CFML code.
functions like “listLast” get hardcoded for performance reasons by the compiler. the function get “streamlined” by us and because of that it’s interface changed. that does not affect newly compiled code, but it does affect old compiled code in archives.

we will add the old interface, that will fix it.

workaround: recompile the archives or use the source code instead.

1 Like

this is the commit causing the problem

That is great news if it will fix it.
How long will it take to add the old interface?

@zendata not long anymore

1 Like

@micstriit Will you notify this thread when there is a snapshot or release that includes these changes?
I am not authorised to view so can not see what is happening.
Thank you.

Try or, both have the fix.

Are you logged into Jira?

Thanks @Zackster
I have not got credentials to log in to Jira

Screen Shot 2019-03-24 at 20.25.57

Yeah, I think I noticed that myself the other day.

@Brad_Wood any ideas? if unauthenticated users can’t see issues, that might prevent Google indexing too

Cool - glad it’s just not me!

@zendata To be clear when you say you can’t log in, are you saying you haven’t signed up for an account (it’s quick and free) or you have an account but it seems to lack permissions?

I just tried viewing a ticket such as from a browser window where I’m not logged in and it loads just fine. I would assume you’re authenticated with an account that has some sort of issues. Please report the details of your user.

Hi @bdw429s - yes now when I go to that URL I am seeing the ticket ok. Previously the ticket page and even just the Jira home link (trying to find where to sign up) all gave me the 401 message page.
Fixed now but @Zackster has seen it too. I am using a different computer now.
Just tried again on the original iMac and it still errors with the 401 error.
I’ll call this a local problem of mine :frowning:
Thanks Brad

thanks for the quick fix!

However I just tested with and still got the same error using my code above:


lucee.runtime.exp.NativeException:;Ljava/lang/String;Ljava/lang/String;)D at org.cfpoi.spreadsheet.spreadsheet_cfc$cf.udfCall3(/org/cfpoi/spreadsheet/Spreadsheet.cfc:1048) at org.cfpoi.spreadsheet.spreadsheet_cfc$cf.udfCall(/org/cfpoi/spreadsheet/Spreadsheet.cfc) at lucee.runtime.type.UDFImpl.implementation( at lucee.runtime.type.UDFImpl._call( at lucee.runtime.type.UDFImpl.callWithNamedValues( at lucee.runtime.ComponentImpl._call( at lucee.runtime.ComponentImpl._call( at lucee.runtime.ComponentImpl.callWithNamedValues( at lucee.runtime.util.VariableUtilImpl.callFunctionWithNamedValues( at lucee.runtime.PageContextImpl.getFunctionWithNamedValues( at spreadsheetaddrows_cfm$cf.udfCall(/SpreadsheetAddRows.cfm:26) at lucee.runtime.type.UDFImpl.implementation( at lucee.runtime.type.UDFImpl._call( at at at$ at lucee.runtime.PageContextImpl._doInclude( at lucee.runtime.PageContextImpl._doInclude( at lucee.runtime.listener.ModernAppListener._onRequest( at lucee.runtime.listener.MixedAppListener.onRequest( at lucee.runtime.PageContextImpl.execute( at lucee.runtime.PageContextImpl._execute( at lucee.runtime.PageContextImpl.executeCFML( at lucee.runtime.engine.Request.exe( at lucee.runtime.engine.CFMLEngineImpl._service( at lucee.runtime.engine.CFMLEngineImpl.serviceCFML( at lucee.loader.engine.CFMLEngineWrapper.serviceCFML( at lucee.loader.servlet.CFMLServlet.service( at javax.servlet.http.HttpServlet.service( at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter( at org.apache.catalina.core.ApplicationFilterChain.doFilter( at org.apache.tomcat.websocket.server.WsFilter.doFilter( at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter( at org.apache.catalina.core.ApplicationFilterChain.doFilter( at org.apache.catalina.core.StandardWrapperValve.invoke( at org.apache.catalina.core.StandardContextValve.invoke( at org.apache.catalina.authenticator.AuthenticatorBase.invoke( at org.apache.catalina.core.StandardHostValve.invoke( at org.apache.catalina.valves.ErrorReportValve.invoke( at org.apache.catalina.core.StandardEngineValve.invoke( at org.apache.catalina.connector.CoyoteAdapter.service( at org.apache.coyote.http11.Http11Processor.service( at org.apache.coyote.AbstractProcessorLight.process( at org.apache.coyote.AbstractProtocol$ConnectionHandler.process( at$SocketProcessor.doRun( at at java.util.concurrent.ThreadPoolExecutor.runWorker( at java.util.concurrent.ThreadPoolExecutor$ at org.apache.tomcat.util.threads.TaskThread$ at Caused by: java.lang.NoSuchMethodError:;Ljava/lang/String;Ljava/lang/String;)D … 50 more will fix it there was actually to separate commits that did cause it

@thilohermann i created a new ticket for this