Cfspreadsheet error

cfspreadsheet no longer works, the error is as follows:
Lucee Error (template)
Message undefined tag [cfspreadsheet]

In lucee administrator → component → Additional Resources
Name : cfspreadsheet
Archive: /opt/lucee/tomcat/lucee-server/context/archives/cfc/cfspreadsheet/cfc-archive-cfspreadsheet.lar
Primary: Archive
Inspect: inherit

This happened after that in cf administrator I get an update for cfspreadsheet (Leftbower version)
The current version is 3.0.3 the new version would be
I ran the update and it gave me the following error:

write access is protected
lucee.runtime.exp.SecurityException: write access is protected at lucee.runtime.config.ConfigWebUtil.checkPassword( at lucee.runtime.config.ConfigWebUtil.checkGeneralWriteAccess( at lucee.runtime.config.XMLConfigAdmin.checkWriteAccess( at lucee.runtime.config.XMLConfigAdmin.removeComponentMapping( at lucee.runtime.config.XMLConfigAdmin.removeArchive( at lucee.runtime.config.XMLConfigAdmin.removeRHExtension( at lucee.runtime.config.XMLConfigAdmin.updateRHExtension( at lucee.runtime.config.XMLConfigAdmin.updateRHExtension( at lucee.runtime.config.XMLConfigAdmin._updateRHExtension( at lucee.runtime.tag.Admin.doUpdateRHExtension( at lucee.runtime.tag.Admin._doStartTag( at lucee.runtime.tag.Admin.doStartTag( at ext_applications_cfm184$ at lucee.runtime.PageContextImpl._doInclude( at lucee.runtime.PageContextImpl._doInclude( at lucee.runtime.PageContextImpl.doInclude( at web_cfm$ at lucee.runtime.PageContextImpl._doInclude( at lucee.runtime.PageContextImpl._doInclude( at lucee.runtime.PageContextImpl.doInclude( at server_cfm$ at lucee.runtime.PageContextImpl._doInclude( at lucee.runtime.PageContextImpl._doInclude( at lucee.runtime.listener.ModernAppListener._onRequest( at lucee.runtime.listener.MixedAppListener.onRequest( at lucee.runtime.PageContextImpl.execute( at lucee.runtime.PageContextImpl._execute( at lucee.runtime.PageContextImpl.executeCFML( at lucee.runtime.engine.Request.exe( at lucee.runtime.engine.CFMLEngineImpl._service( at lucee.runtime.engine.CFMLEngineImpl.serviceCFML( at lucee.loader.engine.CFMLEngineWrapper.serviceCFML( at lucee.loader.servlet.CFMLServlet.service( at javax.servlet.http.HttpServlet.service( at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter( at org.apache.catalina.core.ApplicationFilterChain.doFilter( at org.apache.tomcat.websocket.server.WsFilter.doFilter( at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter( at org.apache.catalina.core.ApplicationFilterChain.doFilter( at org.apache.catalina.core.StandardWrapperValve.invoke( at org.apache.catalina.core.StandardContextValve.invoke( at org.apache.catalina.authenticator.AuthenticatorBase.invoke( at org.apache.catalina.core.StandardHostValve.invoke( at org.apache.catalina.valves.ErrorReportValve.invoke( at mod_cfml.core.invoke( at org.apache.catalina.valves.AbstractAccessLogValve.invoke( at org.apache.catalina.core.StandardEngineValve.invoke( at org.apache.catalina.valves.RemoteIpValve.invoke( at org.apache.catalina.connector.CoyoteAdapter.service( at org.apache.coyote.http11.Http11Processor.service( at org.apache.coyote.AbstractProcessorLight.process( at org.apache.coyote.AbstractProtocol$ConnectionHandler.process( at$SocketProcessor.doRun( at at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) at java.base/java.util.concurrent.ThreadPoolExecutor$ Source) at org.apache.tomcat.util.threads.TaskThread$ at java.base/ Source)

to access the configuration without a password, you need to change the write access to [open] in the Server Administrator

OS: Linux 7.9.2009
Tomcat Version: 9.0.31
Lucee Version:

The .lar file is present in the mapped folder -rw-r----- 1 lighte lighte 76636 May 4 2020 cfc-archive-cfspreadsheet.lar :slight_smile:
-rw-r----- 1 lucee lucee 76636 May 4 2020 cfc-archive-cfspreadsheet.lar

Your problem is at the top:

“write access is protected

You need to correct your security permissions and you need to add a password.txt file if you want to access the web interface.

I tried.
It does not change anything.
I solved it by uninstalling the extension and reinstalling it by loading the cfspreadsheet-lucee-5.lex file in the lucee-server/deploy folder
Now cfspreadsheet works, but in light of the admin proposes me to update it:
obviously I won’t do it because it offers version

Lucee - Overview

The Server Administrator allows you to install updates and patches for your Lucee installation and to restart the engine with a mouse click. You can configure new web contexts and define restrictions and configurations per web context individual.

There are some updates available for your installed Extensions.

I had similar situation and would caution anyone to NOT use the Lucee Admin to update this plugin as it essentially “breaks” it. Just use the drop into deploy directory as noted above.

1 Like

any know which version of Lucee updating via the admin worked with extension? (it was last updated in 2018)

Ran into the same error and after debugging for a while ended up removing the cfspreadsheet plugin all together (minimal usage in our apps thankfully).

The plugin was installed via an environment variable: LUCEE_EXTENSIONS: “037A27FF-0B80-4CBA-B954BEBD790B460E;name=cfspreadsheet;version=3.0.3”

This hadn’t changed in 2.5 years and then all of the sudden in 2023 all our builds failed. We updated the version to, which resulted in successful builds, but then Lucee threw errors later on as it apparently lost track of cfspreadsheet. It’s a pretty bizarre issue that does seem related to the versioning (3.0.3 vs

1 Like