Cfpop - delete action doesn't allow delimiters

I started an ACF 11 to Lucee conversion today and ran into this with the cfpop - delete action.

It seemed like we had problems using a comma delimiter with our mail server so it had been switched to pipes.

Would moving this to Lucee mean looping over each UID calling cfpop for each record to delete?
It would work but not very efficiently.

Attribute [delimiter] is not allowed for tag [cfpop]:valid attribute names are [connection,server,uid,port,username,password,secure,action,name,messagenumber,attachmentpath,timeout,debug,maxrows,startrow,generateuniquefilenames]:


Maybe I’m not understanding, why couldn’t you change the delimiter rather than looping?

I see it now:

This may be one of those try it out and see? Just because you had issues in ACF doesn’t mean Lucee implements the same way.

(Not trying to hijack the thread)

Indeed, I find every now and again that the commands / arguments / etc might be the same between ACF and Lucee - and in the end the result (should) will be the same too - but occasionally due to the actual “programming” being different - i can actually get different results and sometimes “failures”, when attempting to use verbatim code from one platform to another.

An example :
The difference between ACF and lucee copy-by-reference / copy-by-value.Code that worked flawlessly on ACF - creates JVM race conditions and thread locking issues on Lucee. (Lucee needs more diligent “locking” than ACF).

This doesn’t make Lucee worse than ACF - just different.
Sure : it is a pain - to have to amend working code, that has always worked…
(More painful to try and find intermittent JVM thread locking issues, too!)

Anyway my point is - assumption is the mother of all fuck-ups - testing specifically for what you need in the conditions you need it, on the platform you’re using… is ALWAYS sound advice.

And of course you have the forums here and slack channels, too - to ask for help!

Please, let us know how it all turns out.

I’ve created an incompatibility ticket in Jira for this LDEV-4247 - cfpop/cfimap doesn’t supports delimiter attribute

1 Like