Cfmail does not appear to be working

I have verified the connection to the mail server from Lucee server admin. ( it seems to verify ).

Mail server works as it sends from out current cf website.

I have attempted to send with simple content of “test”.
Without username and password and server attributes
With username and password and server attributes

No error.

Nothing in email.log file.

Tried wrapping the code in cftry/catch block to catch any errors that might be suppressed. Seems to run fine.

Anything else I can try?

@dannyF please check your web admin > Services > Tasks page for undelivery mails details.
Also, you can see the error details for cfmail in the remoteclient.log/mail.log file.

If you want to see and troubleshoot the error in the cfmail on the current request page means you have to set the async=false in the cfmail tag.

thanks guys. The error is:

STARTTLS is required to send mail

1 Like

You might need to install the host’s SSL certificate in:

Lucee Admin > Services > SSL Certificates

Thanks. did that. server restart. But still same error.

Did you try the attribute usetls to true?


that worked!