I'd like to propose that cfinsert and cfupdate get an added attribute "fieldObject" this would allow the form scope to be replace by a structure of keys.
IMHO it would also be fitting to change insert and update tag related functions to dbinsert and dbupdate as the former are ambiguous and generic , the suggested names are more obvious.
the fieldlist attribute could then be used in conjunction with this object to limit fields, so basically the 'fieldObject' simply overrides
It would be a quick change, three lines of code (adding the parameter, adding the null reset, and adding a line to write over the form variable by chaing line 238)
Form form = pageContext.formScope();
Form form = fieldobject ? fieldObject : pageContext.formScope();