CFID is not an integer?

So I got my app running on Lucee 5 on Windows 10. I’m now trying to get it
to run on Mac/OS X.

I quickly run into an issue where my app is expecting the CFID cookie to be
an integer but it’s a value like “a6681d40-0f4f-467b-aad2-c161eddcf512”. On
Windows, CFID is an integer just like it is on CF 11.

Is that a bug/difference with Lucee 5 on OSX? Is there an admin setting to
fix that?

Thanks,
Phil

Hmmm…so I found this discussion

https://groups.google.com/forum/#!topic/railo/PudOipSOVVc

so I guess it should be a UUID. And doing a simple case does show CFID as a
UUID on Windows.

But it’s still odd I’m seeing an integer on Windows in my app.

Thanks,
PhilOn Friday, August 12, 2016 at 3:14:39 PM UTC-7, Phil Cruz wrote:

So I got my app running on Lucee 5 on Windows 10. I’m now trying to get it
to run on Mac/OS X.

I quickly run into an issue where my app is expecting the CFID cookie to
be an integer but it’s a value like “a6681d40-0f4f-467b-aad2-c161eddcf512”.
On Windows, CFID is an integer just like it is on CF 11.

Is that a bug/difference with Lucee 5 on OSX? Is there an admin setting to
fix that?

Thanks,
Phil

As far as I’ve always known, cfid has been a UUID in Railo/Lucee.
ColdFusion always used an integer id with an additional token to add
entropy (so someone can’t guess your session information). That was really
sort of lame, so Lucee always just used a UUID right of the bat for the
cfid and uses an empty cftoken.

I’m guessing your browser is remembering a cfid that was set my Adobe on
the same domain. Are you running multiple sites on localhost?

Thanks!

~BradOn Friday, August 12, 2016 at 5:57:51 PM UTC-5, Phil Cruz wrote:

Hmmm…so I found this discussion

https://groups.google.com/forum/#!topic/railo/PudOipSOVVc

so I guess it should be a UUID. And doing a simple case does show CFID as
a UUID on Windows.

But it’s still odd I’m seeing an integer on Windows in my app.

Thanks,
Phil

On Friday, August 12, 2016 at 3:14:39 PM UTC-7, Phil Cruz wrote:

So I got my app running on Lucee 5 on Windows 10. I’m now trying to get
it to run on Mac/OS X.

I quickly run into an issue where my app is expecting the CFID cookie to
be an integer but it’s a value like “a6681d40-0f4f-467b-aad2-c161eddcf512”.
On Windows, CFID is an integer just like it is on CF 11.

Is that a bug/difference with Lucee 5 on OSX? Is there an admin setting
to fix that?

Thanks,
Phil

@brad nailed it, your cookie still has the cfid coming from ACF and
lucee accepts that cfid.
But new cfid will be UUIDs.

MichaOn Sun, Aug 14, 2016 at 5:02 AM, Brad Wood <@Brad_Wood> wrote:

As far as I’ve always known, cfid has been a UUID in Railo/Lucee.
ColdFusion always used an integer id with an additional token to add
entropy (so someone can’t guess your session information). That was really
sort of lame, so Lucee always just used a UUID right of the bat for the
cfid and uses an empty cftoken.

I’m guessing your browser is remembering a cfid that was set my Adobe on
the same domain. Are you running multiple sites on localhost?

Thanks!

~Brad

On Friday, August 12, 2016 at 5:57:51 PM UTC-5, Phil Cruz wrote:

Hmmm…so I found this discussion

https://groups.google.com/forum/#!topic/railo/PudOipSOVVc

so I guess it should be a UUID. And doing a simple case does show CFID as
a UUID on Windows.

But it’s still odd I’m seeing an integer on Windows in my app.

Thanks,
Phil

On Friday, August 12, 2016 at 3:14:39 PM UTC-7, Phil Cruz wrote:

So I got my app running on Lucee 5 on Windows 10. I’m now trying to get
it to run on Mac/OS X.

I quickly run into an issue where my app is expecting the CFID cookie to
be an integer but it’s a value like “a6681d40-0f4f-467b-aad2-c161eddcf512”.
On Windows, CFID is an integer just like it is on CF 11.

Is that a bug/difference with Lucee 5 on OSX? Is there an admin setting
to fix that?

Thanks,
Phil


Get 10% off of the regular price for this years CFCamp in Munich, Germany
(Oct. 20th & 21st) with the Lucee discount code Lucee@cfcamp. 189€
instead of 210€. Visit https://ti.to/cfcamp/cfcamp-
2016/discount/Lucee@cfcamp


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/lucee/f4b91290-c875-4bf6-abf6-917461734cb4%40googlegroups.com
https://groups.google.com/d/msgid/lucee/f4b91290-c875-4bf6-abf6-917461734cb4%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.