Cfcontent stops processing

I have some code that using CFContent. After the CFContent call I do some log processing but that part of the code is not running. Here is a simplified example

message['text']   = "hello world";
message['base64'] = toBase64( message.text, "utf-8" )
bString = toBinary( message.base64 );
cflog( file="cfcontent" type="information" text="1 - start #now()# | #message.text#" );
cfcontent( type="text/html", variable="bString" );
cflog( file="cfcontent" type="information" text="2 - stop #now()#" );

I am using Lucee
Jetty 9.4.14
Open JDK 64 Bit Server VM - 11.0.1

If you have a moment run this on your server to see if the 2nd log entry happens. It is my understanding that cfcontent should not stop all processing.

@apenhorwood, Yes, If we call any actions after the cfcontent, it didn’t work. So, it will be working in before cfcontent

I’ve updated the docs, this should be explicitly stated

1 Like

This is a change from how Lucee 4.x worked and maybe ACF. I no longer have access to ACF or Lucee 4.x without installing one just to test this functionality.

I have a framework that has worked since 2010 that records stuff after CFContent. Why would all CFML code stop working just because cfcontent was called.