Cache issue when migrating from Railo to Lucee

Hello Team,
Recently we switched from Railo server to Lucee server for our Coldfusion application. After the deployment we are facing logout issue for all the new users and few other users who haven’t logged into our application for long time. No users faced logout issue with Railo. This gets fixed by clearing all their browsing history in the browser and hitting the instance URL first and then followed by our application URL. Since it is not an optimal solution, we are looking for a permanent fix for the same.

Versions:
OS: Windows 8 / 11
Java Version: 8
Tomcat Version: 8
Lucee Version: 5.2.5.20

Hi!

How come you migrated to the ancient 5.2.5.20 and not something modern like 5.3.9.141 ?

Hello,
We use 5.2.5.20 version because of our Coldfusion code base that uses Apache POI 3.8 classes and methods and I believe 5.3.9.141 doesn’t support Apache POI 3.8 version.

Any particular reason it doesn’t? It should be fine?

There’s even a POI 5.0 extension available for lucee

Anyway, does that cache problem occur with the latest version?

With latest version of POI there are few deprecated methods and classes and it is present only in lower version. We are facing cache problem for different versions of Lucee.

ok, if you are still seeing the problem with 5.3.9.141, I can help you

(personally, I’m not gonna battle trying to solve problems with older versions of lucee as we have fixed a metric ton of bugs since 5.2.5.20!) hope you can understand my position on this! )

gonna really need to see some code tho, like a stripped down example to reproduce the problem

Hello @Jayashree

Lucee 5 doesn’t include or integrate POI at all as part of its core, so I’m not sure why any Lucee 5.x version would stop you manually loading any POI version you want?

I’ve just tested loading POI 3.8 using Lucee 5.3.9.14 and it seemed to work fine.

What are you using POI for?

If it’s just for spreadsheets then Lucee has some options for that.

2 Likes

Hello,
I tried to upgrade the Lucee version to the latest - 5.3.9.141 and when I tried to generate excel report it is throwing " controller->Sheet name cannot be blank, greater than 31 chars, or contain any of /*?" error but it works well with - 5.2.5.20 version.
can you please let me know where are going wrong ?

can you paint a picture for us, we aren’t mind readers :slight_smile:

  1. what’s the sheet name you are using?
  2. show us the stacktrace?
  3. which lib are you using, a code snippet always helps too
1 Like