Brand new install of Lucee on Window Server having site issues

Ok so this morning I did a brand new install of Lucee on one of my servers.
using the Windows Installer. Everything went fine and i am able to get the
Lucee Server administrator up. All was good.

I have several innstances of Lucee / Railo running on this server (this is
the first fresh install the other Lucee instance i upgraded from Railo) I
have set specific ports for each instance which i then set in the
BonConnector.

I made a few modifications to the server.xml file to match my other Lucee
installation specifically these settings.

I also made some adjustments to the web.xml file as i want my contents in a
specific directory on another drive. these are the same type of settings
that i currently have on my other railo and lucee installs.

CFML Engine CFMLServlet lucee.loader.servlet.CFMLServlet
<init-param>
        <param-name>lucee-web-directory</param-name>

E:\Lucee04-Web-INF/{web-context-label}/
Lucee Web Directory directory

<!-- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - 
  • –>




    1

    After making these changes i then restarted the Lucee instance. I am still
    able to get to the lucee server admin and on the home page i see that the
    context did get created in the e:Lucee0-web-inf directory. All is good.

    I then proceeded to take a site that currently had been running on another
    lucee instance and changed the bon connector to point to the new ajp port,
    stopped the site in iis and restarted it. When browsing to the site i get
    this error.

    Generic Connector Communication Error:------------------------------
    Please check and adjust your setup:
    Ensure that Tomcat is running on given host and port.
    If this is a timeout error consider adjusting IIS timeout by changing
    executionTimeout attribute in web.config (see manual).

    now i have looked through several posts here and googled it as well. I
    have checked and rechedked my settings. I also have logging turned on to
    level 3 in the bon settings

    all i get in the logs is this.

    2015-07-17 10:52:21 BonCode AJP Connenctor version 1.0.23

    nothing else is logged.

    localhost 8904 False True False True HTTP_X_FORWARDED_FOR True 3 E:\mywebsites\mywebsite\www\BIN\logs

    I have verified that it is running …Net 4 in the app pool like the other
    sites.

    So what am i missing? I know it has to be something i am overlooking but
    for the life of me can figure out what it is. Any insights would be a
    great help.

    Thank you.

Barbara,
couple of things to check:
a) what is the webport for the new lucee install and what response do you
get when you hit it?
b) are you making the request on the iis server itself? If not can you do
so and see whether you get more expanded error informtation?
c) are the catalina out log files showing anything?

HTH,
Bilal>

a) what is the webport for the new lucee install and what response do you
get when you hit it?

http://127.0.0.1:8804/lucee/admin/server.cfm I get the Main Lucee login
page.
C:\lucee04\tomcat\webapps\ROOT\ this is the webroot inside of Lucee for
the main app.

b) are you making the request on the iis server itself?

Yes I have my host file set up to resolve sites locally. And I am trying
to get to the site from inside the server not the outside.

If not can you do so and see whether you get more expanded error
information?

It doesn’t give any more information even with logging set at a higher
level.

c) are the catalina out log files showing anything?
Here is some of the stuff in the logs.

[mod_cfml] Host Value => dev.mywebsite.org:8804
[mod_cfml] FATAL: Invalid DocRoot: Null or zero-length.
[mod_cfml] Decoded Requst URI => /lb/default.cfm
[mod_cfml] QueryString => null
[mod_cfml] DocRoot Value => null
[mod_cfml] Host Value => dev.wbbrchamber.org:8804
[mod_cfml] FATAL: Invalid DocRoot: Null or zero-length.
[mod_cfml] Decoded Requst URI => /lucee/admin/server.cfm
[mod_cfml] QueryString => null
[mod_cfml] DocRoot Value => null
[mod_cfml] Host Value => 127.0.0.1:8804
[mod_cfml] FATAL: Invalid DocRoot: Null or zero-length.
[mod_cfml] Decoded Requst URI =>
/lucee/res/css/admin-77aade32be11a0b0.css.cfm
[mod_cfml] QueryString => 1437147435339
[mod_cfml] DocRoot Value => null
[mod_cfml] Host Value => 127.0.0.1:8804
[mod_cfml] FATAL: Invalid DocRoot: Null or zero-length.
[mod_cfml] Decoded Requst URI =>
/lucee/admin/resources/js/jquery-1.7.2.min.js.cfm
[mod_cfml] QueryString => null
[mod_cfml] DocRoot Value => null
[mod_cfml] Host Value => 127.0.0.1:8804
[mod_cfml] FATAL: Invalid DocRoot: Null or zero-length.
[mod_cfml] Decoded Requst URI =>
/lucee/admin/resources/js/jquery.blockUI.js.cfm
[mod_cfml] QueryString => null
[mod_cfml] DocRoot Value => null
[mod_cfml] Host Value => 127.0.0.1:8804
[mod_cfml] FATAL: Invalid DocRoot: Null or zero-length.
[mod_cfml] Decoded Requst URI => /lucee/admin/resources/js/admin.js.cfm

All of those logs in the catalina.out are for hits directly to the 8804 port, which is tomcat’s web server. There’s nothing there to indicate requests from the BonCode connector - coming in over 8904 - are actually reaching Tomcat. You might have a connection issue with port 8904. Can you verify Tomcat is up and listening on port 8904, and that it’s not firewalled?

Last, and this doesn’t directly effect your issue yet, but if you used the most recent installer your Tomcat install of mod_cfml is going to need the shared secret key. You’ll want to add the [YourRandomSecretKeyHere] to your BonCode config and make sure the key matches the secret key config in your Tomcat server.xml.

-Jordan----- Original Message -----
From: “Barbara ONeal” <@Barbara_ONeal>
To: lucee@googlegroups.com
Sent: Monday, July 20, 2015 9:04:39 AM
Subject: [Lucee] Re: Brand new install of Lucee on Window Server having site issues

a) what is the webport for the new lucee install and what response do you
get when you hit it?

http://127.0.0.1:8804/lucee/admin/server.cfm I get the Main Lucee login
page.
C:\lucee04\tomcat\webapps\ROOT\ this is the webroot inside of Lucee for
the main app.

b) are you making the request on the iis server itself?

Yes I have my host file set up to resolve sites locally. And I am trying
to get to the site from inside the server not the outside.

If not can you do so and see whether you get more expanded error
information?

It doesn’t give any more information even with logging set at a higher
level.

c) are the catalina out log files showing anything?
Here is some of the stuff in the logs.

[mod_cfml] Host Value => dev.mywebsite.org:8804
[mod_cfml] FATAL: Invalid DocRoot: Null or zero-length.
[mod_cfml] Decoded Requst URI => /lb/default.cfm
[mod_cfml] QueryString => null
[mod_cfml] DocRoot Value => null
[mod_cfml] Host Value => dev.wbbrchamber.org:8804
[mod_cfml] FATAL: Invalid DocRoot: Null or zero-length.
[mod_cfml] Decoded Requst URI => /lucee/admin/server.cfm
[mod_cfml] QueryString => null
[mod_cfml] DocRoot Value => null
[mod_cfml] Host Value => 127.0.0.1:8804
[mod_cfml] FATAL: Invalid DocRoot: Null or zero-length.
[mod_cfml] Decoded Requst URI =>
/lucee/res/css/admin-77aade32be11a0b0.css.cfm
[mod_cfml] QueryString => 1437147435339
[mod_cfml] DocRoot Value => null
[mod_cfml] Host Value => 127.0.0.1:8804
[mod_cfml] FATAL: Invalid DocRoot: Null or zero-length.
[mod_cfml] Decoded Requst URI =>
/lucee/admin/resources/js/jquery-1.7.2.min.js.cfm
[mod_cfml] QueryString => null
[mod_cfml] DocRoot Value => null
[mod_cfml] Host Value => 127.0.0.1:8804
[mod_cfml] FATAL: Invalid DocRoot: Null or zero-length.
[mod_cfml] Decoded Requst URI =>
/lucee/admin/resources/js/jquery.blockUI.js.cfm
[mod_cfml] QueryString => null
[mod_cfml] DocRoot Value => null
[mod_cfml] Host Value => 127.0.0.1:8804
[mod_cfml] FATAL: Invalid DocRoot: Null or zero-length.
[mod_cfml] Decoded Requst URI => /lucee/admin/resources/js/admin.js.cfm


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/1dd93890-a503-4399-84fd-938397971b09%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Barbara,
please make a local version call to the connector if you can.
http://[hostname]/a.cfm?BonCodeConnectorVersion=true

If you get an error there your IIS configuration is problematic. (.net
conflict?)

For some reason the header data support information is not being
transferred to tomcat.

To check simply turn off the mod_cfml valve and see whether you get any
response; then turn it back on.
Any difference?
If not, looking into IIS and your setting file is probably your next step.

-Bilal>

Bilal

The only error i get is the same one i have been getting:

Generic Connector Communication Error:------------------------------
Please check and adjust your setup:
Ensure that Tomcat is running on given host and port.
If this is a timeout error consider adjusting IIS timeout by changing
executionTimeout attribute in web.config (see manual).

In IIS I have the site set to: .net 4.0 integrated

I turned off the mod_cfml and set the sight up in the server.xml file get
the same response.

Which settings file do you want me to look at?

here is the bon settings.

localhost 8904 False True False True HTTP_X_FORWARDED_FOR 3 E:\mywebsite\www\BIN\logs

ok so I finally have the site up and running but I had to actually run the
bon code connector software. On other sites / other servers all i had to do
was drop in the bin folder into the web root and it worked.