BonCodeAJP Connector - Generic Connector Communication Error


#1

So I finally bit the bullet and updated our production server to Lucee. We
updated our test server to Lucee a few weeks ago and haven’t had any issue.
The software between our test and production environment is identical. The
only difference is the volume of traffic. Before upgrading from Railo to
Lucee, our install was rock solid. We could go months without a single
reboot of Tomcat/Railo or IIS. However, that’s all changed since upgrading
to Lucee. After we upgraded, we made sure all of our settings from our
server.xml were merged with Lucee’s install of the new Server.xml. TomCat
doesn’t seem to be crashing as we have FusionReactor running in the
background and we can still serve up requests to any website via port 8888.

I believe the core of the issue is with the BonCode connector.
Sporadically we receive the following message.

Generic Connector Communication Error:

Please check and adjust your setup:

Ensure that Tomcat is running on given host and port.

If this is a timeout error consider adjusting IIS timeout by changing
executionTimeout attribute in web.config (see manual).

An immediate refresh of the page/website and it loads right up. There is no
way to reproduce the error. It occurs on just about all of our roughly 85
sites randomly throughout the day. Prior to upgrading to Lucee we never had
this issue. In case its asked, all of our IIS application pools have the
IIS default 20min timeout. Some higher traffic sites are set to
“AlwaysRunning”

We enabled logging on the boncode connector, and see this in just about all
of the boncode logs:

*2015-04-14 07:27:15 1.0.21 ERROR *

TCP Client level – Server/Port:localhost/8009

Unable to write data to the transport connection: An established
connection was aborted by the software in your host machine.

2015-04-14 07:27:15 One Connection raised an error

I’ve included some settings below that I believe are relevant to diagnosing
the issue.

BonCode Version:

BonCodeAJP Connector Version 1.0.21
using setting file in C:\Windows\BonCodeAJP13.settings

Lucee/Server Info

Windows Server 2012 R1
IIS 8
Lucee 4.5.1.000 final
Apache Tomcat/7.0.61 <-- I tried several versions of tomcat
Java 1.7.0_76 (Oracle Corporation) 64bit

4096mb Ram dedicated to Lucee (32gigs server total)

BonCodeAJP13.settings

localhost
8009
0
True
True
False
False
3
C:\Lucee\BonCodeLogs

A note about the above: I had set equal to what I had in
the server.xml, but that didn’t help with the error.

Connector settings in TomCat Server.xml

A note about the above: In our Railo install, we never had a
connectionTImeout attribute, but figured I would see if it would help.

Would appreciate any help anyone can offer.


#2

I would recommend turing on logging within BonCode to get more detail on
what is actually happening with the communication between IIS and Tomcat.

You can turn on logging by adding/editing the LogLevel, LogDir, and
LogFile params in the BonCode Connector config:
http://boncode.net/connector/webdocs/Tomcat_Connector.htm#_Toc415060639

Warm Regards,
Jordan MichaelsOn 04/14/2015 02:07 PM, Jason Tully wrote:

So I finally bit the bullet and updated our production server to Lucee.
We updated our test server to Lucee a few weeks ago and haven’t had any
issue. The software between our test and production environment is
identical. The only difference is the volume of traffic. Before
upgrading from Railo to Lucee, our install was rock solid. We could go
months without a single reboot of Tomcat/Railo or IIS. However, that’s
all changed since upgrading to Lucee. After we upgraded, we made sure
all of our settings from our server.xml were merged with Lucee’s install
of the new Server.xml. TomCat doesn’t seem to be crashing as we have
FusionReactor running in the background and we can still serve up
requests to any website via port 8888.

I believe the core of the issue is with the BonCode connector.
Sporadically we receive the following message.

Generic Connector Communication Error:

Please check and adjust your setup:

Ensure that Tomcat is running on given host and port.

If this is a timeout error consider adjusting IIS timeout by changing
executionTimeout attribute in web.config (see manual).

An immediate refresh of the page/website and it loads right up. There is
no way to reproduce the error. It occurs on just about all of our
roughly 85 sites randomly throughout the day. Prior to upgrading to
Lucee we never had this issue. In case its asked, all of our IIS
application pools have the IIS default 20min timeout. Some higher
traffic sites are set to “AlwaysRunning”

We enabled logging on the boncode connector, and see this in just about
all of the boncode logs:

*2015-04-14 07:27:15 1.0.21 ERROR *

TCP Client level – Server/Port:localhost/8009

Unable to write data to the transport connection: An established
connection was aborted by the software in your host machine.

2015-04-14 07:27:15 One Connection raised an error

I’ve included some settings below that I believe are relevant to
diagnosing the issue.

BonCode Version:

|
BonCodeAJPConnectorVersion1.0.21
usingsetting file inC:\Windows\BonCodeAJP13.settings
|

Lucee/Server Info

Windows Server 2012 R1
IIS 8
Lucee 4.5.1.000 final
Apache Tomcat/7.0.61 <-- I tried several versions of tomcat
Java 1.7.0_76 (Oracle Corporation) 64bit

4096mb Ram dedicated to Lucee (32gigs server total)

BonCodeAJP13.settings

|

localhost
8009
0
True
True
False
False
3
C:\Lucee\BonCodeLogs

|

A note about the above: I had set equal to what I had
in the server.xml, but that didn’t help with the error.

Connector settings in TomCat Server.xml

|

|

A note about the above: In our Railo install, we never had a
connectionTImeout attribute, but figured I would see if it would help.

Would appreciate any help anyone can offer.


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to lucee+unsubscribe@googlegroups.com
mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com
mailto:lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/63e07ce1-9bd4-410e-b672-f2843253dad1%40googlegroups.com
https://groups.google.com/d/msgid/lucee/63e07ce1-9bd4-410e-b672-f2843253dad1%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.


#3

Spent the night combing through catalinia.*.log, and didn’t find any
errors. It was just full of a ton of “deployDirectory” logs. Also checked
the other logs, and nothing unusual found. Any other suggestions?On Tuesday, April 14, 2015 at 6:05:41 PM UTC-4, Jordan Michaels wrote:

::facepalm:: My apologies, and thanks for your patient reply Jason.

In this case, I would check the Tomcat catalina.out log file to see if
you’re hitting any connection limits or something of that sort. Tomcat
is usually pretty good about logging issues. If it’s closing connections
prematurely or hitting a limit of some kind, it will usually tell you.
That will give you some direction as to what connection settings to
adjust within your server.xml config.

Again, thanks for your patient response. That was very considerate of
you. :wink:

Warm Regards,
Jordan Michaels

On 04/14/2015 02:59 PM, Jason Tully wrote:

Hi Jordan, Thanks for the reply. I already had logging enabled. The
message from the log is in my original post.

On Tuesday, April 14, 2015 at 5:36:25 PM UTC-4, Jordan Michaels wrote:

I would recommend turing on logging within BonCode to get more 
detail on 
what is actually happening with the communication between IIS and 
Tomcat. 

You can turn on logging by adding/editing the LogLevel, LogDir, and 
LogFile params in the BonCode Connector config: 

http://boncode.net/connector/webdocs/Tomcat_Connector.htm#_Toc415060639

<

http://boncode.net/connector/webdocs/Tomcat_Connector.htm#_Toc415060639>

Warm Regards, 
Jordan Michaels 

On 04/14/2015 02:07 PM, Jason Tully wrote: 
 > So I finally bit the bullet and updated our production server to 
Lucee. 
 > We updated our test server to Lucee a few weeks ago and haven’t 
had any 
 > issue. The software between our test and production environment 

is

 > identical. The only difference is the volume of traffic. Before 
 > upgrading from Railo to Lucee, our install was rock solid. We 
could go 
 > months without a single reboot of Tomcat/Railo or IIS. However, 
that’s 
 > all changed since upgrading to Lucee.  After we upgraded, we made 
sure 
 > all of our settings from our server.xml were merged with Lucee’s 
install 
 > of the new Server.xml. TomCat doesn't seem to be crashing as we 

have

 > FusionReactor running in the background and we can still serve up 
 > requests to any website via port 8888. 
 > 
 > I believe the core of the issue is with the BonCode connector. 
 > Sporadically we receive the following message. 
 > 
 > *Generic Connector Communication Error:* 
 > 
 > *Please check and adjust your setup:* 
 > 
 > *Ensure that Tomcat is running on given host and port.* 
 > 
 > *If this is a timeout error consider adjusting IIS timeout by 
changing 
 > executionTimeout attribute in web.config (see manual).* 
 > 
 > 
 > An immediate refresh of the page/website and it loads right up. 
There is 
 > no way to reproduce the error. It occurs on just about all of our 
 > roughly 85 sites randomly throughout the day. Prior to upgrading 

to

 > Lucee we never had this issue. In case its asked, all of our IIS 
 > application pools have the IIS default 20min timeout. Some higher 
 > traffic sites are set to "AlwaysRunning" 
 > 
 > 
 > We enabled logging on the boncode connector, and see this in just 
about 
 > all of the boncode logs: 
 > 
 > *2015-04-14 07:27:15 1.0.21 ERROR * 
 > 
 > *TCP Client level -- Server/Port:localhost/8009* 
 > 
 > *Unable to write data to the transport connection: An established 
 > connection was aborted by the software in your host machine.* 
 > 
 > *2015-04-14 07:27:15 One Connection raised an error* 
 > 
 > I’ve included some settings below that I believe are relevant to 
 > diagnosing the issue. 
 > 
 > *BonCode Version:* 
 > 
 > | 
 > BonCodeAJPConnectorVersion1.0.21 
 > usingsetting file inC:\Windows\BonCodeAJP13.settings 
 > | 
 > 
 > *Lucee/Server Info* 
 > 
 > Windows Server 2012 R1 
 > IIS 8 
 > Lucee 4.5.1.000 final 
 > Apache Tomcat/7.0.61  <-- I tried several versions of tomcat 
 > Java 1.7.0_76 (Oracle Corporation) 64bit 
 > 
 > 4096mb Ram dedicated to Lucee (32gigs server total) 
 > 
 > 
 > *BonCodeAJP13.settings* 
 > 
 > | 
 > <Settings> 
 > <Server>localhost</Server> 
 > <Port>8009</Port> 
 > <MaxConnections>0</MaxConnections> 
 > <EnableRemoteAdmin>True</EnableRemoteAdmin> 
 > <EnableHeaderDataSupport>True</EnableHeaderDataSupport> 
 > <ForceSecureSession>False</ForceSecureSession> 
 > <AllowEmptyHeaders>False</AllowEmptyHeaders> 
 > <LogLevel>3</LogLevel> 
 > <LogDir>C:\Lucee\BonCodeLogs</LogDir> 
 > </Settings> 
 > 
 > | 
 > 
 > 
 > A note about the above: I had <MaxConnections> set equal to what 
I had 
 > in the server.xml, but that didn't help with the error. 
 > 
 > 
 > *Connector settings in TomCat Server.xml* 
 > 
 > | 
 > <Connector port="8009" 
 >      acceptorThreadCount="6" 
 >      maxThreads="1500" 
 >      minSpareThreads="150" 
 >      maxSpareThreads="500" 
 >      tcpNoDelay="true" 
 >      connectionTimeout="180000" 
 >      enableLookups="false" 
 >      protocol="AJP/1.3" 
 >      redirectPort="8443" 
 > /> 
 > | 
 > 
 > A note about the above: In our Railo install, we never had a 
 > connectionTImeout attribute, but figured I would see if it would 
help. 
 > 
 > 
 > Would appreciate any help anyone can offer. 
 > 
 > -- 
 > You received this message because you are subscribed to the 

Google

 > Groups "Lucee" group. 
 > To unsubscribe from this group and stop receiving emails from it, 
send 
 > an email to lucee+un...@googlegroups.com <javascript:> 
 > <mailto:lucee+un...@googlegroups.com <javascript:>>. 
 > To post to this group, send email to lu...@googlegroups.com 
<javascript:> 
 > <mailto:lu...@googlegroups.com <javascript:>>. 
 > To view this discussion on the web visit 
 > 

https://groups.google.com/d/msgid/lucee/63e07ce1-9bd4-410e-b672-f2843253dad1%40googlegroups.com

<

https://groups.google.com/d/msgid/lucee/63e07ce1-9bd4-410e-b672-f2843253dad1%40googlegroups.com>

 > 
<

https://groups.google.com/d/msgid/lucee/63e07ce1-9bd4-410e-b672-f2843253dad1%40googlegroups.com?utm_medium=email&utm_source=footer

<

https://groups.google.com/d/msgid/lucee/63e07ce1-9bd4-410e-b672-f2843253dad1%40googlegroups.com?utm_medium=email&utm_source=footer>>.

 > For more options, visit https://groups.google.com/d/optout 
<https://groups.google.com/d/optout>. 


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to lucee+un...@googlegroups.com <javascript:>
<mailto:lucee+un...@googlegroups.com <javascript:>>.
To post to this group, send email to lu...@googlegroups.com
<javascript:>
<mailto:lu...@googlegroups.com <javascript:>>.
To view this discussion on the web visit

https://groups.google.com/d/msgid/lucee/b6a19568-3936-49d6-86cb-da9b0f6c9303%40googlegroups.com

<
https://groups.google.com/d/msgid/lucee/b6a19568-3936-49d6-86cb-da9b0f6c9303%40googlegroups.com?utm_medium=email&utm_source=footer>.

For more options, visit https://groups.google.com/d/optout.


#4

Jason,
to isolate the source of the issue
can you temporarily try to force re-connections on the connector side and
let us know if this does it for you:

In the BonCodeAJP13.settings (normally in c:\windows) file, add or change a
line like this:
0

Then, restart IIS.

Thanks,
Bilal>>


#5

Bilal, Thank you. I have the that setting enabled
(0) and from what I can see, the problem
has gone away. Strange that it worked on Railo for quite sometime without
this setting.

Is there any downside/trade-off to having it re-establish a connection
every time using this setting?

ThanksOn Wednesday, April 15, 2015 at 11:29:21 AM UTC-4, Bilal wrote:

Jason,
to isolate the source of the issue
can you temporarily try to force re-connections on the connector side and
let us know if this does it for you:

In the BonCodeAJP13.settings (normally in c:\windows) file, add or change
a line like this:
0

Then, restart IIS.

Thanks,
Bilal


#6

Investigating the issue for now.

There is a slight overhead for establishing connections but if your CPU is
not going critical you will be OK keeping the setting as is.On Friday, April 17, 2015 at 7:08:53 AM UTC-4, Jason Tully wrote:

Bilal, Thank you. I have the that setting enabled
(0) and from what I can see, the problem
has gone away. Strange that it worked on Railo for quite sometime without
this setting.

Is there any downside/trade-off to having it re-establish a connection
every time using this setting?

Thanks


Generic Connector Communication Error and BonCodeAJP
#7

Hi,

I just installed Lucee on a server and run into this strange problem:

  • Installation went fine
  • IIS is running
  • Tomcat is running, Lucee is running
  • I can access the new application direct on the server with the browser
    via the url www.mydomain.com

Now when I try to open the application from a remote computer I get this
error message:

Generic Connector Communication ErrorPlease check and adjust your
setup:Ensure that Tomcat is running on given host and port.If this is a
timeout error consider adjusting IIS timeout by changing executionTimeout
attribute in web.config (see manual).

The boncode log has this entry:

TCP Client level – Server/Port:localhost/8009Value cannot be
nullParameter name: buffer

BonCodeAJP Connector Version 1.0.25
Windows Server 2003 with .net 3.5.1

I changed all kind of settings in the boncode and the tomcat configuration
with no success.
Did someone else run into this problem before and know how to fix it?


#8

Can you talk about your server setup a bit more? Is the server something local (like a box sitting at your feet), or is it something behind a firewall or in some kind of cloud environment?

The path that a local browser takes should be nearly identical to the path that a remote browser would take, so it seems reasonable that if your request works locally, then whatever the problem is is outside the local server environment.–
Kind regards,
Jordan Michaels
Vivio Technologies

----- Original Message -----
From: “Marc Ackermann” <@Marc_Ackermann>
To: “Lucee” lucee@googlegroups.com
Sent: Tuesday, December 15, 2015 8:10:40 AM
Subject: [Lucee] BonCodeAJP Connector - Generic Connector Communication Error

Hi,

I just installed Lucee on a server and run into this strange problem:

  • Installation went fine
  • IIS is running
  • Tomcat is running, Lucee is running
  • I can access the new application direct on the server with the browser
    via the url www.mydomain.com

Now when I try to open the application from a remote computer I get this
error message:

Generic Connector Communication ErrorPlease check and adjust your
setup:Ensure that Tomcat is running on given host and port.If this is a
timeout error consider adjusting IIS timeout by changing executionTimeout
attribute in web.config (see manual).

The boncode log has this entry:

TCP Client level – Server/Port:localhost/8009Value cannot be
nullParameter name: buffer

BonCodeAJP Connector Version 1.0.25
Windows Server 2003 with .net 3.5.1

I changed all kind of settings in the boncode and the tomcat configuration
with no success.
Did someone else run into this problem before and know how to fix it?


Love Lucee? Become a supporter and be part of the Lucee project today! - http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/8bdc0ca3-75e0-48bd-9dfc-d72c2c6f32b2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


#9

Yeah, makes no sense. The only thing I can think of is that something about hitting the site from the outside environment is effecting the path that the request takes in some way. So, the request is sent normally when it’s sent locally, but when it gets sent remotely something about the request changes so that it gets routed differently.

Was this a fresh install? Did you install over anything else or along-side anything else?

Turning on the BonCode Connector’s detailed logging may also yield more clues about what might be happening…–
Kind regards,
Jordan Michaels
Vivio Technologies

----- Original Message -----
From: “Marc Ackermann” <@Marc_Ackermann>
To: “Lucee” lucee@googlegroups.com
Sent: Tuesday, December 15, 2015 2:20:48 PM
Subject: Re: [Lucee] BonCodeAJP Connector - Generic Connector Communication Error

This is a virtual machine.
We can open html pages from that server with the browser on the network
computer. Just .cfm pages return that error. So I don’t think that the
problem is caused by the firewall. I also deactivated the windows firewall
but no positiv effect.
Why is opening with local browser fine and remote return that Boncode
error? I really don’t get it.
I made serveral ColdFusion, Railo and Lucee installations in the past but
never run into such a strange problem.

Am Dienstag, 15. Dezember 2015 20:36:10 UTC+1 schrieb Jordan Michaels:

Can you talk about your server setup a bit more? Is the server something
local (like a box sitting at your feet), or is it something behind a
firewall or in some kind of cloud environment?

The path that a local browser takes should be nearly identical to the path
that a remote browser would take, so it seems reasonable that if your
request works locally, then whatever the problem is is outside the local
server environment.


Kind regards,
Jordan Michaels
Vivio Technologies

----- Original Message -----
From: “Marc Ackermann” <ma...@marcackermann.com <javascript:>>
To: “Lucee” <lu...@googlegroups.com <javascript:>>
Sent: Tuesday, December 15, 2015 8:10:40 AM
Subject: [Lucee] BonCodeAJP Connector - Generic Connector Communication
Error

Hi,

I just installed Lucee on a server and run into this strange problem:

  • Installation went fine
  • IIS is running
  • Tomcat is running, Lucee is running
  • I can access the new application direct on the server with the browser
    via the url www.mydomain.com

Now when I try to open the application from a remote computer I get this
error message:

Generic Connector Communication ErrorPlease check and adjust your
setup:Ensure that Tomcat is running on given host and port.If this is a
timeout error consider adjusting IIS timeout by changing executionTimeout
attribute in web.config (see manual).

The boncode log has this entry:

TCP Client level – Server/Port:localhost/8009Value cannot be
nullParameter name: buffer

BonCodeAJP Connector Version 1.0.25
Windows Server 2003 with .net 3.5.1

I changed all kind of settings in the boncode and the tomcat configuration
with no success.
Did someone else run into this problem before and know how to fix it?


Love Lucee? Become a supporter and be part of the Lucee project today! -
http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com <javascript:>.

To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/8bdc0ca3-75e0-48bd-9dfc-d72c2c6f32b2%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


Love Lucee? Become a supporter and be part of the Lucee project today! - http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/f618afdf-e2c6-4b6b-80bb-232d61b59b14%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


#10

This is a virtual machine.
We can open html pages from that server with the browser on the network
computer. Just .cfm pages return that error. So I don’t think that the
problem is caused by the firewall. I also deactivated the windows firewall
but no positiv effect.
Why is opening with local browser fine and remote return that Boncode
error? I really don’t get it.
I made serveral ColdFusion, Railo and Lucee installations in the past but
never run into such a strange problem.Am Dienstag, 15. Dezember 2015 20:36:10 UTC+1 schrieb Jordan Michaels:

Can you talk about your server setup a bit more? Is the server something
local (like a box sitting at your feet), or is it something behind a
firewall or in some kind of cloud environment?

The path that a local browser takes should be nearly identical to the path
that a remote browser would take, so it seems reasonable that if your
request works locally, then whatever the problem is is outside the local
server environment.


Kind regards,
Jordan Michaels
Vivio Technologies

----- Original Message -----
From: “Marc Ackermann” <ma...@marcackermann.com <javascript:>>
To: “Lucee” <lu...@googlegroups.com <javascript:>>
Sent: Tuesday, December 15, 2015 8:10:40 AM
Subject: [Lucee] BonCodeAJP Connector - Generic Connector Communication
Error

Hi,

I just installed Lucee on a server and run into this strange problem:

  • Installation went fine
  • IIS is running
  • Tomcat is running, Lucee is running
  • I can access the new application direct on the server with the browser
    via the url www.mydomain.com

Now when I try to open the application from a remote computer I get this
error message:

Generic Connector Communication ErrorPlease check and adjust your
setup:Ensure that Tomcat is running on given host and port.If this is a
timeout error consider adjusting IIS timeout by changing executionTimeout
attribute in web.config (see manual).

The boncode log has this entry:

TCP Client level – Server/Port:localhost/8009Value cannot be
nullParameter name: buffer

BonCodeAJP Connector Version 1.0.25
Windows Server 2003 with .net 3.5.1

I changed all kind of settings in the boncode and the tomcat configuration
with no success.
Did someone else run into this problem before and know how to fix it?


Love Lucee? Become a supporter and be part of the Lucee project today! -
http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com <javascript:>.

To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/8bdc0ca3-75e0-48bd-9dfc-d72c2c6f32b2%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


#11

Ok, problem solved. I can access the application from the remote computer
via the server ip. So this is a problem with the domain setup or a firewall
in the customer company network. They have to fix that. Definitely no
problem in BonCode, Tomcat, Lucee, IIS or our application.


#12

I realize this is an old post but we are having a similar problem and I would like to know what setting in the BonCodeAJP.settings was changed here. Its not showing up in this post. Can you please re-type it?
"…
BilalApr '15
Jason,
to isolate the source of the issue
can you temporarily try to force re-connections on the connector side and
let us know if this does it for you:

In the BonCodeAJP13.settings (normally in c:\windows) file, add or change a
line like this:
0

Then, restart IIS.

Thanks,
Bilal>>
…"

Thanks,
Mike


#13

@mikeysrig
Unfortunately I do not remember the particular details. I have looked at the old google groups and see that the entry was deleted.
I would first run an upgrade today before looking at anything else. As with any software we made updates and fixes that otherwise would not be there.
http://www.boncode.net/boncode-connector/upgrading-railo-or-lucee-connector

Best,
Bilal


#14

Bilal,
Thank you for your reply. I appreciate your input.
Mike


#15

I am new with Lucee (used CF a long time). In any case, I have also had intermittent errors with message “Generic Connector Communication Error” etc. The idea of forcing re-connections seems fine for now, but I do not understand what to do with “0” mentioned above. Do I literally just add a new line in the BonCodeAJP13.settings file with just a 0 in the line? Add that anywhere in the file or in a specific location?

This is running IIS on Windows 2016 Datacenter.

Thanks.

Here is the current file:

<Settings>
<Server>localhost</Server>
<Port>8009</Port>
<EnableRemoteAdmin>True</EnableRemoteAdmin>
<EnableHeaderDataSupport>True</EnableHeaderDataSupport>
<ForceSecureSession>False</ForceSecureSession>
<AllowEmptyHeaders>False</AllowEmptyHeaders>
<ModCFMLSecret>[long code]</ModCFMLSecret>
</Settings>

#16

The “0” mentioned above was probably part of a tag that didn’t copy and paste correctly. You can view a list of options available for the settings file here:

http://boncode.net/connector/webdocs/Tomcat_Connector.htm#_Toc483166303

Chances are that the “0” mentioned above was one of those settings that did NOT default to 0.

Hope this helps.