Anybody want to sell a ColdFusion Licenses

I tried to make the switch from ACF to Lucee but unfortunately I was unable to make it happen as one of my sites would not run due to a large amount of cookies/larger header and I just could not get it work. I’ll be coming back in the future when I launch a site that I believe will work on it and I need to expand to an additional server

As this is the place where ex ACF users meet I was wondering if anybody has made a switch to Lucee and has a CF2021 or better still 2023 license that they would like to sell?

You would be better off spending a few dollars with a ColdFusion developer who more than likely has a solution for your problem, rather than buying a license.

@Brad_Wood for example, works for a ColdFusion developer company and has had his hand in personally developing commandbox

@carehart has been troubleshooting and writing about ColdFusion longer than some have been in IT.

@pfreitag and others all have extensive knowledge and more than likely could fix your problem far less costly and faster than you would expect.

1 Like

Ortus has done many ACF to Lucee conversions for our clients and were always happy to help.

I would highly recommend ensuring there is a ticket entered for this cookie issue you describe. I’ve never heard of this issue, but if there is a bug or incompatibility, I’m sure Lucee will want to fix it. It’s quite likely this will be cheaper than an ACF license.


I’m not sure if it’s a bug as such. It’s related to me having a LOT of cookies causing large headers. IIS works straight out of the box (It was a while ago when I first set the site up but I think it worked on HTTPS but not HTTP). I’d tried with help of others to change Lucee settings to make it work, but could not get it working. There is a lengthy ticket about this

Happy to post it as an issue to be looked at, where would I do that? :slight_smile:

Thanks Terry, you might be right on that one :slight_smile: I just thought a ColdFusion upgrade would quickly being me up to date. Charlie has indeed helped me in the past on many occasions with my CF, and I think Peter has also :slight_smile:

You appear to be talking about IIS proxying SSL traffic which seems like it has nothing at all to do with “a large amount of cookies/larger header”. There may already be a fix for whatever your issue was (or perhaps there was always a fix).

Which Lucee settings? To make what work exactly?

Can you link us to it? I searched through the ticket tracker but didn’t find it right off. I can’t find any tickets in JIRA reported by your name or that seem to related to large numbers of cookies.

It was the ticket I mentioned further up where I discussed trying to find a solution (I don’t have a Jira ticket in for this, not sure how/where I would do that)

Just to clarify the HTTP vs HTTPS was when I was using IIS with ACF, and to be honest it was a few years ago when I first set up the platform and I am not 100% sure this was the case, I just seem to remember it was.

The URL for JIRA is here
which you can find on the main site under the “Support” drop down menu. Also note, a discussion in the community forums is not the same as a “ticket”. The Lucee developers don’t really frequent these forums and if there’s not a ticket in JIRA, “the bug doesn’t exist” according to Micha :slight_smile:

That said, I’m not sure you were actually experiencing a Lucee bug, but rather a limit in the header size of one of your web servers, proxies, or servlet container. I skimmed through your thread, and it wasn’t even clear what actual error you were getting and what piece of software was throwing the error. I would recommend some basic troubleshooting whether it was

  • IIS
  • BonCode
  • Tomcat
  • Lucee
  • Something else?

rejecting the request, and then hone in where the setting is in that specific piece of software to allow larger headers. So far as I know Lucee has no limit to the size of headers it will process, so the requests were likely being blocked upstream. Also testing a request sent directly to Tomcat’s HTTP listener port will be very helpful in eliminating moving parts to help test one thing at a time.

There is a max headersize in tomcat 9, which by default maybe far too small for your code.

8KB is the default in Tomcat 9

you find this value in server.xml


I think that’s fair to only consider issues in Jira :slight_smile:

With regards to where the issue lies. The server was a clone of an existing server that was running fine with ACF. I replicated the site under a different domain for test purposes and the only thing I changed was removing ACF and replacing it with Lucee. The IIS settings were not changed at all.

I have to presume it’s something to do with a configuration somewhere in either BonCode or Tomcat, not that I am familiar with their inner workings, quite the opposite.

My advice to you is to stop presuming. Drill down and figure out specifically where the error is coming from. What is the exact wording of the error message? What does it look like (colors, images, etc)? Can you Google the wording? Do you have a screenshot? What log files does it appear in? Does it still happen if you hit Tomcat’s HTTP port directly? Heck, does it happen in CommandBox? Find out what bit of your stack is erroring. You can’t fix an issue if you don’t know where it is.


I say presume from the knowledge gained testing as per the thread. It’s pretty long with 81 posts. So when I get a minute over the next few days I’ll put a summary together of the issue, how to replicate and what was tried (with partial but not full success)

Well, since you made your app work on port 8888, this is absolutely NOT an Lucee issue. I really can’t say what it is in your specific issue. From what I have read in your posts and my direct conversation (PMs) with you, I just believe the same as @bdw429s . If you made it work on a new ACF installation already, it might be a setting that the installer did already, but that you are not aware of, so you might think its something dealing with Lucee. Its not. Your app works on port 8888, but not on IIS with AJP. This is where I’d look into, and you need to debug it, not try and error.