Announcing Lucee 5.3.2 Final (

Hello again, my fellow Lucites. Better late than never, as the old saying goes! We’re a bit late in announcing the final release of 5.3.2, following its Release Candidate period. But, to quote actor Judd Nelson from the movie The Breakfast Club,Don’t you want to hear my excuse?” (Try not to feel old.)

It’s been a very busy Spring on the administrative/organizational side of things with Lucee, with the demands of our annual General Assembly, and the big move to Open Collective for more transparent management of Lucee (which, by the way, is still underway, so please note that Open Collective doesn’t yet present a complete picture of Lucee’s finances and such). Now that all that is behind us, we can return more of our collective focus to shipping Lucee releases!

Today we’re announcing the final release of Lucee 5.3.2 ( There were just 2 regressions that we caught during the RC period (2239 and 2240), so that brings the total # of tickets covered by 5.3.2 to 67. Here’s the full 5.3.2 ticket list:

Ticket Summary
LDEV-2240 Regression: felix log growing
LDEV-2239 modern debugging template filter reset doesn’t work
LDEV-2217 CFFEED returns struct with empty keys, bonkers content
LDEV-2216 Error in RamCache run can turn into CPU hog
LDEV-2211 cfdbinfo is slow with MySQL Connector/J 8.0.x driver
LDEV-2198 AxisFault when return object is complex cfc
LDEV-2196 XmlSearch returning empty arrays after update
LDEV-2195 extend “org.osgi.framework.system.packages” with “”
LDEV-2194 function ListFindNoCase in precompiled code no longer works
LDEV-2192 Modern.cfc addresses js function as cfml function
LDEV-2191 ListLast no longer works for old Lucee archives (.las)
LDEV-2183 debug-template Classic.cfc with error after update ro
LDEV-2175 When using the extract() method and a wrong argument, a false error message appears
LDEV-2152 Recursive directoryList Sort is Depth First instead of Breadth First
LDEV-2136 Auto installed extensions don’t follow redirects
LDEV-2129 Calling canonicalize() with an empty string returns NULL
LDEV-2126 GetTimeZoneInfo() include SHORT display name in results, i.e. PST
LDEV-2114 IsIpInRange() returns incorrect false values
LDEV-2105 Lucee does not forget templates deleted
LDEV-2104 allow queryformat=struct when requesting data from a CFC
LDEV-2100 LuceeAjax.js does not bind empty values
LDEV-2099 LuceeAjax.js does not correctly encode curly braces in cfajaxproxy JSON arguments
LDEV-2095 function extract only supports zip and tar
LDEV-2084 query.cachedAfter default value for query.cachedWithin
LDEV-2083 FileGetMimeType() for .m4a throws java.lang.NullPointerException
LDEV-2081 dateFormat doesn’t support week of year
LDEV-2080 Performance Degradation with struct.get
LDEV-2077 Lucee 5.3 is able to hang on Linux, and have connection failures on Windows under concurrency
LDEV-2068 listFirst, listLast changed default behavior for empty fields in 5.3
LDEV-2066 add possibility to block variable usage within cfquery
LDEV-2056 Closures lose scope when using dynamic proxy
LDEV-2055 mapping-tag no longer works
LDEV-2052 overwrite=true no longer works in cfzip action=unzip
LDEV-2051 import not working for application component mappings
LDEV-2048 datasource logger fails with big data
LDEV-2047 flying saucer (PDF) throws error: Attribute page is not allowed for statement document
LDEV-2046 structGet() incompatibility with ACF
LDEV-2043 writable cgi scope case sensitive
LDEV-2032 Collection disappear after restart of lucee
LDEV-2029 cfajaxproxy extension doesn’t create proxy
LDEV-2028 cfajaxproxy not supported in 5.3
LDEV-2014 CFEXECUTE arguments does not properly handle arrays
LDEV-2008 scheduled task errors when shutting down tomcat
LDEV-2005 GetBaseTemplatePath() errors in JSR-223 context
LDEV-1990 GC Overhead limit exceeded with debugging enabled in 5.3
LDEV-1989 CFZIP: add support for password and encryptionalgorithm attributes
LDEV-1953 Datasource JDBC Type 4 driver mysql lucee admin page is wrong on some features now
LDEV-1951 scheduled tasks shouldn’t stop running after an exception
LDEV-1938 datasource specific ORM settings not possible in Lucee
LDEV-1937 ORM Dialect in Application.cfc prevents multi datasource/multi dialect

In related news, we’ll wrap up the May sprint in the next 10-14 days, and shortly after that we’ll announce the Release Candidate for 5.3.3, which will be in RC status for about a month in June, following which we’ll make it a final release in early July.

The next sprint is scheduled for July, so as always, if we didn’t get to your favorite ticket(s) with this latest release, please comment/vote in Jira, and we’ll do our best to give priority to your problem/request.

Back to the topic at the beginning of the post. In case it wasn’t clear, that was a desperate cry for help. I’m exaggerating, since Team Lucee is always cool, and never desperate. That said, the current team is stretched thin (including yours truly!), and we’re always ready to welcome more help, whether in the form of financial, administrative, and/or technical stewardship of Lucee. If you have one or more of these to give to Lucee, please do get in touch. At present, increasing the number of full Lucee members is our top priority, but we have plenty of opportunities for individual roles as well.

As with all Lucee releases, the credit goes to our hardworking core team, while any mistakes are on me. Please head over to the downloads site, grab the latest, and show us what you can do with Lucee!

Thanks for listening.

Lucee Product Manager


P.S. I will release the Docker images for 5.3.2 tomorrow, please stand by… :smiley:


Just updated to this version and one of my apps has a compile issue…

zip action="list" file=Arguments.File name="local.zipListing" recurse=true;
template; Error: Missing [;] or [line feed] after expression ;

That should still be valid shouldn’t it?

This worked OK on

Just spun up a instance via CommandBox and that zip code ran ok for me.

Don’t know whether clearing your context’s cfclasses folder would make any difference?

It’s inside a Docker container, so they wouldn’t exist… I’ll have play with a few things…


It looks like it might have been down to the setting handleUnquotedAttrValueAsString. We were not setting (or unsetting) this with our setup code.

I’ve change the code so that it treats unquoted as variables, then removed the code that was compiling mappings (as this doesn’t seem to care if that value is set or not) and the app isn’t crashing. Obviously more testing is needed on my end, but that ‘issue’ has gone.

1 Like

This is a really solid release, 5.3.1 had some problems, but 5.3.2 resolves them

anybody who has been hanging back on testing and moving to this release should give this release a go


OK… My issue wasn’t down to the setting at all…

It’s because we install with the lucee-light.jar file… The CFZip has been moved into an Extension, which didn’t show up in the extensions page, installing this fixed the issue.



Thanks for the feedback, @Zackster. Glad to hear we hit some targets. Thanks as always for all the work you put in to keep us on our toes and make Lucee better!


Getting error. Screen shot attached.

Also got same error if I first downgrade from to and then try to upgrade to

The Docker image for Lucee is now available;


Full announcement post is here;