Adding Mapped Azure FileShare to Lucee Tomcat Server through IIS

I have an Azure VM Windows Server 2019 with lucee installed. I am using the Boncode Connecter alongside mod_cfml that comes with the Lucee Installer to connect to IIS.
All is working fine. Even when I create a website with a physical path on the C drive.

I have a mapped Azure File Share on Z drive and I can access files and all in the directory.
The issue I currently have is creating a website with the mapped drive (azure fileshare) as a physical path.
While creating the website from IIS, I was able to test the connection to the drive with the azure storage credentials (I created a local user with that credential already and added it to the IIS_USRS group.). The website was successfully created with that drive and was successfully Authenticated and Authorised to access the mapped path (physical path).

Note that I used this path like this:

not Z:/.

If I try accessing the website, it keeps redirecting multiple times. I noticed this happens for only .cfm files because .HTML files are loading correctly. Obviously, this has to do with the Apache Tomcat server handling cfm pages.

The redirect link is usually like this:

But when I access the site from (not localhost), it shows a blank page. No error. Nothing. Just blank.

I tried modifying the tomcat server.xml by:

  1. Commenting out the mod_cfml and creating a new host
  2. Added the Mapped file share address to the docBase like this:
      <Host name="localhost" appBase="webapps">
       <Context path="" docBase="//" />

I checked the log and this was throwing an error when I try starting the server (server wont start)

The main resource set specified [\\\acishare\web] is not valid

  1. Changed Apache Logon user to the storage account user I created.

All these weren’t able to solve the problem.

Am I doing something wrong? Kindly assist. I will really appreciate

Don’t forget to tell us about your stack!

OS: Windows Server 2019 (10.0) 64bit
Java Version: 11.0.11 (AdoptOpenJDK) 64bit
Tomcat Version: Apache Tomcat/9.0.46
Lucee Version: Lucee

try using // instead of \\ for the unc paths

HI Zack, Thanks for your reply.
Yes. I did that. I used the back and forward slashes but still same issues.

you said you changed the apache login, did you change the tomcat login too?

Super Zack! Thanks

For an unknown reason, I felt changing the Tomcat login should also reflect changes to the Apache.
Apparently, I had also changed the Apache Login but reverted the change on Tomcat.
SO, I went to the Lucee Tomcat Control and changed the login, then went to services - services.msc, and changed the Login for Apache too.

It worked!! I am still setting some things. I will let you know how my migration continues