Adding Efflare’s 64bit Java ImageCR3 CFX to Lucee - solved

As much a this community has a disdain for CFX add ins :slight_smile: I am attempting to add a java CFX to lucee without much success.

I have the Java version of Efflare’s ImageCR3 that I have successfully added to ACF version 11 and am now trying to add it to a Lucee installation.

The Instructions for ACF are:

  • Register a Java CFX tag with the tag name “cfx_imagecr3”, and class name “ImageCR3”.
  • Add the absolute path to imagecr3.jar, in the installation directory, to your “ColdFusion Class Path” path in the CF Administrator. You will find this under “Server Settings”, then “Java and JVM”
  • Restart Coldfusion as directed.
  • Start the “Efflare ImageCR 3 Service”.

Adding CFX tags to Lucee is apparently different and I am confused. How would I add the absolute Class Path so that Lucee can find the imagecr3.jar?

As I said, and I have seen others post, I needed to use Efflare’s 64bit Java version of the ImageCR3 CFX with my configuration. (I know there is an image tag, but it would require rewriting 90+ apps we have developed)

I am not “Java guy” and have a passing familiarity with Tomcat but after much googling and reading I found that all I needed to do to get Tomcat to see the class path was to install the ImageCR3 as specified in it’s installer and then add the following line to the file in the tomcat \bin folder.

CLASSPATH="C:\Program Files (x86)\Efflare\ImageCR3Service\imagecr3.jar"

Once I restated Tomcat/Lucee I could add the CFX name and class to the Lucee server and it works like a charm!

I will leave this here just in case others are looking to do the same.


I’m new to Lucee (Lucee and I’m also trying to install ImageCR3. I tried adding the classpath to the file suggested, and I even tried adding the path to the Tomcat Service controller under the Java tab. After each attempt, I restarted Lucee and tried to add the CFX tag and each time I did that I received this as an error “com/allaire/cfx/CustomTag” with no additional explanation. Can anyone explain what this error message is supposed to tell you?

Lucee CFX Settings

Make sure you have the 64bit version of ImageCR3 and install.

Check the service Efflare ImageCR 3 Service is running in windows services, its a bit buggy and resizing a file it doesnt like can cause the service to stop.

copy the imagecr3.jar from “C:\Program Files\Efflare\ImageCR3Service or whereever you install it to”, to C:\lucee\tomcat\lib\

then go into the lucee server admin and add to the CFX tags

try adding cfx_imagecr3 in the name then ImageCR3 then click save

after adding to verify its working try running a simple resize
<cfx_imagecr3 load=“C:\inetpub\wwwroot\dog.jpg”

1 Like

Thanks for your response. I had already tried all of your suggestions w/ no success. We ended up changing our code to not use cfx_imagecr3.

That’s probably for the best as even though the plugin was faster than cfimage found it to be a bit buggy as the 64bit version never came out of BETA