Accessing lucee server administrator in basic docker install

Greetings,

I am following along here https://hub.docker.com/r/lucee/lucee4-nginx/ to
setup the lucee/lucee4-nginx docker container. I have the docker container
running and processing basic .cfm files which I created manually in the
terminal. Awesome.

My problem is that I can’t seem to figure out how to access the lucee admin
so I can do things like setup a datasource (so my app can run).

My local docker-machine IP is 192.168.99.100. The way I am reading the
description on the docker container, I should be able to access the admin
control panel via: http://192.168.99.100/lucee/admin - but this is not
working (403 forbidden). Just tinkering around I removed the nginx config
rule for location ^~ /lucee deny all but that just changed the 403 to a 404
not found.

One last note: I notice the container description says the /var/www root
should have a hello world file. For me, it was empty. So maybe the lucee
admin should also be in the web root and for some reason isn’t?

Thanks for any insight,
Brian

Try hitting the server and web admins directly and see if that works.

In your case they should be:

http://192.168.99.100/lucee/admin/server.cfm
http://192.168.99.100//lucee/admin/web.cfm​On Wed, Feb 17, 2016 at 9:51 AM, Brian FitzGerald <@Brian_FitzGerald> wrote:

Greetings,

I am following along here https://hub.docker.com/r/lucee/lucee4-nginx/ to
setup the lucee/lucee4-nginx docker container. I have the docker container
running and processing basic .cfm files which I created manually in the
terminal. Awesome.

My problem is that I can’t seem to figure out how to access the lucee
admin so I can do things like setup a datasource (so my app can run).

My local docker-machine IP is 192.168.99.100. The way I am reading the
description on the docker container, I should be able to access the admin
control panel via: http://192.168.99.100/lucee/admin - but this is not
working (403 forbidden). Just tinkering around I removed the nginx config
rule for location ^~ /lucee deny all but that just changed the 403 to a
404 not found.

One last note: I notice the container description says the /var/www root
should have a hello world file. For me, it was empty. So maybe the lucee
admin should also be in the web root and for some reason isn’t?

Thanks for any insight,
Brian


Love Lucee? Become a supporter and be part of the Lucee project today! -
http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/ba173f6f-fcdf-48dc-89f5-00151ced1565%40googlegroups.com
https://groups.google.com/d/msgid/lucee/ba173f6f-fcdf-48dc-89f5-00151ced1565%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

Brian,

Check my blog post here:
http://dnando.github.io/blog/2014/11/04/ssh-tunneling-coldfusion-lockdown-technique/

Highly suggest using ssh tunneling to lockdown and access both lucee and
acf admin directories. Almost all vulnerabilities have been via open access
to these directories.

Aria Media Sagl
+41 91 600 9601
Skype: ariamediaOn 17 Feb 2016, at 15:51, Brian FitzGerald <@Brian_FitzGerald> wrote:

Greetings,

I am following along here https://hub.docker.com/r/lucee/lucee4-nginx/ to
setup the lucee/lucee4-nginx docker container. I have the docker container
running and processing basic .cfm files which I created manually in the
terminal. Awesome.

My problem is that I can’t seem to figure out how to access the lucee admin
so I can do things like setup a datasource (so my app can run).

My local docker-machine IP is 192.168.99.100. The way I am reading the
description on the docker container, I should be able to access the admin
control panel via: http://192.168.99.100/lucee/admin - but this is not
working (403 forbidden). Just tinkering around I removed the nginx config
rule for location ^~ /lucee deny all but that just changed the 403 to a 404
not found.

One last note: I notice the container description says the /var/www root
should have a hello world file. For me, it was empty. So maybe the lucee
admin should also be in the web root and for some reason isn’t?

Thanks for any insight,
Brian


Love Lucee? Become a supporter and be part of the Lucee project today! -
http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/ba173f6f-fcdf-48dc-89f5-00151ced1565%40googlegroups.com
https://groups.google.com/d/msgid/lucee/ba173f6f-fcdf-48dc-89f5-00151ced1565%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

Forgot to mention, you can also define your datasource in the
Application.cfc file. Info on that is about half way down this page:

http://docs.lucee.org/guides/cookbooks/datasource-define-datasource.html
https://mailtrack.io/trace/link/7a3ad7057294e900a3087a290f806292defcd6e9?url=http%3A%2F%2Fdocs.lucee.org%2Fguides%2Fcookbooks%2Fdatasource-define-datasource.html&signature=4f706f5706451a3d

Warm regards,

MikeOn Wed, Feb 17, 2016 at 9:55 AM, Michael Sprague <@Michael_Sprague> wrote:

Try hitting the server and web admins directly and see if that works.

In your case they should be:

http://192.168.99.100/lucee/admin/server.cfm
http://192.168.99.100//lucee/admin/web.cfm​

On Wed, Feb 17, 2016 at 9:51 AM, Brian FitzGerald <@Brian_FitzGerald wrote:

Greetings,

I am following along here https://hub.docker.com/r/lucee/lucee4-nginx/ to
setup the lucee/lucee4-nginx docker container. I have the docker container
running and processing basic .cfm files which I created manually in the
terminal. Awesome.

My problem is that I can’t seem to figure out how to access the lucee
admin so I can do things like setup a datasource (so my app can run).

My local docker-machine IP is 192.168.99.100. The way I am reading the
description on the docker container, I should be able to access the admin
control panel via: http://192.168.99.100/lucee/admin - but this is not
working (403 forbidden). Just tinkering around I removed the nginx config
rule for location ^~ /lucee deny all but that just changed the 403 to a
404 not found.

One last note: I notice the container description says the /var/www root
should have a hello world file. For me, it was empty. So maybe the lucee
admin should also be in the web root and for some reason isn’t?

Thanks for any insight,
Brian


Love Lucee? Become a supporter and be part of the Lucee project today! -
http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/ba173f6f-fcdf-48dc-89f5-00151ced1565%40googlegroups.com
https://groups.google.com/d/msgid/lucee/ba173f6f-fcdf-48dc-89f5-00151ced1565%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

Thanks again Mike. Unfortunately the web root on that docker container
(/var/www) is indeed empty upon initial running of the container.

Maybe I can download and extract the lucee admin code and figure out how to
get it onto the container. Do you know the easiest way to get the admin
code?

@Nando, thank you for sharing that. I definitely plan on locking that stuff
down (especially now with your tip) once I get to production. In the
meantime, I would love to get this administrator running in my dev
environment - does that directory structure I described sound like it’s
even the admin code at all? I’m thinking it’s not.On Wednesday, February 17, 2016 at 10:32:50 AM UTC-5, Nando Breiter wrote:

Brian,

Check my blog post here:
http://dnando.github.io/blog/2014/11/04/ssh-tunneling-coldfusion-lockdown-technique/

Highly suggest using ssh tunneling to lockdown and access both lucee and
acf admin directories. Almost all vulnerabilities have been via open access
to these directories.

Aria Media Sagl
+41 91 600 9601
Skype: ariamedia

On 17 Feb 2016, at 15:51, Brian FitzGerald <bmfitz...@gmail.com <javascript:>> wrote:

Greetings,

I am following along here https://hub.docker.com/r/lucee/lucee4-nginx/ to
setup the lucee/lucee4-nginx docker container. I have the docker container
running and processing basic .cfm files which I created manually in the
terminal. Awesome.

My problem is that I can’t seem to figure out how to access the lucee
admin so I can do things like setup a datasource (so my app can run).

My local docker-machine IP is 192.168.99.100. The way I am reading the
description on the docker container, I should be able to access the admin
control panel via: http://192.168.99.100/lucee/admin - but this is not
working (403 forbidden). Just tinkering around I removed the nginx config
rule for location ^~ /lucee deny all but that just changed the 403 to a
404 not found.

One last note: I notice the container description says the /var/www root
should have a hello world file. For me, it was empty. So maybe the lucee
admin should also be in the web root and for some reason isn’t?

Thanks for any insight,
Brian


Love Lucee? Become a supporter and be part of the Lucee project today! -
http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/ba173f6f-fcdf-48dc-89f5-00151ced1565%40googlegroups.com
https://groups.google.com/d/msgid/lucee/ba173f6f-fcdf-48dc-89f5-00151ced1565%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

Thank you Michael. As I explore this box via the terminal, I am noticing
(again) that the web root was empty upon initially running the docker
container.

I did find a lucee directory in /opt/lucee which has two nested directories
/server and /web, but neither of those has a nested file called server.cfm
or web.cfm. The /opt/lucee/server directory has a nested directory called
lucee-server, which has nested directories context and patches. The web
directory has many sub-directories but no file called web.cfm.

Are these files the lucee administrator, or perhaps lucee itself? Just for
fun I copied that entire lucee directory into the web root and have tried
to access it in several ways without luck.

Brian

ps, I will try defining a datasource manually, but I would still like to
access the admin panel for things like debug output, etc.On Wednesday, February 17, 2016 at 10:04:18 AM UTC-5, Michael Sprague wrote:

Forgot to mention, you can also define your datasource in the
Application.cfc file. Info on that is about half way down this page:

http://docs.lucee.org/guides/cookbooks/datasource-define-datasource.html
https://mailtrack.io/trace/link/7a3ad7057294e900a3087a290f806292defcd6e9?url=http%3A%2F%2Fdocs.lucee.org%2Fguides%2Fcookbooks%2Fdatasource-define-datasource.html&signature=4f706f5706451a3d

Warm regards,

Mike

On Wed, Feb 17, 2016 at 9:55 AM, Michael Sprague <mikes...@gmail.com <javascript:>> wrote:

Try hitting the server and web admins directly and see if that works.

In your case they should be:

http://192.168.99.100/lucee/admin/server.cfm
http://192.168.99.100//lucee/admin/web.cfm​

On Wed, Feb 17, 2016 at 9:51 AM, Brian FitzGerald <bmfitz...@gmail.com <javascript:>> wrote:

Greetings,

I am following along here https://hub.docker.com/r/lucee/lucee4-nginx/ to
setup the lucee/lucee4-nginx docker container. I have the docker container
running and processing basic .cfm files which I created manually in the
terminal. Awesome.

My problem is that I can’t seem to figure out how to access the lucee
admin so I can do things like setup a datasource (so my app can run).

My local docker-machine IP is 192.168.99.100. The way I am reading the
description on the docker container, I should be able to access the admin
control panel via: http://192.168.99.100/lucee/admin - but this is not
working (403 forbidden). Just tinkering around I removed the nginx config
rule for location ^~ /lucee deny all but that just changed the 403 to a
404 not found.

One last note: I notice the container description says the /var/www root
should have a hello world file. For me, it was empty. So maybe the lucee
admin should also be in the web root and for some reason isn’t?

Thanks for any insight,
Brian


Love Lucee? Become a supporter and be part of the Lucee project today! -
http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com
<javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/ba173f6f-fcdf-48dc-89f5-00151ced1565%40googlegroups.com
https://groups.google.com/d/msgid/lucee/ba173f6f-fcdf-48dc-89f5-00151ced1565%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

In my experience, I’ve only seen the admin “missing” in Lucee 5 (since it’s
been moved out of the core and into an extension).

That being said, I haven’t used their Docker images so I don’t have any
real advice; maybe someone else with experience with those will chime in.

​Warm regards,

Mike​On Wed, Feb 17, 2016 at 10:36 AM, Brian FitzGerald <@Brian_FitzGerald> wrote:

Thanks again Mike. Unfortunately the web root on that docker container
(/var/www) is indeed empty upon initial running of the container.

Maybe I can download and extract the lucee admin code and figure out how
to get it onto the container. Do you know the easiest way to get the admin
code?

@Nando, thank you for sharing that. I definitely plan on locking that
stuff down (especially now with your tip) once I get to production. In the
meantime, I would love to get this administrator running in my dev
environment - does that directory structure I described sound like it’s
even the admin code at all? I’m thinking it’s not.

On Wednesday, February 17, 2016 at 10:32:50 AM UTC-5, Nando Breiter wrote:

Brian,

Check my blog post here:
http://dnando.github.io/blog/2014/11/04/ssh-tunneling-coldfusion-lockdown-technique/

Highly suggest using ssh tunneling to lockdown and access both lucee and
acf admin directories. Almost all vulnerabilities have been via open access
to these directories.

Aria Media Sagl
+41 91 600 9601
Skype: ariamedia

On 17 Feb 2016, at 15:51, Brian FitzGerald bmfitz...@gmail.com wrote:

Greetings,

I am following along here https://hub.docker.com/r/lucee/lucee4-nginx/ to
setup the lucee/lucee4-nginx docker container. I have the docker container
running and processing basic .cfm files which I created manually in the
terminal. Awesome.

My problem is that I can’t seem to figure out how to access the lucee
admin so I can do things like setup a datasource (so my app can run).

My local docker-machine IP is 192.168.99.100. The way I am reading the
description on the docker container, I should be able to access the admin
control panel via: http://192.168.99.100/lucee/admin - but this is not
working (403 forbidden). Just tinkering around I removed the nginx config
rule for location ^~ /lucee deny all but that just changed the 403 to a
404 not found.

One last note: I notice the container description says the /var/www root
should have a hello world file. For me, it was empty. So maybe the lucee
admin should also be in the web root and for some reason isn’t?

Thanks for any insight,
Brian


Love Lucee? Become a supporter and be part of the Lucee project today! -
http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/ba173f6f-fcdf-48dc-89f5-00151ced1565%40googlegroups.com
https://groups.google.com/d/msgid/lucee/ba173f6f-fcdf-48dc-89f5-00151ced1565%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.


Love Lucee? Become a supporter and be part of the Lucee project today! -
http://lucee.org/supporters/become-a-supporter.html


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/ad02f850-8f77-4df4-b49b-dc56305b887b%40googlegroups.com
https://groups.google.com/d/msgid/lucee/ad02f850-8f77-4df4-b49b-dc56305b887b%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

Have you tried
http://192.168.99.100/lucee/lucee/admin/server.cfm

Thanks for the suggestion Bilal!

In fact, last night I was able to access the Lucee administrator (it’s a
beautiful site) with the help of Geoff Bowers. I was trying to run the
lucee/luce4-nginx docker container directly, which was really where I went
wrong to begin with.

The correct approach, as it turns out, is really to only use the
preconfigured lucee containers as boxes upon which you base your custom
image. By creating a new image based on lucee/lucee4-nginx and adding the
“configuration overrides” for nginx and lucee, I was able to access the
administrator (at http://[docker_machine_ip]/lucee/admin/server.cfm) and
create a new datasource, which in turn pointed to another docker container
on port 3306. Then, I had a simple index.cfm file run a query and dump some
data. Great!

At this point, I thought I was home free for running my app, but I still
have two issues to work out:

  1. Upon pulling in the actual application code, I noticed that DI/1 is
    having issues trying to auto-discover the beans in my model. I’ve never had
    this problem before, so I’m trying to figure out why this is happening, and
  2. The mounting of volumes from my OSX host into the container is
    proving challenging since there are 3 layers to content with in the docker
    world when running on OSX or windows: 1) the host os (OSX), 2) the
    docker-machine (virtual linux machine for the docker engine to run in), and
  1. the docker containers themselves. My goal is to get a volume from OSX to
    mount directly into the docker container, which as I said is proving
    challenging, but is perhaps outside the scope of this discussion.

Thanks everyone for your suggestions and help. I’m close!

https://lh3.googleusercontent.com/-PoV92w7sqw0/VsXdxHz1-SI/AAAAAAABsEQ/ObLflq7or3Q/s1600/lucee_admin.png

https://lh3.googleusercontent.com/-7hJYLQEg7FU/VsXdzjJdHgI/AAAAAAABsEU/ayt9XI2OGKU/s1600/application_error.pngOn Thursday, February 18, 2016 at 9:52:49 AM UTC-5, Bilal wrote:

Have you tried
http://192.168.99.100/lucee/lucee/admin/server.cfm

I just realized I hadn’t followed up on this guy. The issue here was that
having a method with the name _dateFormat was blowing up in Lucee (whereas
it did not in Railo). Anyhow, @ivanionut had actually contributed a fix to
the CF Mailgun project
https://github.com/DominicWatson/cfmailgun/commit/ed39433213fde62e11285d597f78d4fd81f7e1e1
back in December, so all is well there after updating the method name. I’m
still working out one or two Nginx config kinks but all in all, thrilled to
finally be running on Lucee.On Thursday, February 18, 2016 at 10:06:37 AM UTC-5, Brian FitzGerald wrote:

Thanks for the suggestion Bilal!

In fact, last night I was able to access the Lucee administrator (it’s a
beautiful site) with the help of Geoff Bowers. I was trying to run the
lucee/luce4-nginx docker container directly, which was really where I went
wrong to begin with.

The correct approach, as it turns out, is really to only use the
preconfigured lucee containers as boxes upon which you base your custom
image. By creating a new image based on lucee/lucee4-nginx and adding the
“configuration overrides” for nginx and lucee, I was able to access the
administrator (at http://[docker_machine_ip]/lucee/admin/server.cfm) and
create a new datasource, which in turn pointed to another docker container
on port 3306. Then, I had a simple index.cfm file run a query and dump some
data. Great!

At this point, I thought I was home free for running my app, but I still
have two issues to work out:

  1. Upon pulling in the actual application code, I noticed that DI/1 is
    having issues trying to auto-discover the beans in my model. I’ve never had
    this problem before, so I’m trying to figure out why this is happening, and
  2. The mounting of volumes from my OSX host into the container is
    proving challenging since there are 3 layers to content with in the docker
    world when running on OSX or windows: 1) the host os (OSX), 2) the
    docker-machine (virtual linux machine for the docker engine to run in), and
  1. the docker containers themselves. My goal is to get a volume from OSX to
    mount directly into the docker container, which as I said is proving
    challenging, but is perhaps outside the scope of this discussion.

Thanks everyone for your suggestions and help. I’m close!

https://lh3.googleusercontent.com/-PoV92w7sqw0/VsXdxHz1-SI/AAAAAAABsEQ/ObLflq7or3Q/s1600/lucee_admin.png

https://lh3.googleusercontent.com/-7hJYLQEg7FU/VsXdzjJdHgI/AAAAAAABsEU/ayt9XI2OGKU/s1600/application_error.png

On Thursday, February 18, 2016 at 9:52:49 AM UTC-5, Bilal wrote:

Have you tried
http://192.168.99.100/lucee/lucee/admin/server.cfm