Access is prohibited by security manager, can't log into admin

I installed a fresh copy of Lucee on my AWS EC2 stage system using the newest AWS EC2 Linux (Centos 7). I set it up to me a proxy for my Apache server. I used the non-root user ‘apache’ for it to run.

I can get to the /lucee/admin/web.cfm page on my virtual hosts, but I can not log in using the password I set during the install. It always comes back with “Access is restricted”

I CAN NOT access /lucee/admin/sever.cfm page. No matter how I try I get the error:

can't access [/opt/lucee/tomcat/lucee-server/context/userdata] directory must be inside [/opt/lucee/tomcat/webapps/ROOT]

I have tried from the virtual host URL, I have also tried through an SSH tunnel to

I checked the permissions on all the /opt/lucee directories as well. I can not get into the server admin.


Don’t forget to tell us about your stack!

OS: AWS EC2 Linux 2
Java Version: openjdk 11.0.12 2021-07-20 LTS
Tomcat Version: 9.0.46
Lucee Version: lucee-

Fortunately this is on a staging environment.

I uninstalled lucee and reinstalled running Tomcat as root user. Everything works.
What permissions do I need to double check for this to work as a non-root user?

hi @Square360_George ,

I don’t have experience with centos, so I don’t know if this is going to help, but… did you install Lucee using the installer?

if so, I supose you ran the installer as root? And isn’t the user ‘apache’ already an existing user?

During setup the installer asks you to change the user from root to another username. I’d try to use a specific and non-existing name, e.g. luceehst, or luceesrv, cfmhost, or what ever suits best for your Lucee service. I think the installer should create that user for you and set the permissions right to all those lucee folders. Make sure Lucee is running on a new user.

But as I said, never did an installation to those OS.

Already have a bug in Jira

I see that this is a confirmed bug. Is there any workaround short of a reinstall? I am completely new to Lucee (have been running coldfusion since '98). Everything works fine on my install except access to the admin now. (it was working before changing file access to local).

OS : Windows Server 2019
Java Version : 11.0.11
Tomcat Version : 9.0.46
Lucee Version :

What do you exactly mean with “can’t access admin”? Wrong password? 404 error code? 403 forbidden?