5.3.1.95 AxisFault when return object is complex cfc

I have cfc web services that fail after upgrade to 5.3.1.95, run without error on 5.2.9.31. Lucee is installed on Windows server using Tomcat. I have multiple servers and a dev box running Windows 10, all are failing. Receive the following error when attempting to return the wsdl file. I have had some limited success by supplying the wsdl file to the component but on most calling component functions still fail. I assume this has something to do with moving Axis from core to an extension.

Lucee 5.3.1.95 Error (org.apache.axis.AxisFault)
Message ; nested exception is:
lucee.runtime.exp.NativeException: dev.test.response_status.registerTypeMapping(java.lang.Class)
Java Stacktrace lucee.runtime.exp.NativeException: ; nested exception is:
lucee.runtime.exp.NativeException: dev.test.response_status.registerTypeMapping(java.lang.Class)
at org.apache.axis.AxisFault.makeFault(AxisFault.java:101)
at org.lucee.extension.axis.server.ComponentHandler.generateWSDL(ComponentHandler.java:60)
at org.apache.axis.strategies.WSDLGenStrategy.visit(WSDLGenStrategy.java:33)
at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
at org.apache.axis.SimpleChain.generateWSDL(SimpleChain.java:104)
at org.apache.axis.server.AxisServer.generateWSDL(AxisServer.java:454)

Test case
response_status.cfc - complex cfc component to be returned
<cfcomponent>
<cfproperty name=“status” type=“boolean” hint=“Request pass/fail”>
<cfproperty name=“message” type=“string” hint=“Request status message”>
<cfscript>
//Constructor
this.status = false;
this.message = “”;
</cfscript>
</cfcomponent>

wstest.cfc - test web service
<cfcomponent namespace=“http://luceetest.com/wstest” displayname=“wstest” style=“rpc”>
<cfsetting enableCFoutputOnly = “yes” showDebugOutput = “no”>

<!— Test1 - Test call with complex object return type —>
<cffunction name=“test1” access=“remote” returntype=“response_status” hint=“Test web service returning complex object”>
<cfset oStatus = new response_status()>
<cfreturn oStatus>
</cffunction>
</cfcomponent>

testcall.cfc - test call of web service
<cfscript>
wstest = new wstest();
retStatus = wstest.test1();
writedump(var=retStatus);
</cfscript>

try to reepeat the issue, what i don’t get, why your example does call “wstest” not as a webservice?

Problem seem to be that we use an newer version of axis.

i did open a ticket for this
https://luceeserver.atlassian.net/browse/LDEV-2198

Oops, sorry I copied the wrong test script. Testing with cfinvoke was returning limited trace info so I had switched trying to find a workaround. Thanks for looking into this and opening a ticket.

Updated test script
testwscall.cfm - test call of web service
<cfinvoke
webservice=“http://localhost/dev/test/wstest.cfc?wsdl
method=“test1”
returnvariable=“retStatus”>
</cfinvoke>
<cfdump var="#retStatus#">

problem solved (see tickets for details)

You Rock!, testing with 5.3.2.65 Snapshot this morning looked good. Looking forward to the next release.