Windows 10 | Apache Web server | Opening an intranet

Et al - I wasn’t sure how to ask the question of the community. Thus the odd title for the topic.

I’ve written an application for my business that I want to deploy on a dedicated Windows 10 pro machine here in my office. Early on in the app development I wanted to make sure that I’d be able to use the windows machine, so I installed the IIS compoenent, installed tomcat and connected it to IIS using the AJP connector. Installed my app in the tomcat webroot.

Everything worked except for the fact that it was so slow. I was only hosting the one intranet so the my application files where at the heart of the webroot. So going to localhost got you to the login page of the application. Like I said, everything worked except for the fact that it was slow. If I went to localhost:8080 everything moved fast.

I decided I would uninstall the IIS components and instead use apache as the web server on the windows 10 machine for the local intranet. I uninstalled IIS. I uninstalled all the apache and lucee stuff. I downloaded and installed the windows installer for lucee When prompted by the installer to install a specific IIS component I didn’t. Sorry, I can’t remember exactly what component it wanted to install, but because I wasn’t planning on using IIS, I figured I shouldn’t install it. I also indicated that I wanted apache to run when windows started. When prompted for a port number to run everything through I typed in 80.

Everything went well. When I go to localhost in my browser the Lucee installation welcome page is there smiling at me. To access the hosted intranet site from a different machine, in the past all I’ve had to do is type into the browser the name of the computer. In this case it’s rr_llc. I’ve even tried rr_llc:80 to see if that would work but I get server not available, or site not available.

Does anyone know of a good tutorial some where that shows how to enable the webroot of win 10 pro directory, using apache as the web server?