Welcome to Railo/Lucee page

We are running Railo (hopefully soon Lucee) with Apache, Tomcat and
mod_cfml on Linux. Our application is Contentbox/Coldbox based. It’s just
one site on the server.

After restarting the server sometimes the first page hit shows the Welcome
to Railo page. This can become a serious problem if you have decent load on
the server.
As well your Google index becomes poluted. After checking our remaining
pages in Google index and searching for “Welcome to Railo” index.cfm I got
the feeling
that this doesn’t happen only on startup.

Is there a way to permantly remove/disable documentation and index pages
from Lucee on production machines? Will they return on updates if I just
delete the pages?

I’m also proposing to add as well on all documentation pages: .

Jordan

Should chime in here there are a load of configuration settings you can
tweak for mod cfml that make this less likely to happen.

I’m wondering whether it would be better for you to manually edit the
welcome page with no index no follow or actually get the page to throw the
correct httpcode for application still starting come back later.
Instinctively the latter feels right. I guess that’s a 503?

ASent from my phone
On 30 Mar 2015 06:38, “Gunnar Lieb” <@Gunnar_Lieb> wrote:

We are running Railo (hopefully soon Lucee) with Apache, Tomcat and
mod_cfml on Linux. Our application is Contentbox/Coldbox based. It’s just
one site on the server.

After restarting the server sometimes the first page hit shows the Welcome
to Railo page. This can become a serious problem if you have decent load on
the server.
As well your Google index becomes poluted. After checking our remaining
pages in Google index and searching for “Welcome to Railo” index.cfm I got
the feeling
that this doesn’t happen only on startup.

Is there a way to permantly remove/disable documentation and index pages
from Lucee on production machines? Will they return on updates if I just
delete the pages?

I’m also proposing to add as well on all documentation pages: .


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/50270d63-69ba-46e5-8f10-79fe4200eac9%40googlegroups.com
https://groups.google.com/d/msgid/lucee/50270d63-69ba-46e5-8f10-79fe4200eac9%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

BTW, here’s a Lucee ticket about this (which references a conversation you
and I had about the
topic): https://luceeserver.atlassian.net/browse/LDEV-301On Monday, March 30, 2015 at 3:17:58 AM UTC-4, Jordan Michaels wrote:

Hi Gunnar,

You’re probably hitting the context creation timeout - you can enable
logging in the mod_cfml valve to be sure and increase that timeout as
needed, but since you only have one site, you don’t really need to use
mod_cfml. Mod_cfml is designed to dynamically create multiple contexts on
the fly. Since you only have one context, I’d recommend just adding that
context to your tomcat server.xml file so that the context is created as
Tomcat starts up rather than on the fly. The
/opt/railo/tomcat/conf/server.xml file should be well commented, so you
should be able to use the notes to create your single context.

You might also consider giving your server more resources to work with. If
it’s too slow to create a context under load so that it hits the timeout,
chances are good that your app’s performance is suffering as well. I’d also
be interested to know why you’re restarting Railo while the server is under
load? That seems like an important issue as well.

Hope this helps!

Kind regards,
Jordan Michaels

----- Original Message -----
From: “Gunnar Lieb” <g...@akitogo.com <javascript:>>
To: lu...@googlegroups.com <javascript:>
Sent: Sunday, March 29, 2015 10:38:35 PM
Subject: [Lucee] Welcome to Railo/Lucee page

We are running Railo (hopefully soon Lucee) with Apache, Tomcat and
mod_cfml on Linux. Our application is Contentbox/Coldbox based. It’s just
one site on the server.

After restarting the server sometimes the first page hit shows the Welcome
to Railo page. This can become a serious problem if you have decent load
on
the server.
As well your Google index becomes poluted. After checking our remaining
pages in Google index and searching for “Welcome to Railo” index.cfm I got
the feeling
that this doesn’t happen only on startup.

Is there a way to permantly remove/disable documentation and index pages
from Lucee on production machines? Will they return on updates if I just
delete the pages?

I’m also proposing to add as well on all documentation pages: .


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com <javascript:>.

To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/50270d63-69ba-46e5-8f10-79fe4200eac9%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.