Web-admin mappings and cfimport issues

Hi,
Has anyone resolved this?
I’ve been experiencing this with Lucee 5.2 on linux using Farcry. Funny thing is it works with some and not for others. ie you can have two cfml files importing the same taglib, one will work and other will fail. I wonder if it’s a resource/timing issue during startup of the application. Restarting server can fix it but that’s not really aways an option.
I’ve only ever seen this on Lucee 5. I run the same setup on CF9,CF11, Railo and Lucee 4.5 without this issue.

Phil

Just thought I’d bump this.

This is still very much an ongoing issue for me. It only started with lucee 5.2 that I can see. This will happen randomly on my local linux (centos) development machine and on AWS linux during lucee startup.
Linux , mysql, Lucee 5.2.9.31,Apache Tomcat/7.0.56, Java 1.8.0_121
I thought that it might be a resource issue but doubling the size of the EC2 instance and adding a bit more JVM memory makes no difference.

Could it perhaps be a Java or Tomcat issue?

A reboot of lucee is the only was of resolving the issue (and sometimes it causes the issue to appear on a different cfimport). Once lucee decides it can’t see a library there there is no way of changing it without the reboot. You can change the address from root to relative and then it works eg /mystuff to …/…/mystuff. Not really a realistic workaround.

There have been others reporting this issue, see below and above. I’m interested if it’s still an issue for them or how they resolved it.

Cheers Phil

I see there was a rejected bug here…
https://luceeserver.atlassian.net/browse/LDEV-1197

Could you try upgrading java to the latest 1.8 release and tomcat 7.0.92?

Thanks for the suggestion Zac. I’ve updated Java (1.8.0_191 (Oracle Corporation) 64bit) and Tomcat (Apache Tomcat/7.0.92) and it’s still having this issue.
Any other suggestions?

invalid definition of the attribute taglib [/farcry/projects/XXXXXXXXX/tags/webskin].

I think I’ve seen this before in older versions of Lucee (not see it happen with 5.2.x myself) when there have been JVM issues, and some mappings just randomly disappear even when they are statically configured in the lucee-web.xml.cfm.

Unfortunately I don’t have many more details than that… Do you see any other issues with the app relating to the overall health of the JVM?

An alternative that is specific to FarCry Core might be to eliminate the need for mappings by restructuring your project to use a webroot install (the contents of your projects www folder gets moved into the webroot, and /farcry gets moved into the webroot), but that might only mask the underlying issue too.

Well I do have one thought. These servers have been upgraded from the original install of railo. So I wonder if something my still be hanging around because of that. It’s only turned up in 5.x. I have a similar server running 4.5 that’s never had this issue.

When I saw the issue it wasn’t on servers upgraded from Railo to Lucee, so I’m not sure about that. Even if you had an older config and were using it with Lucee 5.x I can’t think of a reason why it would affect mappings in this way.

You could try going with a fresh install just to rule it out, but of course that’s a little bit of work if you have to reconfigure everything manually.

I have the same issue.

“invalid definition of the attribute taglib [{sometagname}]”

I use <cfimport taglib="/sometagname" prefix="sometagname"> in lots of pages in several websites.
/sometagname is a folder in my webroot.

I now use Lucee 5.3.1.103 and experience this on both my Mac as well as on Ubuntu, but it started happening after upgrading from 4.5 to one of the first versions of 5.
After a restart of Lucee it mostly disappears, if not, I just have to to restart until it works. If one webapp in my lucee install suffers from this problem all fail that use this import. If it works for one webapp they all work. This makes restarting always a frustrating experience, because it seems so random.

can you test 5.3.2.2-SNAPSHOT or later?

https://luceeserver.atlassian.net/browse/LDEV-2051

Hi, just tested Lucee 5.3.3.43-SNAPSHOT on my Mac that had previously lucee-5.1.0.34.

This issue is not appearing anymore on my Mac. I restarted about 8 times and it seems ok now.

I see there is not a newer version that is production ready. So I will test that once it is available.

1 Like

Thanks for testing that and reporting back, great to hear that the problem has been resolved :muscle:

So, 5.3.2.74-RC also includes that fix and is due to drop as a stable release any time now (waves to @IamSigmund)

Waving back to @Zackster. :wink: 5.3.2 final release is live.

1 Like

Hi all,

I’m sorry to say that this issue is back. I’m now using Lucee 5.3.5.92.
I even see it happening that the cfimport fails on one template and are fine on other templates within the same application. I have to do a full regression test on all applications (websites), to know for sure every page is loading as it should.
It is very random: sometimes all websites using the cfimport have this issue, sometimes all websites seem fine at first sight, but then some templates fail.
Restarting lucee has become a very tricky thing to do this way. I hope you can manage to solve this.

Update: I will first update my java version. It is pretty old I see…

If you can, try the 5.3.6 RC or even the latest 5.3.7 snapshot, they are a lot more robust

Thanks. I think it is time for an update of my Lucee installation (both Java and Tomcat). That brings me to a new question: what is the best approach? will raise a new question in the forum.

So after upgrading to java 11 and tomcat 9 and now running 5.3.6 RC, at least it is now consistent in throwing an error, also after restarting several times:
Still getting

invalid definition of the attribute taglib [/sometagname]

I have two imports:

<cfimport taglib="/sometagname" prefix="sometagname"> <!--- fails --->
<cfimport taglib="/core/sometagname" prefix="/coresometagname"> <!---ok--->

The first one fails, the second one works.
The difference is that the first is used as ‘/sometagname’ in the web admin, the second is used as ‘/coresometagname’ as a mapping in the server admin.
If I move the first to the server admin section it starts working (but I do not want it there of course), so apparently this only happens in the context of ‘web’.

/sometagname is just a folder in the root folder of my application and is application specific.
Also if I change it to sometagname without the slash in front, it also fails.

I know this is probably not how you would write code these days, but these are all legacy applications that I would rather not change drastically.

you can that error happens when all the other checks above it fails

there’s also quite a lot of history about these problems in jira
https://luceeserver.atlassian.net/browse/LDEV-1197

Just an update.
I only had 300Mb left on my harddrive, so I got errors in my catalina about allocating Swap space (if I remember correctly). I increased the disk size as well as the Java heap size half a Gb, and now everything is working fine again!
So I thought what if I bring it back to its original Java heap size?
Still no problem. Everything is ok.
I have no idea what’s going on here.

I just wanted to let you know that this issue raised its ugly head again:
Lucee 5.3.7.48 on JAVA 11.0.6 (AdoptOpenJDK) 64bit and Tomcat 11.

It is still like this :slight_smile:

“invalid definition of the attribute taglib [{sometagname}]”

I use <cfimport taglib="/sometagname" prefix="sometagname"> .
/sometagname is a folder in my webroot.

And when it throws this error, I need to restart lucee. 50% chance it will then work. Just keep restarting.

Just re-encountered this error on 5.3.8.206. I have been using cfimport without any issues on this version for a while, and then seemingly randomly this error appeared again. I downgraded to 5.3.8.189 and the error went away. I then went back to 5.3.8.206, and everything is still fine.