Virtual Dir in Railo/Lucee and IIS7

I am really sorry, but I’ve about goggled myself to death, my eyes are
swollen, and my fingers are bleeding.

I have tried this with Lucee and now Railo 4.2.1.008 (windows 2008 and IIS7)

To add a “virtual directory” in IIS7, all that’s needed is to:

  1. Right click the “Default Web site”,
  2. Select the “Add Virtual Directory”,
  3. Put the name in the Alias field (ie, “my_site”)
  4. Add the Physical Path (C:\inetpub\wwwroot\websites\my_site)

and bada bing, it’s done… ready to be used.

I can go to http://localhost/my_site/index.htm and it displays fine

But if I put a cfm file in that folder and go to
http://localhost/my_site/index.cfm, using .cfm instead of .htm) I get an
error:
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not
found.

That is is NOT where the file is… it should have been:
C:\inetpub\wwwroot\websites\my_site\index.cfm
It should have said: c:\inetpub\wwwroot\my_site\index.cfm

It appears that Railo/Lucee is not using the same virtual dir that was
setup in IIS7.

Railo/Lucee thinks the vittual dir is c:\inetpub\wwwroot\my_site
and IIS7 thinks it is C:\inetpub\wwwroot\websites\my_site (where it
actually is)

If I put ANY htm file in C:\inetpub\wwwroot\websites\my_site, it will
display with localhost/my_site/filename.htm

But if I put ANY cfm file in C:\inetpub\wwwroot\websites\my_site, and try
to use localhost/my_site/filename.cfm I’ll get the error.

btw: If I move the folder to C:\inetpub\wwwroot\my_site and set the
Physical Path (C:\inetpub\wwwroot\my_site) everything works.

I just don’t understand why a cfm file will not display if it’s in a sub
directory (ie c:\inetpub\wwwroot\websites)

It’s like IIS7 handles the alias ok, but Railo/Lucee needs another setting
so that it maps to the correct folder.

What am missing?

btw: I’ve been coding CFML since it was version .9 (yep, point 9)

-pat-

you managed to type quite a bit with bleeding fingers and swollen eyes,
so TBH I didn’t read it all in detail, but…

looks to me like what you’re missing is a Context/path entry in
Tomcat/conf/server.xml, so for the Host element of that site, you want
to add something like:

<Context path="/my_site"

docBase=“C:/inetpub/wwwroot/websites/my_site” />

and restart Tomcat for the changes to take effect.

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/On 6/20/2015 3:06 PM, pat forbes wrote:

I am really sorry, but I’ve about goggled myself to death, my eyes are
swollen, and my fingers are bleeding.

I have tried this with Lucee and now Railo 4.2.1.008 (windows 2008 and
IIS7)

To add a “virtual directory” in IIS7, all that’s needed is to:

  1. Right click the “Default Web site”,
  2. Select the “Add Virtual Directory”,
  3. Put the name in the Alias field (ie, “my_site”)
  4. Add the Physical Path (C:\inetpub\wwwroot\websites\my_site)

and bada bing, it’s done… ready to be used.

I can go to http://localhost/my_site/index.htm and it displays fine

But if I put a cfm file in that folder and go to
http://localhost/my_site/index.cfm, using .cfm instead of .htm) I get
an error:
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm)
not found.

That is is NOT where the file is… it should have been:
C:\inetpub\wwwroot\websites\my_site\index.cfm
It should have said: c:\inetpub\wwwroot\my_site\index.cfm

It appears that Railo/Lucee is not using the same virtual dir that was
setup in IIS7.

Railo/Lucee thinks the vittual dir is c:\inetpub\wwwroot\my_site
and IIS7 thinks it is C:\inetpub\wwwroot\websites\my_site (where it
actually is)

If I put ANY htm file in C:\inetpub\wwwroot\websites\my_site, it will
display with localhost/my_site/filename.htm

But if I put ANY cfm file in C:\inetpub\wwwroot\websites\my_site, and
try to use localhost/my_site/filename.cfm I’ll get the error.

btw: If I move the folder to C:\inetpub\wwwroot\my_site and set the
Physical Path (C:\inetpub\wwwroot\my_site) everything works.

I just don’t understand why a cfm file will not display if it’s in a
sub directory (ie c:\inetpub\wwwroot\websites)

It’s like IIS7 handles the alias ok, but Railo/Lucee needs another
setting so that it maps to the correct folder.

What am missing?

btw: I’ve been coding CFML since it was version .9 (yep, point 9)

-pat-


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to lucee+unsubscribe@googlegroups.com
mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com
mailto:lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com
https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

So I add this line right under “

allowLinking=“true”

??

Also FYI: From https://tomcat.apache.org/tomcat-5.5-doc/config/context.html:

“NOTE: This flag MUST NOT be set to true on the Windows platform (or any other OS which does not have a case sensitive filesystem), as it will disable case sensitivity checks, allowing JSP source code disclosure, among other security problems.”From: lucee@googlegroups.com [mailto:lucee@googlegroups.com] On Behalf Of Jon Clausen
Sent: Saturday, June 20, 2015 6:38 PM
To: lucee@googlegroups.com
Subject: Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

No problem. Inside the Context tag:

https://tomcat.apache.org/tomcat-5.5-doc/config/context.html

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:35 PM, <@pat_forbes> <@pat_forbes> wrote:

I’m not seeing where this goes in context.xml

<!-- Default set of monitored resources -->

<WatchedResource>WEB-INF/web.xml</WatchedResource>



<!-- Uncomment this to disable session persistence across Tomcat restarts -->

<!--

<Manager pathname="" />

-->



<!-- Uncomment this to enable Comet connection tacking (provides events

     on session expiration as well as webapp lifecycle) -->

<!--

<Valve className="org.apache.catalina.valves.CometConnectionManagerValve" />

-->

I’m really sorry for being able to get this.

-pat-

From: lucee@googlegroups.com [mailto:lucee@googlegroups.com] On Behalf Of Jon Clausen
Sent: Saturday, June 20, 2015 6:29 PM
To: lucee@googlegroups.com
Subject: Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

I think you need the “allowLinking” attribute in your Tomcat context config:

allowLinking=“true”

HTH,

Jon

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:19 PM, pat forbes <@pat_forbes> wrote:

btw: if i create a dummy.htm, a dummy.txt, and a dummy.cfm (all three the exact same with one line

you are in dummy


If I use http://localhost/my_site/dummy.htm --> it works
If I use http://localhost/my_site/dummy.txt --> it works
If I use http://localhost/my_site/dummy.cfm --> it fails with:
Message Page /my_site/dummy.cfm (c:\inetpub\wwwroot\my_site\dummy.cfm) not found.

On Saturday, June 20, 2015 at 6:14:49 PM UTC-5, pat forbes wrote:

Thank you for your reply.
Yep… I did type a lot. I wanted to make sure I explained it. Probably too wordy :slight_smile:

I added the context path to the existing entry in server.xml like this:

  <Host name="localhost" appBase="webapps">
    <Context path="" docBase="C:\inetpub\wwwroot\" />
    <Context path="/my_site" docBase="C:/inetpub/wwwroot/websites/my_site" />
  </Host>

and then restarted Tomcat
but I get the exact same error:

It still shows
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not found.

It stll thinks my_site is a sub folder of c:\inetpub\wwwroot"
when its actually c:\inetpub\wwwroot\websites

-pat-

On Saturday, June 20, 2015 at 5:14:26 PM UTC-5, Igal wrote:

you managed to type quite a bit with bleeding fingers and swollen eyes, so TBH I didn’t read it all in detail, but…

looks to me like what you’re missing is a Context/path entry in Tomcat/conf/server.xml, so for the Host element of that site, you want to add something like:

<Context path="/my_site" docBase="C:/inetpub/wwwroot/websites/my_site" />

and restart Tomcat for the changes to take effect.

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/

On 6/20/2015 3:06 PM, pat forbes wrote:

I am really sorry, but I’ve about goggled myself to death, my eyes are swollen, and my fingers are bleeding.

I have tried this with Lucee and now Railo 4.2.1.008 (windows 2008 and IIS7)

To add a “virtual directory” in IIS7, all that’s needed is to:

  1. Right click the “Default Web site”,
  2. Select the “Add Virtual Directory”,
  3. Put the name in the Alias field (ie, “my_site”)
  4. Add the Physical Path (C:\inetpub\wwwroot\websites\my_site)

and bada bing, it’s done… ready to be used.

I can go to http://localhost/my_site/index.htm and it displays fine

But if I put a cfm file in that folder and go to http://localhost/my_site/index.cfm, using .cfm instead of .htm) I get an error:
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not found.

That is is NOT where the file is… it should have been:
C:\inetpub\wwwroot\websites\my_site\index.cfm
It should have said: c:\inetpub\wwwroot\my_site\index.cfm

It appears that Railo/Lucee is not using the same virtual dir that was setup in IIS7.

Railo/Lucee thinks the vittual dir is c:\inetpub\wwwroot\my_site
and IIS7 thinks it is C:\inetpub\wwwroot\websites\my_site (where it actually is)

If I put ANY htm file in C:\inetpub\wwwroot\websites\my_site, it will display with localhost/my_site/filename.htm

But if I put ANY cfm file in C:\inetpub\wwwroot\websites\my_site, and try to use localhost/my_site/filename.cfm I’ll get the error.

btw: If I move the folder to C:\inetpub\wwwroot\my_site and set the Physical Path (C:\inetpub\wwwroot\my_site) everything works.

I just don’t understand why a cfm file will not display if it’s in a sub directory (ie c:\inetpub\wwwroot\websites)

It’s like IIS7 handles the alias ok, but Railo/Lucee needs another setting so that it maps to the correct folder.

What am missing?

btw: I’ve been coding CFML since it was version .9 (yep, point 9)

-pat-


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the Google Groups “Lucee” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/lucee/0bQpWRQLiFY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/002f01d0abb1%24ca972ad0%245fc58070%24%40westhold.com https://groups.google.com/d/msgid/lucee/002f01d0abb1%24ca972ad0%245fc58070%24%40westhold.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the Google Groups “Lucee” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/lucee/0bQpWRQLiFY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/3D1D845D-0F7F-4D69-8BBF-80269E59C7BF%40silowebworks.com https://groups.google.com/d/msgid/lucee/3D1D845D-0F7F-4D69-8BBF-80269E59C7BF%40silowebworks.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.

@Jon, this is from the Tomcat 7 docs:

https://tomcat.apache.org/tomcat-7.0-doc/config/context.html#Common_Attributes

"NOTE: This flag MUST NOT be set to true on the Windows platform (or
any other OS which does not have a case sensitive filesystem), as it
will disable case sensitivity checks, allowing JSP source code
disclosure, among other security problems."

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/

On 6/20/2015 4:38 PM, Jon Clausen wrote:

No problem. Inside the Context tag:

https://tomcat.apache.org/tomcat-5.5-doc/config/context.html

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:35 PM, <@pat_forbes mailto:pat_forbes> <@pat_forbes mailto:pat_forbes> wrote:

I’m not seeing where this goes in context.xml

<!-- Default set of monitored resources -->

<WatchedResource>WEB-INF/web.xml</WatchedResource>



<!-- Uncomment this to disable session persistence across Tomcat

restarts -->

<!--

<Manager pathname="" />

-->



<!-- Uncomment this to enable Comet connection tacking (provides

events

     on session expiration as well as webapp lifecycle) -->

<!--

<Valve

className=“org.apache.catalina.valves.CometConnectionManagerValve” />

-->

I’m really sorry for being able to get this.

-pat-

*From:*lucee@googlegroups.com mailto:lucee@googlegroups.com
[mailto:lucee@googlegroups.com] *On Behalf Of *Jon Clausen
Sent: Saturday, June 20, 2015 6:29 PM
To: lucee@googlegroups.com mailto:lucee@googlegroups.com
Subject: Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

I think you need the “allowLinking” attribute in your Tomcat context
config:

allowLinking=“true”

HTH,

Jon

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:19 PM, pat forbes <@pat_forbes mailto:pat_forbes> wrote:

btw: if i create a dummy.htm, a dummy.txt, and a dummy.cfm (all
three the exact same with one line<h2>you are in dummy</h2>
If I use http://localhost/my_site/dummy.htm --> it works
If I use http://localhost/my_site/dummy.txt --> it works
If I use http://localhost/my_site/dummy.cfm --> it fails with:
Message Page /my_site/dummy.cfm
(c:\inetpub\wwwroot\my_site\dummy.cfm) not found.

On Saturday, June 20, 2015 at 6:14:49 PM UTC-5, pat forbes wrote:

Thank you for your reply.
Yep... I did type a lot.  I wanted to make sure I explained it. 
Probably too wordy :)

I added  the context path to the existing entry in server.xml
like this:

      <Host name="localhost" appBase="webapps">
        <Context path="" docBase="C:\inetpub\wwwroot\" />
        <Context path="/my_site"
docBase="C:/inetpub/wwwroot/websites/my_site" />
      </Host>

and then restarted Tomcat
but I get the exact same error:

It still shows
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm
(c:\inetpub\wwwroot\my_site\index.cfm) not found.

It stll thinks my_site is a sub folder of c:\inetpub\wwwroot\"
when its actually c:\inetpub\wwwroot\websites

-pat-


On Saturday, June 20, 2015 at 5:14:26 PM UTC-5, Igal wrote:

you managed to type quite a bit with bleeding fingers and swollen
eyes, so TBH I didn't read it all in detail, but...

looks to me like what you're missing is a Context/path entry in
Tomcat/conf/server.xml, so for the Host element of that site, you
want to add something like:

    <Context path="/my_site"
docBase="C:/inetpub/wwwroot/websites/my_site" />

and restart Tomcat for the changes to take effect.

Igal Sapir
Lucee Core Developer
Lucee.org <http://lucee.org/>

On 6/20/2015 3:06 PM, pat forbes wrote:

    I am really sorry, but I've about goggled myself to death, my
    eyes are swollen, and my fingers are bleeding.

    I have tried this with Lucee and now Railo 4.2.1.008 (windows
    2008 and IIS7)

    To add a "virtual directory" in IIS7, all that's needed is to:
    1. Right click the "Default Web site",
    2. Select the "Add Virtual Directory",
    3. Put the name in the Alias field (ie, "my_site")
    4. Add the Physical Path (C:\inetpub\wwwroot\websites\my_site)

    and bada bing, it's done... ready to be used.

    I can go to http://localhost/my_site/index.htm and it
    displays fine

    But if I put a cfm file in that folder and go to
    http://localhost/my_site/index.cfm, using .cfm instead of
    .htm) I get an error:
    Railo 4.2.1.008 Error (missinginclude)
    Message Page /my_site/index.cfm
    (c:\inetpub\wwwroot\my_site\index.cfm) not found.

    That is is NOT where the file is... it should have been:
    C:\inetpub\wwwroot\websites\my_site\index.cfm
    It should have said: c:\inetpub\wwwroot\my_site\index.cfm

    It appears that Railo/Lucee is not using the same virtual dir
    that was setup in IIS7.

    Railo/Lucee thinks the vittual dir is c:\inetpub\wwwroot\my_site
    and IIS7 thinks it is C:\inetpub\wwwroot\websites\my_site
    (where it actually is)

    If I put ANY htm file in C:\inetpub\wwwroot\websites\my_site,
    it will display with localhost/my_site/filename.htm

    But if I put ANY cfm file in
    C:\inetpub\wwwroot\websites\my_site, and try to use
    localhost/my_site/filename.cfm I'll get the error.

    btw: If I move the folder to C:\inetpub\wwwroot\my_site and
    set the Physical Path (C:\inetpub\wwwroot\my_site) everything
    works.

    I just don't understand why a cfm file will not display if
    it's in a sub directory (ie c:\inetpub\wwwroot\websites)

    It's like IIS7 handles the alias ok, but Railo/Lucee needs
    another setting so that it maps to the correct folder.

    What am missing?

    btw: I've been coding CFML since it was version .9  (yep,
    point 9)

    -pat-




    -- 
    You received this message because you are subscribed to the
    Google Groups "Lucee" group.
    To unsubscribe from this group and stop receiving emails from
    it, send an email to lucee+un...@googlegroups.com
    <mailto:lucee+un...@googlegroups.com>.
    To post to this group, send email to lu...@googlegroups.com
    <mailto:lu...@googlegroups.com>.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com
    <https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com?utm_medium=email&utm_source=footer>.
    For more options, visit https://groups.google.com/d/optout.

 

-- 
You received this message because you are subscribed to the
Google Groups "Lucee" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to lucee+unsubscribe@googlegroups.com
<mailto:lucee+unsubscribe@googlegroups.com>.
To post to this group, send email to lucee@googlegroups.com
<mailto:lucee@googlegroups.com>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com
<https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com?utm_medium=email&utm_source=footer>.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in
the Google Groups “Lucee” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/lucee/0bQpWRQLiFY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
lucee+unsubscribe@googlegroups.com
mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com
mailto:lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com
https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it,
send an email to lucee+unsubscribe@googlegroups.com
mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com
mailto:lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/002f01d0abb1%24ca972ad0%245fc58070%24%40westhold.com
https://groups.google.com/d/msgid/lucee/002f01d0abb1%24ca972ad0%245fc58070%24%40westhold.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to lucee+unsubscribe@googlegroups.com
mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com
mailto:lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/3D1D845D-0F7F-4D69-8BBF-80269E59C7BF%40silowebworks.com
https://groups.google.com/d/msgid/lucee/3D1D845D-0F7F-4D69-8BBF-80269E59C7BF%40silowebworks.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

btw: if i create a dummy.htm, a dummy.txt, and a dummy.cfm (all three the
exact same with one line

you are in dummy


If I use http://localhost/my_site/dummy.htm --> it works
If I use http://localhost/my_site/dummy.txt --> it works
If I use http://localhost/my_site/dummy.cfm --> it fails with:
Message Page /my_site/dummy.cfm (c:\inetpub\wwwroot\my_site\dummy.cfm) not
found.On Saturday, June 20, 2015 at 6:14:49 PM UTC-5, pat forbes wrote:

Thank you for your reply.
Yep… I did type a lot. I wanted to make sure I explained it. Probably
too wordy :slight_smile:

I added the context path to the existing entry in server.xml like this:

  <Host name="localhost" appBase="webapps">
    <Context path="" docBase="C:\inetpub\wwwroot\" />
    <Context path="/my_site" 

docBase=“C:/inetpub/wwwroot/websites/my_site” />

and then restarted Tomcat
but I get the exact same error:

It still shows
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not
found.

It stll thinks my_site is a sub folder of c:\inetpub\wwwroot"
when its actually c:\inetpub\wwwroot\websites

-pat-

On Saturday, June 20, 2015 at 5:14:26 PM UTC-5, Igal wrote:

you managed to type quite a bit with bleeding fingers and swollen eyes,
so TBH I didn’t read it all in detail, but…

looks to me like what you’re missing is a Context/path entry in
Tomcat/conf/server.xml, so for the Host element of that site, you want to
add something like:

<Context path="/my_site" 

docBase=“C:/inetpub/wwwroot/websites/my_site” />

and restart Tomcat for the changes to take effect.

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/
On 6/20/2015 3:06 PM, pat forbes wrote:

I am really sorry, but I’ve about goggled myself to death, my eyes are
swollen, and my fingers are bleeding.

I have tried this with Lucee and now Railo 4.2.1.008 (windows 2008 and
IIS7)

To add a “virtual directory” in IIS7, all that’s needed is to:

  1. Right click the “Default Web site”,
  2. Select the “Add Virtual Directory”,
  3. Put the name in the Alias field (ie, “my_site”)
  4. Add the Physical Path (C:\inetpub\wwwroot\websites\my_site)

and bada bing, it’s done… ready to be used.

I can go to http://localhost/my_site/index.htm and it displays fine

But if I put a cfm file in that folder and go to
http://localhost/my_site/index.cfm, using .cfm instead of .htm) I get an
error:
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm)
not found.

That is is NOT where the file is… it should have been:
C:\inetpub\wwwroot\websites\my_site\index.cfm
It should have said: c:\inetpub\wwwroot\my_site\index.cfm

It appears that Railo/Lucee is not using the same virtual dir that was
setup in IIS7.

Railo/Lucee thinks the vittual dir is c:\inetpub\wwwroot\my_site
and IIS7 thinks it is C:\inetpub\wwwroot\websites\my_site (where it
actually is)

If I put ANY htm file in C:\inetpub\wwwroot\websites\my_site, it will
display with localhost/my_site/filename.htm

But if I put ANY cfm file in C:\inetpub\wwwroot\websites\my_site, and try
to use localhost/my_site/filename.cfm I’ll get the error.

btw: If I move the folder to C:\inetpub\wwwroot\my_site and set the
Physical Path (C:\inetpub\wwwroot\my_site) everything works.

I just don’t understand why a cfm file will not display if it’s in a sub
directory (ie c:\inetpub\wwwroot\websites)

It’s like IIS7 handles the alias ok, but Railo/Lucee needs another
setting so that it maps to the correct folder.

What am missing?

btw: I’ve been coding CFML since it was version .9 (yep, point 9)

-pat-


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com
https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

I’m not seeing where this goes in context.xml

<!-- Default set of monitored resources -->

<WatchedResource>WEB-INF/web.xml</WatchedResource>



<!-- Uncomment this to disable session persistence across Tomcat restarts -->

<!--

<Manager pathname="" />

-->



<!-- Uncomment this to enable Comet connection tacking (provides events

     on session expiration as well as webapp lifecycle) -->

<!--

<Valve className="org.apache.catalina.valves.CometConnectionManagerValve" />

-->

I’m really sorry for being able to get this.

-pat-From: lucee@googlegroups.com [mailto:lucee@googlegroups.com] On Behalf Of Jon Clausen
Sent: Saturday, June 20, 2015 6:29 PM
To: lucee@googlegroups.com
Subject: Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

I think you need the “allowLinking” attribute in your Tomcat context config:

allowLinking=“true”

HTH,

Jon

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:19 PM, pat forbes <@pat_forbes> wrote:

btw: if i create a dummy.htm, a dummy.txt, and a dummy.cfm (all three the exact same with one line

you are in dummy


If I use http://localhost/my_site/dummy.htm --> it works
If I use http://localhost/my_site/dummy.txt --> it works
If I use http://localhost/my_site/dummy.cfm --> it fails with:
Message Page /my_site/dummy.cfm (c:\inetpub\wwwroot\my_site\dummy.cfm) not found.

On Saturday, June 20, 2015 at 6:14:49 PM UTC-5, pat forbes wrote:

Thank you for your reply.
Yep… I did type a lot. I wanted to make sure I explained it. Probably too wordy :slight_smile:

I added the context path to the existing entry in server.xml like this:

  <Host name="localhost" appBase="webapps">
    <Context path="" docBase="C:\inetpub\wwwroot\" />
    <Context path="/my_site" docBase="C:/inetpub/wwwroot/websites/my_site" />
  </Host>

and then restarted Tomcat
but I get the exact same error:

It still shows
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not found.

It stll thinks my_site is a sub folder of c:\inetpub\wwwroot"
when its actually c:\inetpub\wwwroot\websites

-pat-

On Saturday, June 20, 2015 at 5:14:26 PM UTC-5, Igal wrote:

you managed to type quite a bit with bleeding fingers and swollen eyes, so TBH I didn’t read it all in detail, but…

looks to me like what you’re missing is a Context/path entry in Tomcat/conf/server.xml, so for the Host element of that site, you want to add something like:

<Context path="/my_site" docBase="C:/inetpub/wwwroot/websites/my_site" />

and restart Tomcat for the changes to take effect.

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/

On 6/20/2015 3:06 PM, pat forbes wrote:

I am really sorry, but I’ve about goggled myself to death, my eyes are swollen, and my fingers are bleeding.

I have tried this with Lucee and now Railo 4.2.1.008 (windows 2008 and IIS7)

To add a “virtual directory” in IIS7, all that’s needed is to:

  1. Right click the “Default Web site”,
  2. Select the “Add Virtual Directory”,
  3. Put the name in the Alias field (ie, “my_site”)
  4. Add the Physical Path (C:\inetpub\wwwroot\websites\my_site)

and bada bing, it’s done… ready to be used.

I can go to http://localhost/my_site/index.htm and it displays fine

But if I put a cfm file in that folder and go to http://localhost/my_site/index.cfm, using .cfm instead of .htm) I get an error:
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not found.

That is is NOT where the file is… it should have been:
C:\inetpub\wwwroot\websites\my_site\index.cfm
It should have said: c:\inetpub\wwwroot\my_site\index.cfm

It appears that Railo/Lucee is not using the same virtual dir that was setup in IIS7.

Railo/Lucee thinks the vittual dir is c:\inetpub\wwwroot\my_site
and IIS7 thinks it is C:\inetpub\wwwroot\websites\my_site (where it actually is)

If I put ANY htm file in C:\inetpub\wwwroot\websites\my_site, it will display with localhost/my_site/filename.htm

But if I put ANY cfm file in C:\inetpub\wwwroot\websites\my_site, and try to use localhost/my_site/filename.cfm I’ll get the error.

btw: If I move the folder to C:\inetpub\wwwroot\my_site and set the Physical Path (C:\inetpub\wwwroot\my_site) everything works.

I just don’t understand why a cfm file will not display if it’s in a sub directory (ie c:\inetpub\wwwroot\websites)

It’s like IIS7 handles the alias ok, but Railo/Lucee needs another setting so that it maps to the correct folder.

What am missing?

btw: I’ve been coding CFML since it was version .9 (yep, point 9)

-pat-


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the Google Groups “Lucee” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/lucee/0bQpWRQLiFY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.

No problem. Inside the Context tag:

https://tomcat.apache.org/tomcat-5.5-doc/config/context.html

[Note: Typo assistance courtesy of iPhone]> On Jun 20, 2015, at 7:35 PM, <@pat_forbes> <@pat_forbes> wrote:

I’m not seeing where this goes in context.xml


WEB-INF/web.xml

<!-- Uncomment this to disable session persistence across Tomcat restarts -->
<!--
<Manager pathname="" />
-->

<!-- Uncomment this to enable Comet connection tacking (provides events
     on session expiration as well as webapp lifecycle) -->
<!--
<Valve className="org.apache.catalina.valves.CometConnectionManagerValve" />
-->
I’m really sorry for being able to get this.

-pat-

From: lucee@googlegroups.com [mailto:lucee@googlegroups.com] On Behalf Of Jon Clausen
Sent: Saturday, June 20, 2015 6:29 PM
To: lucee@googlegroups.com
Subject: Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

I think you need the “allowLinking” attribute in your Tomcat context config:

allowLinking=“true”
HTH,
Jon

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:19 PM, pat forbes <@pat_forbes> wrote:

btw: if i create a dummy.htm, a dummy.txt, and a dummy.cfm (all three the exact same with one line

you are in dummy


If I use http://localhost/my_site/dummy.htm --> it works
If I use http://localhost/my_site/dummy.txt --> it works
If I use http://localhost/my_site/dummy.cfm --> it fails with:
Message Page /my_site/dummy.cfm (c:\inetpub\wwwroot\my_site\dummy.cfm) not found.

On Saturday, June 20, 2015 at 6:14:49 PM UTC-5, pat forbes wrote:
Thank you for your reply.
Yep… I did type a lot. I wanted to make sure I explained it. Probably too wordy :slight_smile:

I added the context path to the existing entry in server.xml like this:

  <Host name="localhost" appBase="webapps">
    <Context path="" docBase="C:\inetpub\wwwroot\" />
    <Context path="/my_site" docBase="C:/inetpub/wwwroot/websites/my_site" />
  </Host>

and then restarted Tomcat
but I get the exact same error:

It still shows
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not found.

It stll thinks my_site is a sub folder of c:\inetpub\wwwroot"
when its actually c:\inetpub\wwwroot\websites

-pat-

On Saturday, June 20, 2015 at 5:14:26 PM UTC-5, Igal wrote:
you managed to type quite a bit with bleeding fingers and swollen eyes, so TBH I didn’t read it all in detail, but…

looks to me like what you’re missing is a Context/path entry in Tomcat/conf/server.xml, so for the Host element of that site, you want to add something like:

<Context path="/my_site" docBase="C:/inetpub/wwwroot/websites/my_site" />

and restart Tomcat for the changes to take effect.

Igal Sapir
Lucee Core Developer
Lucee.org

On 6/20/2015 3:06 PM, pat forbes wrote:
I am really sorry, but I’ve about goggled myself to death, my eyes are swollen, and my fingers are bleeding.

I have tried this with Lucee and now Railo 4.2.1.008 (windows 2008 and IIS7)

To add a “virtual directory” in IIS7, all that’s needed is to:

  1. Right click the “Default Web site”,
  2. Select the “Add Virtual Directory”,
  3. Put the name in the Alias field (ie, “my_site”)
  4. Add the Physical Path (C:\inetpub\wwwroot\websites\my_site)

and bada bing, it’s done… ready to be used.

I can go to http://localhost/my_site/index.htm and it displays fine

But if I put a cfm file in that folder and go to http://localhost/my_site/index.cfm, using .cfm instead of .htm) I get an error:
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not found.

That is is NOT where the file is… it should have been:
C:\inetpub\wwwroot\websites\my_site\index.cfm
It should have said: c:\inetpub\wwwroot\my_site\index.cfm

It appears that Railo/Lucee is not using the same virtual dir that was setup in IIS7.

Railo/Lucee thinks the vittual dir is c:\inetpub\wwwroot\my_site
and IIS7 thinks it is C:\inetpub\wwwroot\websites\my_site (where it actually is)

If I put ANY htm file in C:\inetpub\wwwroot\websites\my_site, it will display with localhost/my_site/filename.htm

But if I put ANY cfm file in C:\inetpub\wwwroot\websites\my_site, and try to use localhost/my_site/filename.cfm I’ll get the error.

btw: If I move the folder to C:\inetpub\wwwroot\my_site and set the Physical Path (C:\inetpub\wwwroot\my_site) everything works.

I just don’t understand why a cfm file will not display if it’s in a sub directory (ie c:\inetpub\wwwroot\websites)

It’s like IIS7 handles the alias ok, but Railo/Lucee needs another setting so that it maps to the correct folder.

What am missing?

btw: I’ve been coding CFML since it was version .9 (yep, point 9)

-pat-


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to a topic in the Google Groups “Lucee” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/lucee/0bQpWRQLiFY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/002f01d0abb1%24ca972ad0%245fc58070%24%40westhold.com.
For more options, visit https://groups.google.com/d/optout.

I think you need the “allowLinking” attribute in your Tomcat context config:

allowLinking=“true”
HTH,
Jon

[Note: Typo assistance courtesy of iPhone]> On Jun 20, 2015, at 7:19 PM, pat forbes <@pat_forbes> wrote:

btw: if i create a dummy.htm, a dummy.txt, and a dummy.cfm (all three the exact same with one line

you are in dummy


If I use http://localhost/my_site/dummy.htm --> it works
If I use http://localhost/my_site/dummy.txt --> it works
If I use http://localhost/my_site/dummy.cfm --> it fails with:
Message Page /my_site/dummy.cfm (c:\inetpub\wwwroot\my_site\dummy.cfm) not found.

On Saturday, June 20, 2015 at 6:14:49 PM UTC-5, pat forbes wrote:
Thank you for your reply.
Yep… I did type a lot. I wanted to make sure I explained it. Probably too wordy :slight_smile:

I added the context path to the existing entry in server.xml like this:

  <Host name="localhost" appBase="webapps">
    <Context path="" docBase="C:\inetpub\wwwroot\" />
    <Context path="/my_site" docBase="C:/inetpub/wwwroot/websites/my_site" />
  </Host>

and then restarted Tomcat
but I get the exact same error:

It still shows
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not found.

It stll thinks my_site is a sub folder of c:\inetpub\wwwroot"
when its actually c:\inetpub\wwwroot\websites

-pat-

On Saturday, June 20, 2015 at 5:14:26 PM UTC-5, Igal wrote:
you managed to type quite a bit with bleeding fingers and swollen eyes, so TBH I didn’t read it all in detail, but…

looks to me like what you’re missing is a Context/path entry in Tomcat/conf/server.xml, so for the Host element of that site, you want to add something like:

<Context path="/my_site" docBase="C:/inetpub/wwwroot/websites/my_site" />

and restart Tomcat for the changes to take effect.

Igal Sapir
Lucee Core Developer
Lucee.org

On 6/20/2015 3:06 PM, pat forbes wrote:
I am really sorry, but I’ve about goggled myself to death, my eyes are swollen, and my fingers are bleeding.

I have tried this with Lucee and now Railo 4.2.1.008 (windows 2008 and IIS7)

To add a “virtual directory” in IIS7, all that’s needed is to:

  1. Right click the “Default Web site”,
  2. Select the “Add Virtual Directory”,
  3. Put the name in the Alias field (ie, “my_site”)
  4. Add the Physical Path (C:\inetpub\wwwroot\websites\my_site)

and bada bing, it’s done… ready to be used.

I can go to http://localhost/my_site/index.htm and it displays fine

But if I put a cfm file in that folder and go to http://localhost/my_site/index.cfm, using .cfm instead of .htm) I get an error:
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not found.

That is is NOT where the file is… it should have been:
C:\inetpub\wwwroot\websites\my_site\index.cfm
It should have said: c:\inetpub\wwwroot\my_site\index.cfm

It appears that Railo/Lucee is not using the same virtual dir that was setup in IIS7.

Railo/Lucee thinks the vittual dir is c:\inetpub\wwwroot\my_site
and IIS7 thinks it is C:\inetpub\wwwroot\websites\my_site (where it actually is)

If I put ANY htm file in C:\inetpub\wwwroot\websites\my_site, it will display with localhost/my_site/filename.htm

But if I put ANY cfm file in C:\inetpub\wwwroot\websites\my_site, and try to use localhost/my_site/filename.cfm I’ll get the error.

btw: If I move the folder to C:\inetpub\wwwroot\my_site and set the Physical Path (C:\inetpub\wwwroot\my_site) everything works.

I just don’t understand why a cfm file will not display if it’s in a sub directory (ie c:\inetpub\wwwroot\websites)

It’s like IIS7 handles the alias ok, but Railo/Lucee needs another setting so that it maps to the correct folder.

What am missing?

btw: I’ve been coding CFML since it was version .9 (yep, point 9)

-pat-


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

what happens when you go to localhost/websites/my_site/index.cfm ? does
it work then or do you get the same issue?

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/On 6/20/2015 5:08 PM, @pat_forbes wrote:

Thank you.

Re-iterating

Folder is “c:\inetpub\wwwroot\websites\my_site”

IIs7 Alias is “my_site”

localhost/my_site/index.htm WORKS

localhost/my_site/index.cfm FAILS

Any htm, txt, etc in my_site works,

any cfm fails

There has to be a setting somewhere that I am missing.

*From:*lucee@googlegroups.com [mailto:lucee@googlegroups.com] *On
Behalf Of *Jon Clausen
Sent: Saturday, June 20, 2015 7:01 PM
To: lucee@googlegroups.com
Subject: Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

Oh, crud. You’re right Igal. Disregard, Pat, since you’re on Windows.
I know there’s an alternate setting for this as a workaround for
Windows, but I’m away from a computer at the moment. Let me check in
a bit and get back to you, Pat.

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:42 PM, Igal @ Lucee.org mailto:Lucee.org <@Igal mailto:Igal> wrote:

@Jon, this is from the Tomcat 7 docs:

https://tomcat.apache.org/tomcat-7.0-doc/config/context.html#Common_Attributes

"*NOTE: This flag MUST NOT be set to true on the Windows platform
(or any other OS which does not have a case sensitive filesystem),
as it will disable case sensitivity checks, allowing JSP source
code disclosure, among other security problems."*

Igal Sapir
Lucee Core Developer
Lucee.org <http://lucee.org/>

On 6/20/2015 4:38 PM, Jon Clausen wrote:

    No problem.  Inside the Context tag:

     

    https://tomcat.apache.org/tomcat-5.5-doc/config/context.html

    [Note: Typo assistance courtesy of iPhone]


    On Jun 20, 2015, at 7:35 PM, <@pat_forbes <mailto:@pat_forbes>> <@pat_forbes <mailto:@pat_forbes>> wrote:

        I’m not seeing where this goes in context.xml

        <Context useHttpOnly="true">

            <!-- Default set of monitored resources -->

            <WatchedResource>WEB-INF/web.xml</WatchedResource>

         

            <!-- Uncomment this to disable session persistence
        across Tomcat restarts -->

            <!--

            <Manager pathname="" />

            -->

         

            <!-- Uncomment this to enable Comet connection tacking
        (provides events

                 on session expiration as well as webapp
        lifecycle) -->

            <!--

            <Valve
        className="org.apache.catalina.valves.CometConnectionManagerValve"
        />

            -->

        </Context>

        I’m really sorry for being able to get this.

         

        -pat-

         

         

         

        *From:*lucee@googlegroups.com
        <mailto:lucee@googlegroups.com>
        [mailto:lucee@googlegroups.com] *On Behalf Of *Jon Clausen
        *Sent:* Saturday, June 20, 2015 6:29 PM
        *To:* lucee@googlegroups.com <mailto:lucee@googlegroups.com>
        *Subject:* Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

         

        I think you need the "allowLinking" attribute in your
        Tomcat context config:

         

        allowLinking="true"

        HTH,

        Jon


        [Note: Typo assistance courtesy of iPhone]


        On Jun 20, 2015, at 7:19 PM, pat forbes <@pat_forbes <mailto:@pat_forbes>> wrote:

            btw: if i create a dummy.htm, a dummy.txt, and a
            dummy.cfm (all three the exact same with one
            line<h2>you are in dummy</h2>
            If I use http://localhost/my_site/dummy.htm --> it works
            If I use http://localhost/my_site/dummy.txt --> it works
            If I use http://localhost/my_site/dummy.cfm --> it
            fails with:
            Message Page /my_site/dummy.cfm
            (c:\inetpub\wwwroot\my_site\dummy.cfm) not found.

            On Saturday, June 20, 2015 at 6:14:49 PM UTC-5, pat forbes wrote:

            Thank you for your reply.
            Yep... I did type a lot.  I wanted to make sure I
            explained it.  Probably too wordy :)

            I added  the context path to the existing entry in
            server.xml like this:

                  <Host name="localhost" appBase="webapps">
                    <Context path="" docBase="C:\inetpub\wwwroot\" />
                    <Context path="/my_site"
            docBase="C:/inetpub/wwwroot/websites/my_site" />
                  </Host>

            and then restarted Tomcat
            but I get the exact same error:

            It still shows
            Railo 4.2.1.008 Error (missinginclude)
            Message Page /my_site/index.cfm
            (c:\inetpub\wwwroot\my_site\index.cfm) not found.

            It stll thinks my_site is a sub folder of
            c:\inetpub\wwwroot\"
            when its actually c:\inetpub\wwwroot\websites

            -pat-


            On Saturday, June 20, 2015 at 5:14:26 PM UTC-5, Igal wrote:

            you managed to type quite a bit with bleeding fingers
            and swollen eyes, so TBH I didn't read it all in
            detail, but...

            looks to me like what you're missing is a Context/path
            entry in Tomcat/conf/server.xml, so for the Host
            element of that site, you want to add something like:

                <Context path="/my_site"
            docBase="C:/inetpub/wwwroot/websites/my_site" />

            and restart Tomcat for the changes to take effect.

            Igal Sapir
            Lucee Core Developer
            Lucee.org <http://lucee.org/>

            On 6/20/2015 3:06 PM, pat forbes wrote:

                I am really sorry, but I've about goggled myself
                to death, my eyes are swollen, and my fingers are
                bleeding.

                I have tried this with Lucee and now Railo
                4.2.1.008 (windows 2008 and IIS7)

                To add a "virtual directory" in IIS7, all that's
                needed is to:
                1. Right click the "Default Web site",
                2. Select the "Add Virtual Directory",
                3. Put the name in the Alias field (ie, "my_site")
                4. Add the Physical Path
                (C:\inetpub\wwwroot\websites\my_site)

                and bada bing, it's done... ready to be used.

                I can go to http://localhost/my_site/index.htm and
                it displays fine

                But if I put a cfm file in that folder and go to
                http://localhost/my_site/index.cfm, using .cfm
                instead of .htm) I get an error:
                Railo 4.2.1.008 Error (missinginclude)
                Message Page /my_site/index.cfm
                (c:\inetpub\wwwroot\my_site\index.cfm) not found.

                That is is NOT where the file is... it should have
                been:
                C:\inetpub\wwwroot\websites\my_site\index.cfm
                It should have said:
                c:\inetpub\wwwroot\my_site\index.cfm

                It appears that Railo/Lucee is not using the same
                virtual dir that was setup in IIS7.

                Railo/Lucee thinks the vittual dir is
                c:\inetpub\wwwroot\my_site
                and IIS7 thinks it is
                C:\inetpub\wwwroot\websites\my_site (where it
                actually is)

                If I put ANY htm file in
                C:\inetpub\wwwroot\websites\my_site, it will
                display with localhost/my_site/filename.htm

                But if I put ANY cfm file in
                C:\inetpub\wwwroot\websites\my_site, and try to
                use localhost/my_site/filename.cfm I'll get the error.

                btw: If I move the folder to
                C:\inetpub\wwwroot\my_site and set the Physical
                Path (C:\inetpub\wwwroot\my_site) everything works.

                I just don't understand why a cfm file will not
                display if it's in a sub directory (ie
                c:\inetpub\wwwroot\websites)

                It's like IIS7 handles the alias ok, but
                Railo/Lucee needs another setting so that it maps
                to the correct folder.

                What am missing?

                btw: I've been coding CFML since it was version
                .9  (yep, point 9)

                -pat-





                -- 
                You received this message because you are
                subscribed to the Google Groups "Lucee" group.
                To unsubscribe from this group and stop receiving
                emails from it, send an email to
                lucee+un...@googlegroups.com
                <mailto:lucee+un...@googlegroups.com>.
                To post to this group, send email to
                lu...@googlegroups.com
                <mailto:lu...@googlegroups.com>.
                To view this discussion on the web visit
                https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com
                <https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com?utm_medium=email&utm_source=footer>.
                For more options, visit
                https://groups.google.com/d/optout.

             

            -- 
            You received this message because you are subscribed
            to the Google Groups "Lucee" group.
            To unsubscribe from this group and stop receiving
            emails from it, send an email to
            lucee+unsubscribe@googlegroups.com
            <mailto:lucee+unsubscribe@googlegroups.com>.
            To post to this group, send email to
            lucee@googlegroups.com <mailto:lucee@googlegroups.com>.
            To view this discussion on the web visit
            https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com
            <https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com?utm_medium=email&utm_source=footer>.
            For more options, visit
            https://groups.google.com/d/optout.

        -- 
        You received this message because you are subscribed to a
        topic in the Google Groups "Lucee" group.
        To unsubscribe from this topic, visit
        https://groups.google.com/d/topic/lucee/0bQpWRQLiFY/unsubscribe.
        To unsubscribe from this group and all its topics, send an
        email to lucee+unsubscribe@googlegroups.com
        <mailto:lucee+unsubscribe@googlegroups.com>.
        To post to this group, send email to
        lucee@googlegroups.com <mailto:lucee@googlegroups.com>.
        To view this discussion on the web visit
        https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com
        <https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com?utm_medium=email&utm_source=footer>.
        For more options, visit https://groups.google.com/d/optout.

        -- 
        You received this message because you are subscribed to
        the Google Groups "Lucee" group.
        To unsubscribe from this group and stop receiving emails
        from it, send an email to
        lucee+unsubscribe@googlegroups.com
        <mailto:lucee+unsubscribe@googlegroups.com>.
        To post to this group, send email to
        lucee@googlegroups.com <mailto:lucee@googlegroups.com>.
        To view this discussion on the web visit
        https://groups.google.com/d/msgid/lucee/002f01d0abb1%24ca972ad0%245fc58070%24%40westhold.com
        <https://groups.google.com/d/msgid/lucee/002f01d0abb1%24ca972ad0%245fc58070%24%40westhold.com?utm_medium=email&utm_source=footer>.
        For more options, visit https://groups.google.com/d/optout.

    -- 
    You received this message because you are subscribed to the
    Google Groups "Lucee" group.
    To unsubscribe from this group and stop receiving emails from
    it, send an email to lucee+unsubscribe@googlegroups.com
    <mailto:lucee+unsubscribe@googlegroups.com>.
    To post to this group, send email to lucee@googlegroups.com
    <mailto:lucee@googlegroups.com>.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/lucee/3D1D845D-0F7F-4D69-8BBF-80269E59C7BF%40silowebworks.com
    <https://groups.google.com/d/msgid/lucee/3D1D845D-0F7F-4D69-8BBF-80269E59C7BF%40silowebworks.com?utm_medium=email&utm_source=footer>.
    For more options, visit https://groups.google.com/d/optout.

 

-- 
You received this message because you are subscribed to the Google
Groups "Lucee" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to lucee+unsubscribe@googlegroups.com
<mailto:lucee+unsubscribe@googlegroups.com>.
To post to this group, send email to lucee@googlegroups.com
<mailto:lucee@googlegroups.com>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/5585FA4C.6090406%40lucee.org
<https://groups.google.com/d/msgid/lucee/5585FA4C.6090406%40lucee.org?utm_medium=email&utm_source=footer>.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “Lucee” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/lucee/0bQpWRQLiFY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
lucee+unsubscribe@googlegroups.com
mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com
mailto:lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/EED41C88-3824-4CF2-AD91-1D0EBA183CEB%40silowebworks.com
https://groups.google.com/d/msgid/lucee/EED41C88-3824-4CF2-AD91-1D0EBA183CEB%40silowebworks.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to lucee+unsubscribe@googlegroups.com
mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com
mailto:lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/004801d0abb6%2468e8cff0%243aba6fd0%24%40westhold.com
https://groups.google.com/d/msgid/lucee/004801d0abb6%2468e8cff0%243aba6fd0%24%40westhold.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

Oh, crud. You’re right Igal. Disregard, Pat, since you’re on Windows. I know there’s an alternate setting for this as a workaround for Windows, but I’m away from a computer at the moment. Let me check in a bit and get back to you, Pat.

[Note: Typo assistance courtesy of iPhone]> On Jun 20, 2015, at 7:42 PM, Igal @ Lucee.org <@Igal> wrote:

@Jon, this is from the Tomcat 7 docs:

https://tomcat.apache.org/tomcat-7.0-doc/config/context.html#Common_Attributes

“NOTE: This flag MUST NOT be set to true on the Windows platform (or any other OS which does not have a case sensitive filesystem), as it will disable case sensitivity checks, allowing JSP source code disclosure, among other security problems.”

Igal Sapir
Lucee Core Developer
Lucee.org

On 6/20/2015 4:38 PM, Jon Clausen wrote:
No problem. Inside the Context tag:

https://tomcat.apache.org/tomcat-5.5-doc/config/context.html

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:35 PM, <@pat_forbes> <@pat_forbes> wrote:

I’m not seeing where this goes in context.xml


WEB-INF/web.xml

<!-- Uncomment this to disable session persistence across Tomcat restarts -->
<!--
<Manager pathname="" />
-->

<!-- Uncomment this to enable Comet connection tacking (provides events
     on session expiration as well as webapp lifecycle) -->
<!--
<Valve className="org.apache.catalina.valves.CometConnectionManagerValve" />
-->
I’m really sorry for being able to get this.

-pat-

From: lucee@googlegroups.com [mailto:lucee@googlegroups.com] On Behalf Of Jon Clausen
Sent: Saturday, June 20, 2015 6:29 PM
To: lucee@googlegroups.com
Subject: Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

I think you need the “allowLinking” attribute in your Tomcat context config:

allowLinking=“true”
HTH,
Jon

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:19 PM, pat forbes <@pat_forbes> wrote:

btw: if i create a dummy.htm, a dummy.txt, and a dummy.cfm (all three the exact same with one line

you are in dummy


If I use http://localhost/my_site/dummy.htm --> it works
If I use http://localhost/my_site/dummy.txt --> it works
If I use http://localhost/my_site/dummy.cfm --> it fails with:
Message Page /my_site/dummy.cfm (c:\inetpub\wwwroot\my_site\dummy.cfm) not found.

On Saturday, June 20, 2015 at 6:14:49 PM UTC-5, pat forbes wrote:
Thank you for your reply.
Yep… I did type a lot. I wanted to make sure I explained it. Probably too wordy :slight_smile:

I added the context path to the existing entry in server.xml like this:

  <Host name="localhost" appBase="webapps">
    <Context path="" docBase="C:\inetpub\wwwroot\" />
    <Context path="/my_site" docBase="C:/inetpub/wwwroot/websites/my_site" />
  </Host>

and then restarted Tomcat
but I get the exact same error:

It still shows
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not found.

It stll thinks my_site is a sub folder of c:\inetpub\wwwroot"
when its actually c:\inetpub\wwwroot\websites

-pat-

On Saturday, June 20, 2015 at 5:14:26 PM UTC-5, Igal wrote:
you managed to type quite a bit with bleeding fingers and swollen eyes, so TBH I didn’t read it all in detail, but…

looks to me like what you’re missing is a Context/path entry in Tomcat/conf/server.xml, so for the Host element of that site, you want to add something like:

<Context path="/my_site" docBase="C:/inetpub/wwwroot/websites/my_site" />

and restart Tomcat for the changes to take effect.

Igal Sapir
Lucee Core Developer
Lucee.org

On 6/20/2015 3:06 PM, pat forbes wrote:
I am really sorry, but I’ve about goggled myself to death, my eyes are swollen, and my fingers are bleeding.

I have tried this with Lucee and now Railo 4.2.1.008 (windows 2008 and IIS7)

To add a “virtual directory” in IIS7, all that’s needed is to:

  1. Right click the “Default Web site”,
  2. Select the “Add Virtual Directory”,
  3. Put the name in the Alias field (ie, “my_site”)
  4. Add the Physical Path (C:\inetpub\wwwroot\websites\my_site)

and bada bing, it’s done… ready to be used.

I can go to http://localhost/my_site/index.htm and it displays fine

But if I put a cfm file in that folder and go to http://localhost/my_site/index.cfm, using .cfm instead of .htm) I get an error:
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not found.

That is is NOT where the file is… it should have been:
C:\inetpub\wwwroot\websites\my_site\index.cfm
It should have said: c:\inetpub\wwwroot\my_site\index.cfm

It appears that Railo/Lucee is not using the same virtual dir that was setup in IIS7.

Railo/Lucee thinks the vittual dir is c:\inetpub\wwwroot\my_site
and IIS7 thinks it is C:\inetpub\wwwroot\websites\my_site (where it actually is)

If I put ANY htm file in C:\inetpub\wwwroot\websites\my_site, it will display with localhost/my_site/filename.htm

But if I put ANY cfm file in C:\inetpub\wwwroot\websites\my_site, and try to use localhost/my_site/filename.cfm I’ll get the error.

btw: If I move the folder to C:\inetpub\wwwroot\my_site and set the Physical Path (C:\inetpub\wwwroot\my_site) everything works.

I just don’t understand why a cfm file will not display if it’s in a sub directory (ie c:\inetpub\wwwroot\websites)

It’s like IIS7 handles the alias ok, but Railo/Lucee needs another setting so that it maps to the correct folder.

What am missing?

btw: I’ve been coding CFML since it was version .9 (yep, point 9)

-pat-


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to a topic in the Google Groups “Lucee” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/lucee/0bQpWRQLiFY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/002f01d0abb1%24ca972ad0%245fc58070%24%40westhold.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/3D1D845D-0F7F-4D69-8BBF-80269E59C7BF%40silowebworks.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/5585FA4C.6090406%40lucee.org.
For more options, visit https://groups.google.com/d/optout.

I take that back…

localhost/websites/my_site/index.htm

localhost/websites/my_site/index.cfm

both generate 500.23 internal server errorsFrom: lucee@googlegroups.com [mailto:lucee@googlegroups.com] On Behalf Of Igal @ Lucee.org
Sent: Saturday, June 20, 2015 7:15 PM
To: lucee@googlegroups.com
Subject: Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

what happens when you go to localhost/websites/my_site/index.cfm ? does it work then or do you get the same issue?

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/

On 6/20/2015 5:08 PM, @pat_forbes wrote:

Thank you.

Re-iterating

Folder is “c:\inetpub\wwwroot\websites\my_site”

IIs7 Alias is “my_site”

localhost/my_site/index.htm WORKS

localhost/my_site/index.cfm FAILS

Any htm, txt, etc in my_site works,

any cfm fails

There has to be a setting somewhere that I am missing.

From: lucee@googlegroups.com [mailto:lucee@googlegroups.com] On Behalf Of Jon Clausen
Sent: Saturday, June 20, 2015 7:01 PM
To: lucee@googlegroups.com
Subject: Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

Oh, crud. You’re right Igal. Disregard, Pat, since you’re on Windows. I know there’s an alternate setting for this as a workaround for Windows, but I’m away from a computer at the moment. Let me check in a bit and get back to you, Pat.

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:42 PM, Igal @ Lucee.org <@Igal> wrote:

@Jon, this is from the Tomcat 7 docs:

https://tomcat.apache.org/tomcat-7.0-doc/config/context.html#Common_Attributes

“NOTE: This flag MUST NOT be set to true on the Windows platform (or any other OS which does not have a case sensitive filesystem), as it will disable case sensitivity checks, allowing JSP source code disclosure, among other security problems.”

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/

On 6/20/2015 4:38 PM, Jon Clausen wrote:

No problem. Inside the Context tag:

https://tomcat.apache.org/tomcat-5.5-doc/config/context.html

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:35 PM, <@pat_forbes> <@pat_forbes> wrote:

I’m not seeing where this goes in context.xml

<!-- Default set of monitored resources -->

<WatchedResource>WEB-INF/web.xml</WatchedResource>



<!-- Uncomment this to disable session persistence across Tomcat restarts -->

<!--

<Manager pathname="" />

-->



<!-- Uncomment this to enable Comet connection tacking (provides events

     on session expiration as well as webapp lifecycle) -->

<!--

<Valve className="org.apache.catalina.valves.CometConnectionManagerValve" />

-->

I’m really sorry for being able to get this.

-pat-

From: lucee@googlegroups.com [mailto:lucee@googlegroups.com] On Behalf Of Jon Clausen
Sent: Saturday, June 20, 2015 6:29 PM
To: lucee@googlegroups.com
Subject: Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

I think you need the “allowLinking” attribute in your Tomcat context config:

allowLinking=“true”

HTH,

Jon

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:19 PM, pat forbes <@pat_forbes> wrote:

btw: if i create a dummy.htm, a dummy.txt, and a dummy.cfm (all three the exact same with one line

you are in dummy


If I use http://localhost/my_site/dummy.htm --> it works
If I use http://localhost/my_site/dummy.txt --> it works
If I use http://localhost/my_site/dummy.cfm --> it fails with:
Message Page /my_site/dummy.cfm (c:\inetpub\wwwroot\my_site\dummy.cfm) not found.

On Saturday, June 20, 2015 at 6:14:49 PM UTC-5, pat forbes wrote:

Thank you for your reply.
Yep… I did type a lot. I wanted to make sure I explained it. Probably too wordy :slight_smile:

I added the context path to the existing entry in server.xml like this:

  <Host name="localhost" appBase="webapps">
    <Context path="" docBase="C:\inetpub\wwwroot\" />
    <Context path="/my_site" docBase="C:/inetpub/wwwroot/websites/my_site" />
  </Host>

and then restarted Tomcat
but I get the exact same error:

It still shows
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not found.

It stll thinks my_site is a sub folder of c:\inetpub\wwwroot"
when its actually c:\inetpub\wwwroot\websites

-pat-

On Saturday, June 20, 2015 at 5:14:26 PM UTC-5, Igal wrote:

you managed to type quite a bit with bleeding fingers and swollen eyes, so TBH I didn’t read it all in detail, but…

looks to me like what you’re missing is a Context/path entry in Tomcat/conf/server.xml, so for the Host element of that site, you want to add something like:

<Context path="/my_site" docBase="C:/inetpub/wwwroot/websites/my_site" />

and restart Tomcat for the changes to take effect.

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/

On 6/20/2015 3:06 PM, pat forbes wrote:

I am really sorry, but I’ve about goggled myself to death, my eyes are swollen, and my fingers are bleeding.

I have tried this with Lucee and now Railo 4.2.1.008 (windows 2008 and IIS7)

To add a “virtual directory” in IIS7, all that’s needed is to:

  1. Right click the “Default Web site”,
  2. Select the “Add Virtual Directory”,
  3. Put the name in the Alias field (ie, “my_site”)
  4. Add the Physical Path (C:\inetpub\wwwroot\websites\my_site)

and bada bing, it’s done… ready to be used.

I can go to http://localhost/my_site/index.htm and it displays fine

But if I put a cfm file in that folder and go to http://localhost/my_site/index.cfm, using .cfm instead of .htm) I get an error:
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not found.

That is is NOT where the file is… it should have been:
C:\inetpub\wwwroot\websites\my_site\index.cfm
It should have said: c:\inetpub\wwwroot\my_site\index.cfm

It appears that Railo/Lucee is not using the same virtual dir that was setup in IIS7.

Railo/Lucee thinks the vittual dir is c:\inetpub\wwwroot\my_site
and IIS7 thinks it is C:\inetpub\wwwroot\websites\my_site (where it actually is)

If I put ANY htm file in C:\inetpub\wwwroot\websites\my_site, it will display with localhost/my_site/filename.htm

But if I put ANY cfm file in C:\inetpub\wwwroot\websites\my_site, and try to use localhost/my_site/filename.cfm I’ll get the error.

btw: If I move the folder to C:\inetpub\wwwroot\my_site and set the Physical Path (C:\inetpub\wwwroot\my_site) everything works.

I just don’t understand why a cfm file will not display if it’s in a sub directory (ie c:\inetpub\wwwroot\websites)

It’s like IIS7 handles the alias ok, but Railo/Lucee needs another setting so that it maps to the correct folder.

What am missing?

btw: I’ve been coding CFML since it was version .9 (yep, point 9)

-pat-


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the Google Groups “Lucee” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/lucee/0bQpWRQLiFY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/002f01d0abb1%24ca972ad0%245fc58070%24%40westhold.com https://groups.google.com/d/msgid/lucee/002f01d0abb1%24ca972ad0%245fc58070%24%40westhold.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/3D1D845D-0F7F-4D69-8BBF-80269E59C7BF%40silowebworks.com https://groups.google.com/d/msgid/lucee/3D1D845D-0F7F-4D69-8BBF-80269E59C7BF%40silowebworks.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/5585FA4C.6090406%40lucee.org https://groups.google.com/d/msgid/lucee/5585FA4C.6090406%40lucee.org?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the Google Groups “Lucee” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/lucee/0bQpWRQLiFY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/EED41C88-3824-4CF2-AD91-1D0EBA183CEB%40silowebworks.com https://groups.google.com/d/msgid/lucee/EED41C88-3824-4CF2-AD91-1D0EBA183CEB%40silowebworks.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/004801d0abb6%2468e8cff0%243aba6fd0%24%40westhold.com https://groups.google.com/d/msgid/lucee/004801d0abb6%2468e8cff0%243aba6fd0%24%40westhold.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the Google Groups “Lucee” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/lucee/0bQpWRQLiFY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/5586020D.6070907%40lucee.org https://groups.google.com/d/msgid/lucee/5586020D.6070907%40lucee.org?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.

localhost/websites/my_site/index.cfm

Exact same issue

But if I go to localhost/websites/my_site/index.htm it works

It’s just the cfm files that don’t seem to get mapped correctlyFrom: lucee@googlegroups.com [mailto:lucee@googlegroups.com] On Behalf Of Igal @ Lucee.org
Sent: Saturday, June 20, 2015 7:15 PM
To: lucee@googlegroups.com
Subject: Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

what happens when you go to localhost/websites/my_site/index.cfm ? does it work then or do you get the same issue?

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/

On 6/20/2015 5:08 PM, @pat_forbes wrote:

Thank you.

Re-iterating

Folder is “c:\inetpub\wwwroot\websites\my_site”

IIs7 Alias is “my_site”

localhost/my_site/index.htm WORKS

localhost/my_site/index.cfm FAILS

Any htm, txt, etc in my_site works,

any cfm fails

There has to be a setting somewhere that I am missing.

From: lucee@googlegroups.com [mailto:lucee@googlegroups.com] On Behalf Of Jon Clausen
Sent: Saturday, June 20, 2015 7:01 PM
To: lucee@googlegroups.com
Subject: Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

Oh, crud. You’re right Igal. Disregard, Pat, since you’re on Windows. I know there’s an alternate setting for this as a workaround for Windows, but I’m away from a computer at the moment. Let me check in a bit and get back to you, Pat.

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:42 PM, Igal @ Lucee.org <@Igal> wrote:

@Jon, this is from the Tomcat 7 docs:

https://tomcat.apache.org/tomcat-7.0-doc/config/context.html#Common_Attributes

“NOTE: This flag MUST NOT be set to true on the Windows platform (or any other OS which does not have a case sensitive filesystem), as it will disable case sensitivity checks, allowing JSP source code disclosure, among other security problems.”

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/

On 6/20/2015 4:38 PM, Jon Clausen wrote:

No problem. Inside the Context tag:

https://tomcat.apache.org/tomcat-5.5-doc/config/context.html

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:35 PM, <@pat_forbes> <@pat_forbes> wrote:

I’m not seeing where this goes in context.xml

<!-- Default set of monitored resources -->

<WatchedResource>WEB-INF/web.xml</WatchedResource>



<!-- Uncomment this to disable session persistence across Tomcat restarts -->

<!--

<Manager pathname="" />

-->



<!-- Uncomment this to enable Comet connection tacking (provides events

     on session expiration as well as webapp lifecycle) -->

<!--

<Valve className="org.apache.catalina.valves.CometConnectionManagerValve" />

-->

I’m really sorry for being able to get this.

-pat-

From: lucee@googlegroups.com [mailto:lucee@googlegroups.com] On Behalf Of Jon Clausen
Sent: Saturday, June 20, 2015 6:29 PM
To: lucee@googlegroups.com
Subject: Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

I think you need the “allowLinking” attribute in your Tomcat context config:

allowLinking=“true”

HTH,

Jon

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:19 PM, pat forbes <@pat_forbes> wrote:

btw: if i create a dummy.htm, a dummy.txt, and a dummy.cfm (all three the exact same with one line

you are in dummy


If I use http://localhost/my_site/dummy.htm --> it works
If I use http://localhost/my_site/dummy.txt --> it works
If I use http://localhost/my_site/dummy.cfm --> it fails with:
Message Page /my_site/dummy.cfm (c:\inetpub\wwwroot\my_site\dummy.cfm) not found.

On Saturday, June 20, 2015 at 6:14:49 PM UTC-5, pat forbes wrote:

Thank you for your reply.
Yep… I did type a lot. I wanted to make sure I explained it. Probably too wordy :slight_smile:

I added the context path to the existing entry in server.xml like this:

  <Host name="localhost" appBase="webapps">
    <Context path="" docBase="C:\inetpub\wwwroot\" />
    <Context path="/my_site" docBase="C:/inetpub/wwwroot/websites/my_site" />
  </Host>

and then restarted Tomcat
but I get the exact same error:

It still shows
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not found.

It stll thinks my_site is a sub folder of c:\inetpub\wwwroot"
when its actually c:\inetpub\wwwroot\websites

-pat-

On Saturday, June 20, 2015 at 5:14:26 PM UTC-5, Igal wrote:

you managed to type quite a bit with bleeding fingers and swollen eyes, so TBH I didn’t read it all in detail, but…

looks to me like what you’re missing is a Context/path entry in Tomcat/conf/server.xml, so for the Host element of that site, you want to add something like:

<Context path="/my_site" docBase="C:/inetpub/wwwroot/websites/my_site" />

and restart Tomcat for the changes to take effect.

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/

On 6/20/2015 3:06 PM, pat forbes wrote:

I am really sorry, but I’ve about goggled myself to death, my eyes are swollen, and my fingers are bleeding.

I have tried this with Lucee and now Railo 4.2.1.008 (windows 2008 and IIS7)

To add a “virtual directory” in IIS7, all that’s needed is to:

  1. Right click the “Default Web site”,
  2. Select the “Add Virtual Directory”,
  3. Put the name in the Alias field (ie, “my_site”)
  4. Add the Physical Path (C:\inetpub\wwwroot\websites\my_site)

and bada bing, it’s done… ready to be used.

I can go to http://localhost/my_site/index.htm and it displays fine

But if I put a cfm file in that folder and go to http://localhost/my_site/index.cfm, using .cfm instead of .htm) I get an error:
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not found.

That is is NOT where the file is… it should have been:
C:\inetpub\wwwroot\websites\my_site\index.cfm
It should have said: c:\inetpub\wwwroot\my_site\index.cfm

It appears that Railo/Lucee is not using the same virtual dir that was setup in IIS7.

Railo/Lucee thinks the vittual dir is c:\inetpub\wwwroot\my_site
and IIS7 thinks it is C:\inetpub\wwwroot\websites\my_site (where it actually is)

If I put ANY htm file in C:\inetpub\wwwroot\websites\my_site, it will display with localhost/my_site/filename.htm

But if I put ANY cfm file in C:\inetpub\wwwroot\websites\my_site, and try to use localhost/my_site/filename.cfm I’ll get the error.

btw: If I move the folder to C:\inetpub\wwwroot\my_site and set the Physical Path (C:\inetpub\wwwroot\my_site) everything works.

I just don’t understand why a cfm file will not display if it’s in a sub directory (ie c:\inetpub\wwwroot\websites)

It’s like IIS7 handles the alias ok, but Railo/Lucee needs another setting so that it maps to the correct folder.

What am missing?

btw: I’ve been coding CFML since it was version .9 (yep, point 9)

-pat-


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the Google Groups “Lucee” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/lucee/0bQpWRQLiFY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/002f01d0abb1%24ca972ad0%245fc58070%24%40westhold.com https://groups.google.com/d/msgid/lucee/002f01d0abb1%24ca972ad0%245fc58070%24%40westhold.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/3D1D845D-0F7F-4D69-8BBF-80269E59C7BF%40silowebworks.com https://groups.google.com/d/msgid/lucee/3D1D845D-0F7F-4D69-8BBF-80269E59C7BF%40silowebworks.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/5585FA4C.6090406%40lucee.org https://groups.google.com/d/msgid/lucee/5585FA4C.6090406%40lucee.org?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the Google Groups “Lucee” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/lucee/0bQpWRQLiFY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/EED41C88-3824-4CF2-AD91-1D0EBA183CEB%40silowebworks.com https://groups.google.com/d/msgid/lucee/EED41C88-3824-4CF2-AD91-1D0EBA183CEB%40silowebworks.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/004801d0abb6%2468e8cff0%243aba6fd0%24%40westhold.com https://groups.google.com/d/msgid/lucee/004801d0abb6%2468e8cff0%243aba6fd0%24%40westhold.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the Google Groups “Lucee” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/lucee/0bQpWRQLiFY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/5586020D.6070907%40lucee.org https://groups.google.com/d/msgid/lucee/5586020D.6070907%40lucee.org?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.

Thank you.

Re-iterating

Folder is “c:\inetpub\wwwroot\websites\my_site”

IIs7 Alias is “my_site”

localhost/my_site/index.htm WORKS

localhost/my_site/index.cfm FAILS

Any htm, txt, etc in my_site works,

any cfm fails

There has to be a setting somewhere that I am missing.From: lucee@googlegroups.com [mailto:lucee@googlegroups.com] On Behalf Of Jon Clausen
Sent: Saturday, June 20, 2015 7:01 PM
To: lucee@googlegroups.com
Subject: Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

Oh, crud. You’re right Igal. Disregard, Pat, since you’re on Windows. I know there’s an alternate setting for this as a workaround for Windows, but I’m away from a computer at the moment. Let me check in a bit and get back to you, Pat.

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:42 PM, Igal @ Lucee.org <@Igal> wrote:

@Jon, this is from the Tomcat 7 docs:

https://tomcat.apache.org/tomcat-7.0-doc/config/context.html#Common_Attributes

“NOTE: This flag MUST NOT be set to true on the Windows platform (or any other OS which does not have a case sensitive filesystem), as it will disable case sensitivity checks, allowing JSP source code disclosure, among other security problems.”

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/

On 6/20/2015 4:38 PM, Jon Clausen wrote:

No problem. Inside the Context tag:

https://tomcat.apache.org/tomcat-5.5-doc/config/context.html

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:35 PM, <@pat_forbes> <@pat_forbes> wrote:

I’m not seeing where this goes in context.xml

<!-- Default set of monitored resources -->

<WatchedResource>WEB-INF/web.xml</WatchedResource>



<!-- Uncomment this to disable session persistence across Tomcat restarts -->

<!--

<Manager pathname="" />

-->



<!-- Uncomment this to enable Comet connection tacking (provides events

     on session expiration as well as webapp lifecycle) -->

<!--

<Valve className="org.apache.catalina.valves.CometConnectionManagerValve" />

-->

I’m really sorry for being able to get this.

-pat-

From: lucee@googlegroups.com [mailto:lucee@googlegroups.com] On Behalf Of Jon Clausen
Sent: Saturday, June 20, 2015 6:29 PM
To: lucee@googlegroups.com
Subject: Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

I think you need the “allowLinking” attribute in your Tomcat context config:

allowLinking=“true”

HTH,

Jon

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:19 PM, pat forbes <@pat_forbes> wrote:

btw: if i create a dummy.htm, a dummy.txt, and a dummy.cfm (all three the exact same with one line

you are in dummy


If I use http://localhost/my_site/dummy.htm --> it works
If I use http://localhost/my_site/dummy.txt --> it works
If I use http://localhost/my_site/dummy.cfm --> it fails with:
Message Page /my_site/dummy.cfm (c:\inetpub\wwwroot\my_site\dummy.cfm) not found.

On Saturday, June 20, 2015 at 6:14:49 PM UTC-5, pat forbes wrote:

Thank you for your reply.
Yep… I did type a lot. I wanted to make sure I explained it. Probably too wordy :slight_smile:

I added the context path to the existing entry in server.xml like this:

  <Host name="localhost" appBase="webapps">
    <Context path="" docBase="C:\inetpub\wwwroot\" />
    <Context path="/my_site" docBase="C:/inetpub/wwwroot/websites/my_site" />
  </Host>

and then restarted Tomcat
but I get the exact same error:

It still shows
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not found.

It stll thinks my_site is a sub folder of c:\inetpub\wwwroot"
when its actually c:\inetpub\wwwroot\websites

-pat-

On Saturday, June 20, 2015 at 5:14:26 PM UTC-5, Igal wrote:

you managed to type quite a bit with bleeding fingers and swollen eyes, so TBH I didn’t read it all in detail, but…

looks to me like what you’re missing is a Context/path entry in Tomcat/conf/server.xml, so for the Host element of that site, you want to add something like:

<Context path="/my_site" docBase="C:/inetpub/wwwroot/websites/my_site" />

and restart Tomcat for the changes to take effect.

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/

On 6/20/2015 3:06 PM, pat forbes wrote:

I am really sorry, but I’ve about goggled myself to death, my eyes are swollen, and my fingers are bleeding.

I have tried this with Lucee and now Railo 4.2.1.008 (windows 2008 and IIS7)

To add a “virtual directory” in IIS7, all that’s needed is to:

  1. Right click the “Default Web site”,
  2. Select the “Add Virtual Directory”,
  3. Put the name in the Alias field (ie, “my_site”)
  4. Add the Physical Path (C:\inetpub\wwwroot\websites\my_site)

and bada bing, it’s done… ready to be used.

I can go to http://localhost/my_site/index.htm and it displays fine

But if I put a cfm file in that folder and go to http://localhost/my_site/index.cfm, using .cfm instead of .htm) I get an error:
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not found.

That is is NOT where the file is… it should have been:
C:\inetpub\wwwroot\websites\my_site\index.cfm
It should have said: c:\inetpub\wwwroot\my_site\index.cfm

It appears that Railo/Lucee is not using the same virtual dir that was setup in IIS7.

Railo/Lucee thinks the vittual dir is c:\inetpub\wwwroot\my_site
and IIS7 thinks it is C:\inetpub\wwwroot\websites\my_site (where it actually is)

If I put ANY htm file in C:\inetpub\wwwroot\websites\my_site, it will display with localhost/my_site/filename.htm

But if I put ANY cfm file in C:\inetpub\wwwroot\websites\my_site, and try to use localhost/my_site/filename.cfm I’ll get the error.

btw: If I move the folder to C:\inetpub\wwwroot\my_site and set the Physical Path (C:\inetpub\wwwroot\my_site) everything works.

I just don’t understand why a cfm file will not display if it’s in a sub directory (ie c:\inetpub\wwwroot\websites)

It’s like IIS7 handles the alias ok, but Railo/Lucee needs another setting so that it maps to the correct folder.

What am missing?

btw: I’ve been coding CFML since it was version .9 (yep, point 9)

-pat-


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the Google Groups “Lucee” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/lucee/0bQpWRQLiFY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/002f01d0abb1%24ca972ad0%245fc58070%24%40westhold.com https://groups.google.com/d/msgid/lucee/002f01d0abb1%24ca972ad0%245fc58070%24%40westhold.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/3D1D845D-0F7F-4D69-8BBF-80269E59C7BF%40silowebworks.com https://groups.google.com/d/msgid/lucee/3D1D845D-0F7F-4D69-8BBF-80269E59C7BF%40silowebworks.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/5585FA4C.6090406%40lucee.org https://groups.google.com/d/msgid/lucee/5585FA4C.6090406%40lucee.org?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the Google Groups “Lucee” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/lucee/0bQpWRQLiFY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/EED41C88-3824-4CF2-AD91-1D0EBA183CEB%40silowebworks.com https://groups.google.com/d/msgid/lucee/EED41C88-3824-4CF2-AD91-1D0EBA183CEB%40silowebworks.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.

If I put in c:\inetpub\my_site - DOESN’T WORK

If I put in c:\railo\tomcat\webapps\ROOT\websites\my_site – DOESN’T WORK

If I put in c:\inetpub\wwwroot\my_site it DOES work

But I already knew that c:\inetpub\wwwroot\my_site would work – I just didn’t understand why c:\inetpub\wwwroot\websites\my_site would not workFrom: lucee@googlegroups.com [mailto:lucee@googlegroups.com] On Behalf Of Igal @ Lucee.org
Sent: Saturday, June 20, 2015 7:07 PM
To: lucee@googlegroups.com
Subject: Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

@Pat

I’m pretty sure that it will work if you put your physical path outside the root path of the context. the nesting of these “sites” seem to mess it up.

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/

On 6/20/2015 5:00 PM, Jon Clausen wrote:

Oh, crud. You’re right Igal. Disregard, Pat, since you’re on Windows. I know there’s an alternate setting for this as a workaround for Windows, but I’m away from a computer at the moment. Let me check in a bit and get back to you, Pat.

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:42 PM, Igal @ Lucee.org <@Igal> wrote:

@Jon, this is from the Tomcat 7 docs:

https://tomcat.apache.org/tomcat-7.0-doc/config/context.html#Common_Attributes

“NOTE: This flag MUST NOT be set to true on the Windows platform (or any other OS which does not have a case sensitive filesystem), as it will disable case sensitivity checks, allowing JSP source code disclosure, among other security problems.”

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/

On 6/20/2015 4:38 PM, Jon Clausen wrote:

No problem. Inside the Context tag:

https://tomcat.apache.org/tomcat-5.5-doc/config/context.html

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:35 PM, <@pat_forbes> <@pat_forbes> wrote:

I’m not seeing where this goes in context.xml

<!-- Default set of monitored resources -->

<WatchedResource>WEB-INF/web.xml</WatchedResource>



<!-- Uncomment this to disable session persistence across Tomcat restarts -->

<!--

<Manager pathname="" />

-->



<!-- Uncomment this to enable Comet connection tacking (provides events

     on session expiration as well as webapp lifecycle) -->

<!--

<Valve className="org.apache.catalina.valves.CometConnectionManagerValve" />

-->

I’m really sorry for being able to get this.

-pat-

From: lucee@googlegroups.com [mailto:lucee@googlegroups.com] On Behalf Of Jon Clausen
Sent: Saturday, June 20, 2015 6:29 PM
To: lucee@googlegroups.com
Subject: Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

I think you need the “allowLinking” attribute in your Tomcat context config:

allowLinking=“true”

HTH,

Jon

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:19 PM, pat forbes <@pat_forbes> wrote:

btw: if i create a dummy.htm, a dummy.txt, and a dummy.cfm (all three the exact same with one line

you are in dummy


If I use http://localhost/my_site/dummy.htm --> it works
If I use http://localhost/my_site/dummy.txt --> it works
If I use http://localhost/my_site/dummy.cfm --> it fails with:
Message Page /my_site/dummy.cfm (c:\inetpub\wwwroot\my_site\dummy.cfm) not found.

On Saturday, June 20, 2015 at 6:14:49 PM UTC-5, pat forbes wrote:

Thank you for your reply.
Yep… I did type a lot. I wanted to make sure I explained it. Probably too wordy :slight_smile:

I added the context path to the existing entry in server.xml like this:

  <Host name="localhost" appBase="webapps">
    <Context path="" docBase="C:\inetpub\wwwroot\" />
    <Context path="/my_site" docBase="C:/inetpub/wwwroot/websites/my_site" />
  </Host>

and then restarted Tomcat
but I get the exact same error:

It still shows
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not found.

It stll thinks my_site is a sub folder of c:\inetpub\wwwroot"
when its actually c:\inetpub\wwwroot\websites

-pat-

On Saturday, June 20, 2015 at 5:14:26 PM UTC-5, Igal wrote:

you managed to type quite a bit with bleeding fingers and swollen eyes, so TBH I didn’t read it all in detail, but…

looks to me like what you’re missing is a Context/path entry in Tomcat/conf/server.xml, so for the Host element of that site, you want to add something like:

<Context path="/my_site" docBase="C:/inetpub/wwwroot/websites/my_site" />

and restart Tomcat for the changes to take effect.

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/

On 6/20/2015 3:06 PM, pat forbes wrote:

I am really sorry, but I’ve about goggled myself to death, my eyes are swollen, and my fingers are bleeding.

I have tried this with Lucee and now Railo 4.2.1.008 (windows 2008 and IIS7)

To add a “virtual directory” in IIS7, all that’s needed is to:

  1. Right click the “Default Web site”,
  2. Select the “Add Virtual Directory”,
  3. Put the name in the Alias field (ie, “my_site”)
  4. Add the Physical Path (C:\inetpub\wwwroot\websites\my_site)

and bada bing, it’s done… ready to be used.

I can go to http://localhost/my_site/index.htm and it displays fine

But if I put a cfm file in that folder and go to http://localhost/my_site/index.cfm, using .cfm instead of .htm) I get an error:
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm (c:\inetpub\wwwroot\my_site\index.cfm) not found.

That is is NOT where the file is… it should have been:
C:\inetpub\wwwroot\websites\my_site\index.cfm
It should have said: c:\inetpub\wwwroot\my_site\index.cfm

It appears that Railo/Lucee is not using the same virtual dir that was setup in IIS7.

Railo/Lucee thinks the vittual dir is c:\inetpub\wwwroot\my_site
and IIS7 thinks it is C:\inetpub\wwwroot\websites\my_site (where it actually is)

If I put ANY htm file in C:\inetpub\wwwroot\websites\my_site, it will display with localhost/my_site/filename.htm

But if I put ANY cfm file in C:\inetpub\wwwroot\websites\my_site, and try to use localhost/my_site/filename.cfm I’ll get the error.

btw: If I move the folder to C:\inetpub\wwwroot\my_site and set the Physical Path (C:\inetpub\wwwroot\my_site) everything works.

I just don’t understand why a cfm file will not display if it’s in a sub directory (ie c:\inetpub\wwwroot\websites)

It’s like IIS7 handles the alias ok, but Railo/Lucee needs another setting so that it maps to the correct folder.

What am missing?

btw: I’ve been coding CFML since it was version .9 (yep, point 9)

-pat-


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the Google Groups “Lucee” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/lucee/0bQpWRQLiFY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/002f01d0abb1%24ca972ad0%245fc58070%24%40westhold.com https://groups.google.com/d/msgid/lucee/002f01d0abb1%24ca972ad0%245fc58070%24%40westhold.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/3D1D845D-0F7F-4D69-8BBF-80269E59C7BF%40silowebworks.com https://groups.google.com/d/msgid/lucee/3D1D845D-0F7F-4D69-8BBF-80269E59C7BF%40silowebworks.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/5585FA4C.6090406%40lucee.org https://groups.google.com/d/msgid/lucee/5585FA4C.6090406%40lucee.org?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/EED41C88-3824-4CF2-AD91-1D0EBA183CEB%40silowebworks.com https://groups.google.com/d/msgid/lucee/EED41C88-3824-4CF2-AD91-1D0EBA183CEB%40silowebworks.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the Google Groups “Lucee” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/lucee/0bQpWRQLiFY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/55860041.7040900%40lucee.org https://groups.google.com/d/msgid/lucee/55860041.7040900%40lucee.org?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.

I didn’t find any references to what I am trying to do. I am googled out…

I went ahead and moved all of the sub directories into the c:\inetpub\wwroot directory and everything worked.-----Original Message-----
From: lucee@googlegroups.com [mailto:lucee@googlegroups.com] On Behalf Of Bilal
Sent: Sunday, June 21, 2015 3:32 PM
To: lucee@googlegroups.com
Subject: RE: [Lucee] Virtual Dir in Railo/Lucee and IIS7

The easiest way to represent virtual directories is to do railo / lucee application mapping.
Please google this group or the previous railo one.
There should be quite a few examples.

Your application server is not going to recognize/pick-up IIS virtual
directories. Your HTTP requests are going to IIS and then sending off all
cfm/cfc to Lucee/Tomcat to interpret. So, your Virtual Directories are
respected by all non-cf requests, but the cf requests will look for those
files in whatever folder you told Tomcat to look for them.

I don’t ever use IIS, so I don’t know how things get wired up, but I would
try adding an entry to your hosts file, e.g.:

127.0.0.1 dev.my_site.com

and then add a separate entry to the Tomcat server.xml like so:



Setup the same hostname in IIS and then restart Tomcat and you should be
good to go when you hit dev.my_site.comOn Saturday, June 20, 2015 at 6:03:52 PM UTC-7, pat forbes wrote:

I take that back…

localhost/websites/my_site/index.htm

localhost/websites/my_site/index.cfm

both generate 500.23 internal server errors

email resent to clean up the posts

I take that back…

localhost/websites/my_site/index.htm

localhost/websites/my_site/index.cfm

both generate 500.23 internal server errors

email resent to clean up the posts

@Pat

I’m pretty sure that it will work if you put your physical path outside
the root path of the context. the nesting of these “sites” seem to mess
it up.

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/On 6/20/2015 5:00 PM, Jon Clausen wrote:

Oh, crud. You’re right Igal. Disregard, Pat, since you’re on Windows.
I know there’s an alternate setting for this as a workaround for
Windows, but I’m away from a computer at the moment. Let me check in
a bit and get back to you, Pat.

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:42 PM, Igal @ Lucee.org http://Lucee.org <@Igal mailto:Igal> wrote:

@Jon, this is from the Tomcat 7 docs:

https://tomcat.apache.org/tomcat-7.0-doc/config/context.html#Common_Attributes

“*NOTE: This flag MUST NOT be set to true on the Windows platform (or
any other OS which does not have a case sensitive filesystem), as it
will disable case sensitivity checks, allowing JSP source code
disclosure, among other security problems.”

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/

On 6/20/2015 4:38 PM, Jon Clausen wrote:

No problem. Inside the Context tag:

https://tomcat.apache.org/tomcat-5.5-doc/config/context.html

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:35 PM, <@pat_forbes mailto:pat_forbes> <@pat_forbes mailto:pat_forbes> wrote:

I’m not seeing where this goes in context.xml

<!-- Default set of monitored resources -->

<WatchedResource>WEB-INF/web.xml</WatchedResource>



<!-- Uncomment this to disable session persistence across

Tomcat restarts -->

<!--

<Manager pathname="" />

-->



<!-- Uncomment this to enable Comet connection tacking

(provides events

     on session expiration as well as webapp lifecycle) -->

<!--

<Valve

className=“org.apache.catalina.valves.CometConnectionManagerValve” />

-->

I’m really sorry for being able to get this.

-pat-

*From:*lucee@googlegroups.com mailto:lucee@googlegroups.com
[mailto:lucee@googlegroups.com] *On Behalf Of *Jon Clausen
Sent: Saturday, June 20, 2015 6:29 PM
To: lucee@googlegroups.com mailto:lucee@googlegroups.com
Subject: Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

I think you need the “allowLinking” attribute in your Tomcat
context config:

allowLinking=“true”

HTH,

Jon

[Note: Typo assistance courtesy of iPhone]

On Jun 20, 2015, at 7:19 PM, pat forbes <@pat_forbes mailto:pat_forbes> wrote:

btw: if i create a dummy.htm, a dummy.txt, and a dummy.cfm (all
three the exact same with one line<h2>you are in dummy</h2>
If I use http://localhost/my_site/dummy.htm --> it works
If I use http://localhost/my_site/dummy.txt --> it works
If I use http://localhost/my_site/dummy.cfm --> it fails with:
Message Page /my_site/dummy.cfm
(c:\inetpub\wwwroot\my_site\dummy.cfm) not found.

On Saturday, June 20, 2015 at 6:14:49 PM UTC-5, pat forbes wrote:

Thank you for your reply.
Yep... I did type a lot.  I wanted to make sure I explained
it.  Probably too wordy :)

I added  the context path to the existing entry in server.xml
like this:

      <Host name="localhost" appBase="webapps">
        <Context path="" docBase="C:\inetpub\wwwroot\" />
        <Context path="/my_site"
docBase="C:/inetpub/wwwroot/websites/my_site" />
      </Host>

and then restarted Tomcat
but I get the exact same error:

It still shows
Railo 4.2.1.008 Error (missinginclude)
Message Page /my_site/index.cfm
(c:\inetpub\wwwroot\my_site\index.cfm) not found.

It stll thinks my_site is a sub folder of c:\inetpub\wwwroot\"
when its actually c:\inetpub\wwwroot\websites

-pat-


On Saturday, June 20, 2015 at 5:14:26 PM UTC-5, Igal wrote:

you managed to type quite a bit with bleeding fingers and
swollen eyes, so TBH I didn't read it all in detail, but...

looks to me like what you're missing is a Context/path entry in
Tomcat/conf/server.xml, so for the Host element of that site,
you want to add something like:

    <Context path="/my_site"
docBase="C:/inetpub/wwwroot/websites/my_site" />

and restart Tomcat for the changes to take effect.

Igal Sapir
Lucee Core Developer
Lucee.org <http://lucee.org/>

On 6/20/2015 3:06 PM, pat forbes wrote:

    I am really sorry, but I've about goggled myself to death,
    my eyes are swollen, and my fingers are bleeding.

    I have tried this with Lucee and now Railo 4.2.1.008
    (windows 2008 and IIS7)

    To add a "virtual directory" in IIS7, all that's needed is to:
    1. Right click the "Default Web site",
    2. Select the "Add Virtual Directory",
    3. Put the name in the Alias field (ie, "my_site")
    4. Add the Physical Path (C:\inetpub\wwwroot\websites\my_site)

    and bada bing, it's done... ready to be used.

    I can go to http://localhost/my_site/index.htm and it
    displays fine

    But if I put a cfm file in that folder and go to
    http://localhost/my_site/index.cfm, using .cfm instead of
    .htm) I get an error:
    Railo 4.2.1.008 Error (missinginclude)
    Message Page /my_site/index.cfm
    (c:\inetpub\wwwroot\my_site\index.cfm) not found.

    That is is NOT where the file is... it should have been:
    C:\inetpub\wwwroot\websites\my_site\index.cfm
    It should have said: c:\inetpub\wwwroot\my_site\index.cfm

    It appears that Railo/Lucee is not using the same virtual
    dir that was setup in IIS7.

    Railo/Lucee thinks the vittual dir is
    c:\inetpub\wwwroot\my_site
    and IIS7 thinks it is C:\inetpub\wwwroot\websites\my_site
    (where it actually is)

    If I put ANY htm file in
    C:\inetpub\wwwroot\websites\my_site, it will display with
    localhost/my_site/filename.htm

    But if I put ANY cfm file in
    C:\inetpub\wwwroot\websites\my_site, and try to use
    localhost/my_site/filename.cfm I'll get the error.

    btw: If I move the folder to C:\inetpub\wwwroot\my_site and
    set the Physical Path (C:\inetpub\wwwroot\my_site)
    everything works.

    I just don't understand why a cfm file will not display if
    it's in a sub directory (ie c:\inetpub\wwwroot\websites)

    It's like IIS7 handles the alias ok, but Railo/Lucee needs
    another setting so that it maps to the correct folder.

    What am missing?

    btw: I've been coding CFML since it was version .9  (yep,
    point 9)

    -pat-




    -- 
    You received this message because you are subscribed to the
    Google Groups "Lucee" group.
    To unsubscribe from this group and stop receiving emails
    from it, send an email to lucee+un...@googlegroups.com
    <mailto:lucee+un...@googlegroups.com>.
    To post to this group, send email to lu...@googlegroups.com
    <mailto:lu...@googlegroups.com>.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com
    <https://groups.google.com/d/msgid/lucee/cbc06aca-7ad9-44bb-8d2e-428e682fdd2b%40googlegroups.com?utm_medium=email&utm_source=footer>.
    For more options, visit https://groups.google.com/d/optout.

 

-- 
You received this message because you are subscribed to the
Google Groups "Lucee" group.
To unsubscribe from this group and stop receiving emails from
it, send an email to lucee+unsubscribe@googlegroups.com
<mailto:lucee+unsubscribe@googlegroups.com>.
To post to this group, send email to lucee@googlegroups.com
<mailto:lucee@googlegroups.com>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com
<https://groups.google.com/d/msgid/lucee/0e90d4f0-b01c-47af-841e-4ee6e4243d92%40googlegroups.com?utm_medium=email&utm_source=footer>.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in
the Google Groups “Lucee” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/lucee/0bQpWRQLiFY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
lucee+unsubscribe@googlegroups.com
mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com
mailto:lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com
https://groups.google.com/d/msgid/lucee/08875A21-B43E-4D32-9F2B-C7CD9E01D3A8%40silowebworks.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it,
send an email to lucee+unsubscribe@googlegroups.com
mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com
mailto:lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/002f01d0abb1%24ca972ad0%245fc58070%24%40westhold.com
https://groups.google.com/d/msgid/lucee/002f01d0abb1%24ca972ad0%245fc58070%24%40westhold.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it,
send an email to lucee+unsubscribe@googlegroups.com
mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com
mailto:lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/3D1D845D-0F7F-4D69-8BBF-80269E59C7BF%40silowebworks.com
https://groups.google.com/d/msgid/lucee/3D1D845D-0F7F-4D69-8BBF-80269E59C7BF%40silowebworks.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it,
send an email to lucee+unsubscribe@googlegroups.com
mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com
mailto:lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/5585FA4C.6090406%40lucee.org
https://groups.google.com/d/msgid/lucee/5585FA4C.6090406%40lucee.org?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to lucee+unsubscribe@googlegroups.com
mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com
mailto:lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/EED41C88-3824-4CF2-AD91-1D0EBA183CEB%40silowebworks.com
https://groups.google.com/d/msgid/lucee/EED41C88-3824-4CF2-AD91-1D0EBA183CEB%40silowebworks.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

The easiest way to represent virtual directories is to do railo / lucee application mapping.
Please google this group or the previous railo one.
There should be quite a few examples.

Unfortunately, I cannot use that method. I have dozens of sites but none are using domain names. All are referenced by the ip address.

Ie. 50.249.93.76/site1

Ie. 50.249.93.76/site2

Ie. 50.249.93.76/site3

etc

I can make it work if I move each of the sites from the websites dir to c:\inetpub\wwwroot for example:

c:\inetpub\wwwroot\site1

c:\inetpub\wwwroot\site2

c:\inetpub\wwwroot\site3

Then, IIS works as it should and, so does Railo/Lucee

I just didn’t want to have to move everything because they all share common files.

Thanks to everyone for their advice and help.From: lucee@googlegroups.com [mailto:lucee@googlegroups.com] On Behalf Of ADK
Sent: Saturday, June 20, 2015 9:50 PM
To: lucee@googlegroups.com
Subject: Re: [Lucee] Virtual Dir in Railo/Lucee and IIS7

Your application server is not going to recognize/pick-up IIS virtual directories. Your HTTP requests are going to IIS and then sending off all cfm/cfc to Lucee/Tomcat to interpret. So, your Virtual Directories are respected by all non-cf requests, but the cf requests will look for those files in whatever folder you told Tomcat to look for them.

I don’t ever use IIS, so I don’t know how things get wired up, but I would try adding an entry to your hosts file, e.g.:

127.0.0.1 dev.my_site.com

and then add a separate entry to the Tomcat server.xml like so:

Setup the same hostname in IIS and then restart Tomcat and you should be good to go when you hit dev.my_site.com